Ventura Automator Bug: Converting a workflow to an App corrupts the resulting App

When converting an. Automator workflow to an Application the resulting Application is corrupted and cannot be launched.

  • Create an Automator workflow and save it.
  • Open the saved workflow and choose Conversion Tool under File
  • Convert it to an App
  • Save the App after first choosing Application instead of what appears in the box which is Workflow.

The result is a corrupted Automator application presenting itself with a circle with a diagonal line through it. The reason for this is that it is saved as an unpacked Application.

First convert the workflow to a Dictation Command, give it a name and save it. Then open the resulting file and then convert it to an App. I have no idea why it works but it does. You also may wish to open the Speakable Items folder in the Speech folder in your user library and delete the dictation file you temporarily created in the workaround.
~/Library/Speech/Speakable Items/

I have a related problem with Applescript and Ventura. Many, many years ago I created an app with Applescript to take a screen snapshot (using crosshairs), open GraphicConverter and create a new picture with the clipboard. The app is in my Dock and I simply click on it to start the process. I have used it nearly every day for years.
I just bought a Macbook Air M2 and tried to do the same. I opened the Applescript and save it as an app. The first steps worked but then I got an error message when trying to simulate keystrokes. I elected to fix this in System Settings and my new app appeared in the list.
However Ventura still wouldn’t let me run the app. It seems to “forget” that I have allowed the app to send keystrokes!
The Applescript is here