Ventura 13.6.3 Update Missing Dock

Just updated the OS on my Intel iMac18,1 to 13.6.3. and now my dock has been reduced to a very thin gray and black line across the bottom of the screen. I’ve tried using the System Settings Dock options to tweak/reset it’s behaviour, but nothing seems to change it.
Is anyone else having this problem? or know how to reset the dock?

Have you tried relaunching the Finder from the Force Quit item in the Apple Menu?

Thanks for your reply.
Just tried that didn’t change anything. I’m going to do a safe mode reboot and then come back and see if it still persists.

UPDATE: I booted into safe mode, and checked the dock—it was working properly. Reboot into normal mode and the problem was cleared. I never realized how much I relied on accessing things through the dock until it was there.

1 Like

I wonder if the dock’s size has been set to a too-small size. Can you adjust the size and magnification settings?

You may also want to read these values directly from the system defaults. They are in the domain. The size is the tilesize key and the maximum size (for magnification) is largesize. On my system (small size, large magnification), I see:

$ defaults read tilesize
$ defaults read largesize

If you’re seeing something impossible (e.g. a number less than 16 or greater than 128), see if you can reset the values by deleting the keys. Then restart the Dock:

$ deaults delete tilesize
$ deaults delete largesize
$ killall Dock

If that fails, you can also try deleting all of the Dock’s defaults:

$ defaults delete
$ killall Dock

But note that this will completely reset it. You’ll lose all configuration, including the list of icons you have placed there. So you’ll have to put them back again afterward.

h/t: How to reset the Mac Dock to default | iMore

1 Like

Thank you for the very detailed instructions. Although I was able to reset the dock by doing a safe mode reboot, I will squirrel this away for future reference.