USB Restricted Mode Can Block iOS Device Charging


(Josh Centers) #1

Originally published at: https://tidbits.com/2018/08/06/usb-restricted-mode-can-block-ios-device-charging/

USB Restricted Mode is a new security feature in iOS 11.4.1, but it can have some unintended consequences. Josh Centers explains what it is, how it works, why it exists, and how you can turn it off if necessary.


(Dennis Swaney) #2

Since I rely on charging my iDevices via the Lightning port, USB Restricted Mode (URM) WILL be disabled on any iDevice that has iOS 11.4 and greater. I use non-Apple 0.5 meter cables for overnight charging at home and when traveling I use a 4-USB port charger (so I don’t have to carry 4 individual chargers) to charge my iDevices. Apple needs to GUARANTEE that URM will be fixed to NEVER impede charging no matter who’s cables and chargers are used before I enable URM on my iDevices.


(John Burt) #3

Sounds like 60 minutes might be too long and explains why I have never had a problem. Might be nice to activate manually and in minutes actually. But my charging is at night and I routinely delete all unused apps before plugging it in.


(Al Varnell) #4

Note that charging from a charging only device should never be disabled by this feature. It absolutely has never been a problem for my iPad Pro or iPhone 7 using the charger that came with it.

When I plug them into my iMac after an hour, I’m informed that I need to unlock my phone and charging is disabled until I do that.

The difference being that chargers are not able to also access data, but the computer does. If the charging device cannot be positively identified as charge only, then it should be prevented, IMHO.

-Al-


(Doug Miller) #5

I believe that you can by pressing the sleep/wake button 5 times in succession (on TouchID iPhones) or squeeze the sleep/wake and one of the volume buttons (on the iPhone X) to completely lock the device from TouchID/FaceID.


(Dennis Swaney) #6

However, Apple said that use of non-Apple cables will not charge with URM enabled, but didn’t say whether or not the unlock notice is triggered. So you are using non-Apple cables and are getting the unlock notice?


(Jim Carr) #7

Dennis:

Not the OP.

I first noticed this new feature with a non-Apple iPhone device that allows both a USB cable with power plus a headphone cable to connect my iPhone 7 to my car.

Now I know why I got the popup message.

At least the device still works as intended.

Will eventually upgrade my 2010 car to work better with my next iPhone. :wink:

–Jim


(Adam Engst) #8

Are you being prompted to unlock your devices to charge with iOS 11.4.1? If not, there’s no win in turning off a security feature that isn’t hampering your everyday usage.

Also, with Touch ID and Face ID, unlocking your device often happens in the background when you’re not even thinking about it.


(Seth Anderson) #9

I suppose this is why I’ve never noticed problems with playing music/charging in my 2009 car: I tend to unlock the phone (check email, queue up songs, look up an address, etc.) right before I plug it in. If I could break my long-time habit, and wait 60 minutes, maybe I’d be able to trigger this message.

And as the article mentions, the Qi option of wirelessly charging works great (albeit slowly, but for an overnight charge, that’s no problem)


(Dennis Swaney) #10

Not yet, Adam. I’ve been staying away from iOS 11.4.1 and higher due to the other reported problems. My iPhone 10 is still on 11.2, while my iPad Mini 3 is on 10.x, and my iPad Mini 4 is on 11.4. I’m waiting to see how iOS 12 does next month before deciding to install it or wait for 12.1.


(Al Varnell) #11

I only have one non-Apple lightning cable and it did give me the notice when I plugged it in after over an hour of not being used. Further, although it said it was not charging my iPad, it actually was, just slow since the source apparently wasn’t supplying full iPad level wattage.


(Al Varnell) #12

I’ve not had any problems at all with 11.4.1 over 11.4, nor do I recall reading about any. Do you have a reference to such problems? I’d like to see if I can replicate them in case it’s something I don’t normally try.


(mpainesyd) #13

I raised this issue in another thread.

My concern was that my usual practice (for years) of dropping my iPhone into a Belkin charging dock resulted in the iPhone not charging overnight. I thought I had not docked it correctly but next time noticed the message that I needed to unlock the iPhone in order to charge it. I complained that this was an unannounced and pointless change with 11.4.1 but it was pointed out to me that Apple had “announced” it as part of the update. The security “feature” can be disabled, as Josh points out but I think that many people will be stuck with uncharged iPhones until they figure out the problem.

It is becoming increasingly frustrating that software we have become accustomed to suddenly changes its UI and simple actions have become more complicated. I had the same problem with Skype (Microsoft - say no more!) where the method of logging out became more tedious in a recent “update”.


(Adam Engst) #14

The silver lining to changes like this, from our perspective, is that people who see our coverage will learn these things! If Apple was documenting everything really well, there’d be much less reason for TidBITS to exist. :slight_smile:


(Dennis Swaney) #15

Al, I get the same “Not charging” indication even with Apple cables when I either connect to an USB port on my iMac or if I use a 5 watt Apple charger. Apple says you need to use a 10 watt minimum charger with iPads, but a 5 watt WILL charge them albeit more slowly as you discovered. My travel charger has two 1 Amp and two 2 Amp ports, so I can charge my iPad, iPhone, and Watch without lugging 3 separate chargers.


(Dennis Swaney) #16

Sorta of a “Missing Manual” supplement!


(Dennis Swaney) #17

Actually, the problems were when 11.4 was released and were discussed extensively regarding their effect. I did put 11.4 on my iPad Mini 4 but I don’t use it that much yet. It really is a backup to my Mini 3. I’m just being cautious with my daily use hardware.


(Diane D) #18

When did this update come out, and is there a way for me to know when I actually applied it?

I normally charge my phone nightly with an Anker PowerLine cable into an iPad charger. I transported both pieces on a trip 2.5 weeks ago with no issues and used them fine when I got back home. Last Friday I started a housesitting gig and brought them along with me, and it wouldn’t charge the phone. I tried the cable in my laptop and it wouldn’t work either. I plugged it in the car in the morning (Anker ultra-compact 24W 2 port charger with a connected lightning cable) and it worked fine.

After seeing pieces of this thread, I decided to pull the cable that failed out of my bag and try again at home. It still won’t charge, but twice I got 3 beeps/vibrates and a message to unlock the phone to use accessories. When I unlocked the phone, it still wasn’t charging.

I can charge the phone fine from an Apple cable into an Anker PowerPort 5

I can plug the Apple cable into the iPad charger and that works.

So it’s possible my Anker cable has failed… just trying to explore options before seeking a replacement.

Thanks
Diane


(Dennis Swaney) #19

It is part of the iOS 11.4.1 update released on 10 Jul 18. Did you install the update? If so, try going to Settings and disabling the USB Restriction. If your cables work, then that was the problem. If the cables still don’t work then you most likely either have bad cables or a bad Lightning port.


(Adam Engst) #20

You can always check your iOS version in Settings > General > About > Version.