Upgrade to Monterey! Now!

LOL, now I’m also getting the notification to install Monterey on my Late 2013 MBP that can’t run it.

macOS Notification: Upgrade to macOS Monterey. Get new FaceTime features, SharePlay, and Live Text.

1 Like

I get this too, on my “trashcan” Mac Pro running High Sierra. Fortunately, I just have to click the “Not Now” button to get rid of it until the next time. What’s more irritating to me is Apple’s pell-mell annual OS upgrade schedule, with “features” I don’t need that will break stuff I depend on right and left. I’d much rather see Apple put some of its hundreds of billions in cash toward issuing security updates for legacy systems, but that wouldn’t force us to buy new machines. I’m a luddite curmudgeon, I guess.

The difference between your situation, with a MacPro (Late 2013) and my situation, with a MacBook Pro (Mid-2014) is you can update to Monterey if you chose to do so. So one could at least justify Apple nagging you to do so, in the name of security. My MacBook Pro is unable to update to Monterey by Apple’s own rules, so why is Apple nagging me to update when they won’t allow me to?

Why doesn’t the same software algorithm that determines I can’t install Monterey also turn off the nagging notification?

I think that’s the point this thread is trying to make.


I finally updated my Big Sur installation on a 2019 iMac, to Monterey.
While I notice some subtle differences, for the moment (only two days in) I really don’t see anything that I could not do in Big Sur, in Monterey.
So, those who can’t update, you really ain’t missing much.

Rich the Weather Guy


I agree. I imagine the reason Apple keeps nagging the owners of ineligible machines is to prompt them to buy a new one.

1 Like

If so, then it worked in my case. As I mentioned earlier, I’m buying a new M2 MacBook Air as soon as I’m allowed. So my current behavior is reinforcing the very Apple policy I’m railing against. That’s unfortunate, he said sheepishly…

Well, even I am planning to buy an M2 MBAir but because my much older Air has bit the dust.
But like I said, update to Monterey, ho-hum.

Rich the weather guy

In looking for a screenshot online, I found Macworld had an article about this phenomenon in February.

It was also noted here, in passing, back in February, in the thread ‘MacOS Big Sur 11.6.4 and Security Update 2022-002 Catalina’.

Enjoy your M2 MB Air! Apple’s business is about selling hardware, so good on you. I remember the late '90s when Apple was about to die. Scary. Just wish I’d bought stock back then, when it was about $7/share! :)

I think I have the same model as you Curtis, but I’m still getting the notifications. Mind you, there is some rogue problem with my MacBook as it keeps saying it’s run out of space, sometimes just after startup, and also it restarts itself with a watchdog timer issue which is quite well-known but apparently incurable. I suspect these gremlins are there to make me buy a new machine, but sadly I haven’t got the budget. I do feel rather abandoned, even though Big Sur isn’t that old.

I realize you’re trying to solve an annoying notification but it is possible to install Monterey on your machine via community solutions such as the OpenCore Legacy Patcher( supported macs at link ). Mr. Macintosh, a well-known suppport site, has lengthy instructions and a detailed video. My 2009 MacBook runs Catalina just fine for basic computing using another hack from dosDude. There are caveats to this approach but it is an option for many. ymmv.

1 Like

It finally re-appeared; here is a quick video of what I see. (Again, this is on Mojave).


I recently upgraded my 2018 mac mini from Mojave to Monterey. I never got the nag for all the OS versions I skipped, but then I turn off auto update.

Monetary… that’s actually pretty funny. Was that just a typo, or were you making a joke? Either way, I like it.

In my opinion, it is just another example of Apple’s myopic greed. They think by constantly annoying you with non-dismissable upgrade messages they will get you to purchase a new machine out of frustration so that they can make more money, Unfortunately, it often works which is why they keep doing it. Recently they did it to my perfectly good and working iPhone 7 by announcing that they were stopping all updates and support for it. Since you cannot get older versions of software on the Apple Store in case I have an issue with an App or accidentally delete it, I was coerced to get a new phone. Since all I use the phone for is Mail, CarPlay, and making phone calls, I got an iPhone SE. Aside from being a bit faster and perhaps a sharper screen, it is identical. Apple’s claim of being environmentally friendly in my opinion is one big joke. The box of my MacPro Desktop 7.1 (a $10K machine that has not worked properly, for about a month since I got it over 2 years ago) almost required the use of a power saw to take it apart to get it into my recycle bin. When asked what they would do with my iPhone y I was told they would refurbish it and resell it to third-world countries. I find it outlandish that they would refurbish an obsolete product that can’t be updated, can’t run many Apps due to an old iOS, is unsupported for any long-term security updates is being resold to third-world generally poor countries who likely have no idea what they are really buying until they experience the issue with purchasing obsolete hardware or get slammed by hackers. Frankly, it would not surprise me to learn that some of these land up on the dark web as burner phones. If Apple was sincerely environmentally concerned the least they could do is do a trade-in at a reasonable price for an iPhone 7 refurb with updated circuitry for the continued support which is likely far more recyclable than an entire phone and doing it without attempting to make a profit by selling obsolete equipment to third world countries or possibly putting them in the hands of criminals.

1 Like

Apple’s timelines for upgrades are far superior to the to the two to four years offered by their Android competitors. Here’s examples of just the top two’s upgrade schedules

“ In addition to those security updates, Samsung offers four Android upgrades for a majority of its devices. The list of those devices can be found on Samsung’s websiteand it includes newer models from those series’ as well.)

“ Google doesn’t have nearly as many devices to worry about as Samsung, but they’re still not all treated the same. Support timelines for Pixel devices can be found here on Google’s website.”

Your iPhone 7 debuted in 2016 and received iOS upgrades until now:

Older devices might not have the hardware or be able to handle software that can handle the latest and greatest systems. Apple is a for profit company. They don’t charge for their operating system upgrades and they giveaway quite a few apps, including software upgrades, so hardware revenue streams are important to their bottom line.

Alright, no more posts apart from trying to figure out why some Macs get Monterey upgrade notices when they can’t upgrade and others don’t.

1 Like

This is reminiscent of behavior several years ago and discussed at The Eclectic Light Company:

Back then I ZIP’ed the file and removed the original – and the notifications stopped. With today’s system security removing that file would not be possible.

1 Like

Maybe not. I just looked on my Big Sur system.

The i option on the ls command shows each file/directory’s inode number. This is an index to a file system structure used internally to represent a file. inodes uniquely identify a file on a single volume, but files on different volumes may have the same inode numbers.

When Apple works its magic (volume groups, firmlinks, etc.) to make the System and Data volumes appear as a single volume, they prepend a 32-bit prefix onto the 32-bit inode numbers, in order to guarantee uniqueness. The upshot of this is that when you look at a running system, the files on your Data volume have inode numbers that fit within 32-bits (they have a zero-prefix), while files on your System volume have very large inode numbers (they have a non-trivial 32-bit prefix).

That having been said, look at the content of the Bundles directory:

$ cd /Library/Bundles
$ ls -lai
total 0
36431954 drwxr-xr-x   3 root  wheel    96 Dec 14  2021 .
42698335 drwxr-xr-x  76 root  wheel  2432 Jun 10 09:44 ..
36431955 drwxr-xr-x   3 root  wheel    96 Dec 14  2021 OSXNotification.bundle

Note that the inode numbers on the left side (e.g. 36431955) is a “small” number. That is, it fits within 32-bits (the maximum 32-bit number is 4,294,967,295, and these inode numbers are all smaller).

This means they live on the system’s Data volume, not the System volume. You might have to jump through a few hoops in order to delete the OSXNotification bundle, but the file doesn’t exist within the signed/sealed system volume, where it would truly be untouchable.

In contrast, look at the root directory:

$ ls -lai /
total 10
                  2 drwxr-xr-x  20 root  wheel   640 Jan  1  2020 .
                  2 drwxr-xr-x  20 root  wheel   640 Jan  1  2020 ..
1152921500311879696 lrwxr-xr-x   1 root  admin    36 Jan  1  2020 .VolumeIcon.icns -> System/Volumes/Data/.VolumeIcon.icns
1152921500311879697 ----------   1 root  admin     0 Jan  1  2020 .file
1152921500311879698 drwxr-xr-x   2 root  wheel    64 Jan  1  2020 .vol
           42721130 drwxrwxr-x  62 root  admin  1984 Jun 23 18:51 Applications
           42698335 drwxr-xr-x  76 root  wheel  2432 Jun 10 09:44 Library
1152921500311879701 drwxr-xr-x@  9 root  wheel   288 Jan  1  2020 System
              21335 drwxr-xr-x   9 root  admin   288 Jan  1  2020 Users
              23584 drwxr-xr-x   6 root  wheel   192 Jun 24 16:09 Volumes
1152921500312764509 drwxr-xr-x@ 38 root  wheel  1216 Jan  1  2020 bin
              23586 drwxr-xr-x   2 root  wheel    64 Jul  5  2020 cores
                314 dr-xr-xr-x   3 root  wheel  4638 Jun 20 09:34 dev
1152921500312764584 lrwxr-xr-x@  1 root  wheel    11 Jan  1  2020 etc -> private/etc
1152921504606781440 lrwxr-xr-x   1 root  wheel    25 Jun 20 09:34 home -> /System/Volumes/Data/home
              23583 drwxr-xr-x   4 root  wheel   128 Oct 18  2020 opt
           42720201 drwxr-xr-x   6 root  wheel   192 Jan  1  2020 private
1152921500312764587 drwxr-xr-x@ 65 root  wheel  2080 Jan  1  2020 sbin
1152921500312764692 lrwxr-xr-x@  1 root  wheel    11 Jan  1  2020 tmp -> private/tmp
1152921500312764693 drwxr-xr-x@ 11 root  wheel   352 Jan  1  2020 usr
1152921500312799555 lrwxr-xr-x@  1 root  wheel    11 Jan  1  2020 var -> private/var

Note that some files (e.g. /System and /bin) have huge inode numbers (1152921500311879701 and 1152921500312764509, respectively, on my system). These are on the System volume and can not be changed, except by a macOS system install/upgrade utility.

Other files (e.g. /Applications and /Users) have small inode numbers (42721130 and 21335, respectively, on my sysgtem), indicating that they reside on the Data volume and can therefore be deleted without breaking the system volume’s seal.


I was able to delete the Catalina Data one while booted into Mojave.

1 Like