Unexpected limitations of iOS/iPadOS

I recently returned from a trip in which I only carried an iPhone and an iPad. I encountered some unexpected limitations with the devices.

  1. I received an email with PDF that needed to have fields filled in. Nothing I did could activate or edit those fields in Mail or Safari. Instead, clicking or tapping (I had a pencil with me) only caused the document to zoom. Is there a way to edit PDF fields with Apple-supplied tools on these devices?

  2. I was replying to an email and wanted to add a photo. I found no way to do so. Apple help pages show the icons for adding photos/attachements (see 1st image below) but those icons do not appear on my devices (2nd image). Any ideas?

You can always long-press within the reply window at the location you want to add the photo, which brings up a menu that allows you to add a photo or video, scan a document, etc. That’s the way I always do so with iOS as well.

4 Likes

Strange but true: as I start to type a reply (on my iPhone SE), I do not see those buttons if I start with my iPhone in portrait mode. They do appear when I turn the iPhone to landscape mode – and stay there, above the keyboard, when I turn it back to portrait mode.

This kinda reminds me of Apple’s Calculator app on the iPhone – which is a simple Calculator in portrait mode, but turns into a scientific calculator in landscape mode. Except that it turns back into a simple calculator when turned back to landscape.

On the other hand, those buttons seem to consistently show up on my iPad (mini), even when I start using Mail in portrait mode. Very strange?

6 Likes

Thanks. I had tried this but failed to notice the “>” at the right end of the pop-up menu. Your response made me try again. That’s when I noticed the “>” and tapping it scrolls the menu and there is the add photo, add attachment options.

Aha!!! Thanks.

PDF forms can be filled in the Files app. In fact, it might offer to help fill fields it recognizes, such as your name and address. Press on the attachment and choose Save to Files.

4 Likes

Thanks. Unfortunately, I cannot test this. I filled out and digitally signed the form on my Mac this afternoon–and it will not let me access the form again (“This document has already been signed” from URL documents.adobe.com). I’ll keep this in mind if I run into this situation again.

As you found out the UI is not good. Tap, hold, select > symbol to display these choices:

2 Likes