Tried to install Catalina and it failed

I tried to install Catalina on my Mac Mini. The installation failed just before it was going to restart the Mac, with the error “osishelperd[8527]: Couldn’t mount base system dmg! (error code 110).”

I have not seen it but osishelperd is on a number of reports when upgrading an OS fails. One suggestion was to try upgrading in Safe mode, Recovery Mode, and with a new user account.

Before doing that I would check your hard disk for any problems. Safe mode will do a check, I use DiskWarrior if the drive is still HFS+.

I suspect your problem is related to the technical discussion in this article. Open the article and look up osishelperd. I wonder if the problem is related to blessing the new system.

After spending all day trying various things, I finally got Catalina installed. I ran Disk Utility First Aid and it found some file system problems. Apparently, it fixed them, but that didn’t seem to be the only problem, because I still got an error when I tried to install Catalina. I think the fact that I had turned off receiving betas also had something to do with it. I rejoined the beta program and that seems to have triggered a new download of the update, which subsequently installed correctly. I’m now running 10.15.1 on my old Mac Mini. I have a Parallels virtual machine running 10.14.6, in case I need some old 32-bit apps. For the time being, I’m happy.