Tough time with latest copy of MS Office, Excel v. 16.68

This is just a warning post.

Though I don’t use them, I find it wise to have them to read files exchanged in their native format (I know many other apps have importers but they often change the format), if no other reason. I have a lot of experience with Excel, trying to get better at Numbers. So when I bought my wife her new M2 MacAir, there was an offer for MS Office for a discounted price for non-subscription version. She can continue the use the version she has (gotten through employment). But I was on a very old version, like 2008, and knew it wouldn’t make the trip from Mojave to Monterey. I installed it the other night. Basically in the mailed box was a card telling me to go to a site to download it, and gave a license number. Well the site given was wrong. It did download and installed an app, an .exe app, tried it, it didn’t run! Going back in (like to war), it took quite a while to find how do download the Mac Version. Also while there I read the system requirements page, that was horrible. Only references like “last three OS’s”, not absolutes. Several links didn’t work. OK, it’s downloaded and installed. First thing was to run each app and register, etc.

OK, I had a project I’ve been needing to do before Christmas and finally Christmas morning started it. Well first thing in an Excel workbook needed was a Text Box. I couldn’t type into it. I finally discovered that after typing, I could right click on the box and what I previously typed only then showed up. So putting text into the text box was like driving blind. Then there was the printing. I had Excel show the workbook in page format. Well some rows printed on not the page shown in the page format view. They did show on the correct page in the print preview dialog box, so I no longer had to waste paper getting things to work out correctly. I had set no header on the first page but a page # out of ## header for the remainder pages. I only had 3 pages, but it printed out 6, the last three blank and the header said page # out of 6. That was corrected easily by setting a ‘print area’. This what should have been less than an hour project ended up about 3 hours. Is MS going downhill or what?

1 Like

Welcome to the world of Microsoft! I too have had to “upgrade” to the latest Office suite after buying a Macbook Air M2 running Ventura. In my case I already had Office 365 on another Mac (but used Office 2011 on that Mac to avoid the problems some users have described).
To my surprise the migration worked well and 365 seems to be running OK on the new MBA. However I haven’t fully tested it. I will look out for the problems that you have described.
I did find that Office 2011 was sometimes glitchy with tables in Word - text in cells would vanish in Print View and I had to change to draft view. It will be interesting to see if that is fixed in 365.

1 Like

More Office/Micro$oft Fun. An an old work computer that had Mathematica and MatLab on it (~multiple thousands of bucks) was still running El Capitan. When I upgraded to El Capitan it took quite a while to get those two programs running again, so I never upgraded again. Well all the certificates for El Capitan have expired so doing much of anything on the internet is almost impossible. I formatted a new drive, installed High Sierra (newest formally allowed), then used migration assistant to move everything over (still have El Capitan HD if things don’t work out). Everything did just FINE, with flying Colors! Except, you named it, 2011 Office apps. They want the original Product ID codes. Pretty sure this package was downloaded. The mail server used at the time later crashed (well actually the HD in the mac mini used as a server crashed) and since my company was closing, nothing was done to recover it. I can go back now and look at all old e-mail, and receipts in a separate folder, still on the MBP but have found nothing. I can go back and boot the El Capitan HD as a USB 3.0 external drive, and run the Office apps, but can’t find where the Product ID is, did find a Product number of some sort in the ‘About Excel’ box but its not the right format, and didn’t work as the Product ID code in the High Sierra HD. Many moons ago you could, or there was an app to do it for you if it was encrypted, get the product code from a working/running Office app. Trying to reach Micro$oft on this issue has been a little hit and miss. I found the place to request a phone call, after much hunting on Micro$ I then received an e-mail which I responded to with more information on what I need. I received a phone call and explained what I wanted and was transferred to someone who should be able to help but they didn’t answer after about 45 minutes. During that time I got another phone call (not too confident yet how to take a second call and be assured I could go back to first) and they left a voice message. That call was another call from Micro$oft employee, I guess from the replied to e-mail. The transcription software on my iPhone failed to understand the voice mail. My wife and I tried to understand the voice mail and failed too. I tried to call that number back without much luck, I was told to wait a few days and they should call back.

A few more got you’s. I ‘formatted’ an ‘invoice’ so some things were in columns using tabs in a word processor (Nisus, not Word). I selected all, then copied into a new Excel spreadsheet. It didn’t recognize the tabs as the next text should be pasted into the next column. I can’t find where to specify that should happen. I had to save as a text file, then import that. Saving as a text file removed all the images that were helpful in some identification in the invoice.

I really had to hunt for the AutoSum button

Now I can’t find the format selected cells (or items) menu item. Evidently my current solution is to click the … in the green title bar, and add that to the ‘quick menu’, i.e. the green menu bar. (Oops, have to take this one back, there is a Format Menu, and Format Cells is under that, and if you right click a row or column head there is also a menu choice.)

Some things when imported were quite lengthly and need the cells to be formatted to wrap (see above to find the menu problems/solution(s)). Had some problems with auto row height adjustment, seemed to be rather random. Sometimes after the wrap text command the row would automagically adjust, and when the format/row/autohieght command was used sometime it would leave and extra space and sometimes not. (There were no ‘extra’ character that would cause the extra space in some cells).

Seems to me, if you import a text file, and then add to it with formulas, and go to save it, the default should be to a .xlsx file, not a text file. Just sayin’.

It kind of seems to me new versions of at least Excel just changes the GUI, doesn’t fix bugs.

For those of you that are offended by the $ sign in my typing of that company mentioned, I am being nice in my feelings of them. I could just as easily type another four letter word instead of ‘soft’, that also starts with an ‘s’, that more accurately describes my feelings, but I refrain (this is a ‘family’ forum is it not?).

I ended up buying a newer version on a MacHeist deal. I had tried to move Office 2011 to another machine as I may lose it when I upgrade. It’s very frustrating as I’d already moved it in the past but M$ changed something over the years to no longer allow it.


I am not 100% sure, but 99.999%, that Office 2011 is 32 bit and will not transfer to Catalina or anything above that. Just checked, nope, its 32 bit. Use option/apple menu/system information/applications to check any app. Be patient, it takes a while to check and populate the screen, there is a spinning gear in the bottom right corner. A useful app to see all your 32bit apps that will not transfer from Mojave, or below, is Go64, its free, the advantage, I think, is it screens out all the OS apps that will get upgraded when upgrading to Catalina or above.

Yes, there were three apps I was worried about in my upgrade project that I am two years behind on: Illy CS 6 (finally got it moved to a different machine), Ascent (easily moves to different machines) and Office. I am upgrading to High Sierra, on my early 2015 MBPr. Though if I lose those apps I may be able to go higher on the machine. Either way I think the MacHeist deal was $40 and is now installed on a Big Sur machine, so it should be good for awhile, and I’ll continue to update that as far as I can.


I too held out on Mojave just for the Adobe Creative Suite (that and Canvas Draw) that I owned outright on a 2015 MBP. But Live Text on Monterey sounded too good to pass up, and it is! I jumped from Mojave to Monterey. Forget Adobe, see the writeup here in TidBits on the Affinity Apps, Photo, Designer, and Publisher, they replace Adobe Photoshop, Illustrator, and InDesign (and pretty much Canvas Draw), all for $99 before Jan 24th I believe (and iPad versions too), and that is NOT a subscription price, you own it outright as long as you want or until you need/forced to upgrade (whatever comes sooner). I have found for my needs, Designer and Publisher much better than Illustrator and InDesign. Publisher pretty much replaces Acrobat Pro too, and seems much easier and faster to use too.

Hint on upgrading. Get another HD and a case, see OWC ( ). Format the HD with the new format, APFS, you might have some difficulty doing that with how far back you are, maybe a friend can do it. I did an extra step and cloned my HD to an old spinning drive, just to have a complete good bootable copy of it. Install fresh copy of Monterey on new drive. Then using Go64 as a guide, delete all old 32 bit apps on old HD. If any have an uninstaller for an app, use that. Then use migration assistant to move your old drive materials to the new drive. Boot off the external to make sure it works. Then install the external drive into your MBP. The drives from OWC are faster than the one that came with your MBP. See figure below, top line is new drive from OWC, bottom is the one that came with my MBP. When getting the drive and case from OWC also get the screwdriver set to open the 2015 MBP, they use a special 5 pointed torx type screws (try or if you already have most of those try ). Feel free to contact me for any clarification needed, we’ll leave a light on for you.

My 2015 MBP has never felt livelier. I got it on eBay, and evidently I couldn’t do a OS upgrade, as going through the initial setup I got a notice screen on the MBP (more complicated than this, but this the low down) that this MBP had been stolen from Hulu, and to call the Hulu IT department, a phone # was given. Well some discussions with the Hulu IT, and LAPD (in the Chicago airport no less as I was on the way to a remote island 72 mi from Tromsø in Norway), sent them all the info on the eBay seller, and they removed the ‘hold’ on my laptop. I was glad I got to keep the laptop and not have to return it.

Note, some of my above posts are about an older 2011 ‘work’ MBP.

Screen Shot 2023-01-14 at 4.52.38 PM.pdf (222.1 KB)

Thank you! I may take you up on that offer, at the least I am printing this message out. I did order the OWC kit - Black Friday sale back then! I was determined to get it done last year, actually forgot about it for awhile prior, but work got busy. I just need to take a deep breath and gather all my materials and clear a space.

IIRC I have to upgrade this machine to HS just to do the upgrade. I have some info printed out. First I have to get through my January work then I’m taking time to get caught up on other things.

Thanks again!

Been there, done that. It took forever for me to sit down and just do it. I ran with an spinning external drive running Mojave with 1/2 the 32 bit apps removed for weeks, even took it that way on a 1 1/2 week river cruise in Germany. I now understand why the HS temp upgrade, to be able to format and work with the APFS drive, to install a later OS. Makes since now.