Total mystery website access problem

I have just come across an incredibly frustrating problem accessing my own website, from my own Mac! It’s completely defeated my attempts to resolve it. It is so weird I thought TibBITS readers might be interested—and suggest a solution!

I run a website at It’s a Wordpress site, independently hosted by SiteGround (who are superb, by the way). I have been accessing the site for editing or maintenance once or twice a week for the last three years, since I set it up.

This evening I tried to visit it as usual to update a plug-in—but couldn’t. The familiar web address just resulted in a blank page in Safari, followed eventually by a ‘server not responding’ error message. Here’s what I have tried to resolve the issue:

  1. Emptied Safari’s caches, and removed all cookies and website data for
  2. Quit and reopened Safari (version 13.1.2 (14609.
  3. Used a different browser (Chrome)
  4. Rebooted the Mac (which is running OS Mojave 10.14.6)
  5. Switched to my clean ‘Test’ user account
  6. Switched to a completely different WiFi network (my neighbour’s) connected to a different router

Absolutely nothing has worked. Needless to say, I have changed no settings on my Mac since I last accessed the site a few days ago. I haven’t, to my knowledge, installed any OS updates, nor browser updates. I haven’t touched my network settings for months.

And the problem is limited to just this one site. I can open every other website I have tried. And the mystery is compounded by the fact that I can open the site on my wife’s and my other three MacBooks, and on our iPhones. And I contacted SiteGround: they checked the site too, and could find no problem with it.

Having tried every step I can think of I am completely stumped as to the cause. Clearly it has something to do with the unique combination of my Mac and my website. Something that has occurred in the last 24 hours without any action on my part. I half expect to wake up tomorrow morning to find everything working again—but somehow I can’t see that happening.

So if anyone has any bright ideas about what it might be, and what I could try to solve this puzzle, please let me know!

Thanks in anticipation,

DNS caching on your machine or router? Do all your machines list the same servers in advanced network preferences? Try changing them on your machine to not use defaults?

1 Like

Such a good thought Dana. Indeed, my Mac was set up with first choice DNS, second choice The other devices I tried were using the default DNS for my service provider (BT in the UK).

I changed my Mac’s setting by removing and Alas it has made no difference! I am now using the same DNS as my second MacBook (which can access the website) but I still cannot open the site.

Great idea—but I fear not the right one.

Ahh, too bad. Assume you rebooted or otherwise cleared any local DNS caching on your machine as well? It would be suspicious if the only machine wIth non-default servers was the only one failing though…

1 Like

Yep, I rebooted. I’ll try tomorrow and add the and servers to my second MacBook to see if that will still open the website. But it’s 1230 AM here now so I’m off to bed!

Thanks for your suggestions

One step I often check to identify where a problem might located is try a different device if one is available. I didn’t see you mention it, so if you have a phone or tablet, can you access the website from it?

That will at least tell you if the problem is on your Mac, or on your local network (cell phones are great to also check your local network by switching off wifi and using a data plan to rule out your home network or ISP, your neighbor might use the same ISP).

1 Like

Sleep well! DNS problems typically resolve themselves in 24 hours as any changes propagate, so tomorrow may be a good day. Otherwise, I was going to blame it on the metric system.

1 Like

I don’t know if this is relevant to your problem, but Easy DNS forwarded news on a 0 day vulnerability attacking Word Press sites recently:

1 Like

Yeah, I saw that tonight too, elsewhere. But the other symptoms were so odd, especially given the fact that I could reach his website, still tended to imply DNS to me. On the other hand, I’ve no idea if WordPress has some kind of server load leveling going on behind the scenes that’s also adding to the confusion. Or it’s the metric system.

1 Like

Angus, appreciate the suggestion, but therein lies the root of the issue, as I wrote:

So in essence, I can open the site on every other Mac on our home network, and on our mobile devices. And I can open any other site on the culprit Mac, my every day workhorse 15" MacBook 2017 Retina. What I cannot do is access from the 15" MacBook.

Thanks @mark4 but I’m with @schwartz : I’m not sure that an issue at WordPress explains how there is just one website I cannot open, from just one computer. The site itself seems to be working perfectly fine. I have to believe that the problem lies within my Mac.

Or perhaps @schwartz is right and it’s the metric system. But then all my MacBooks are in inches: 12", 13", 15", and 17". It’s only the 15" that’s not working! (And by the way, it’s a new day in the UK—and I still have the problem.)

You’ve tried already a different user and a different browser. It is not DNS. It could be your proxy settings. In SysPref —> Network —> advanced —> proxy tab. See if there is an exclusion for your domain or IP-address.

1 Like

you could be being blocked by the server. You need to contact site ground and give them you IP to unblock you. These blocks usually only last 24 hours but could be longer or shorter depending on how it is set up.

1 Like

That’s probably not it because other computers in the same location (which I assume are behind a NAT router and have the same IP address) can access the site. And he’s tried it using the neighbor’s WiFi, definitely a different IP address.

You don’t have any utilities like little snitch (or anything that firewalls within the computer), do you?


Yes I read that he as able to access with other computers. and Phone.

@gdewaard I have no proxies set up. All the check-boxes under the proxies tab are unchecked. In the “Bypass proxy settings for these Hosts & Domains” box is “*.local, 169.254/16”, and “Use Passive FTP Mode” is checked. These setting are common to all my computers.

@appleget I think @ddmiller is right. All my computers are using the same NAT router—and the other devices can all access the site; and I still cannot access the site with the problem computer using a different WiFi network and a different router.

@ddmiller I do not have Little Snitch, and to my knowledge I have no firewalls in operation. I have a purely domestic set up: one router, two WiFi networks, four MacBooks, two iPads, two iPhones. And the thing is, no network settings were changed recently; and I do not have automatic updates enabled, so I know that neither the OS nor Safari have been updated recently. Otherwise the first thing I would have suspected would have been one of those—well, the OS I guess, since I can’t open the site using Chrome either, which suggests it’s not a Safari issue

You used a different router (your neighbour’s), so no blocking parental controls or firewall.
Either the browser engine, or your website blocks on something else than IP-address (like MAC-address).

Both Safari and Chrome are based on Webkit. Try using a browser that is not Webkit based, like Internet Explorer. Or choose from this list:

1 Like

Internet Explorer hasn’t existed on the Mac platform for a very long time.

Chrome (and current versions of Microsoft Edge) are based on Blink, which is a fork from WebKit.

Firefox is based on Gecko, which is not in any way related to WebKit/Safari.

Unfortunately, these three engines (WebKit, Blink and Gecko) seem to be all there is these days. The other engines have all fallen by the wayside over the years.


@gdewaard @Shamino Thanks for that suggestion. Downloaded Firefox in great anticipation that we might be arriving at a resolution—but no! It didn’t work. Same blank screen when I try and visit my site.

I even tried using Tor Browser. But that resulted in a captcha screen from my site host, SiteGround, which I couldn’t get past.

So, still no progress towards a solution.

Your site is reachable by me using Safari on Mojave.
Just did a traceroute to in terminal. It died after 64 hops. Last identified hop is

Can you reach your website with other protocols, eg FTP?
Can you do a traceroute?

1 Like