Too Many Kernel Panics - 2017 iMac - Monterey

This on a 2017 Retina 21" iMac Running MacOS 12.4

The day before I installed 12.4 I had a kernel panic. The day after I installed it I had four kernel panics in rapid succession in the space of a half hour. Since then I have had more. Sometimes a day goes by without one, sometimes there are several in a day. I have read and, for the most part, followed this:

If Your Mac Restarts and a Message Appears

The Kernel-YYYY-MM-DD-hhmmss.panic logs (/Library/Logs/DiagnosticReports/) offer no clues as to what software/hardware might be causing the panics

So far I have:

• Removed an external display and adapter
• Removed a USB hub
• Not removed a non-Apple (Logitech) keyboard as the machine would be useless without it.
• Not removed an external Samsung SSD as the machine would be useless to me without it

I started the machine in Recovery Mode and:

• Ran Disk First aid on the boot volume: No problems found
• Reinstalled MacOS

I started the machine in Diagnostics Mode and ran diagnostics: No problems found

The only extensions I have are those installed by:

• Graphic Converter
• Bartender
• Dropbox
• Google Drive
• Markup

The external drives that I have not removed have all been running fine on the machine for well over a year. I’ve had the keyboard for about 18 months.

I have attached the first few lines of the most recent panic report. This one happens to show that iStat menus was the panicked task, but I don’t think that means much. Every panic reports shows a different process as the panicked task.

Any ideas?

[Edit] Just an aside here. I bought my first Mac in the Summer of 1984. Since then I’ve only bought Macs for me and my family (well, except for a handful of Raspberry Pies). This is the first time I’ve ever reinstalled the OS. A broken string after 38 years.


Stackshot source : disk",“macOSPanicString”:"Machine-check capabilities: 0x0000000000000c0a family: 6 model: 158 stepping: 9 microcode: 240 signature: 0x906e9
Intel(R) Core™ i5-7500 CPU @ 3.40GHz
10 error-reporting banks Processor 0: IA32_MCG_STATUS: 0x0000000000000005 IA32_MC0_STATUS(0x401): 0xb200000000030005 mp_kdp_enter() timed-out on cpu 0, NMI-ing mp_kdp_enter() NMI pending on cpus: 0 1 2 3 mp_kdp_enter() timed-out during locked wait after NMI;expected 4 acks but received 1 after 9777577 loops in 1704000001 ticks panic(cpu 0 caller 0xffffff8012dd19d7): Machine Check at 0x00007ff817e89400, registers: CR0: 0x0000000080010033, CR2: 0x00007faa36919000, CR3: 0x000000044e4ef086, CR4: 0x00000000003626e0 RAX: 0x021dfff8595ae711, RBX: 0x00007faa36915600, RCX: 0x0080000000000000, RDX: 0x0000000000000000 RSP: 0x0000700007cdd348, RBP: 0x0000700007cdd390, RSI: 0x000000010a4af0ec, RDI: 0x00007faa36915600 R8: 0x0000efa0f5f5a900, R9: 0x000000000001dd37, R10: 0x000000010a4edb90, R11: 0x000000010a47940c R12: 0x00007ff817e89400, R13: 0x00007ff817e8c000, R14: 0x000060000327a900, R15: 0x0000600003c75f80 RFL: 0x0000000000000206, RIP: 0x00007ff817e89400, CS: 0x000000000000002b, SS: 0x0000000000000023 Error code: 0x0000000000000000 @trap_native.c:168 Panicked task 0xffffff95098af380: 4 threads: pid 125: iStatMenusDaemon Backtrace (CPU 0), panicked thread: 0xffffff903e6cfaa0, Frame : Return Address 0xffffffe5bde53b10 : 0xffffff8012c81c8d

iStat Menus does have a few hooks into the internals of macOS to do its monitoring, so I’m wondering if it’s worth uninstalling then reinstalling iStat Menus. It looks like you’ve ruled out any peripherals as the culprit. The only other possibility I can think of is something breaking in the iMac itself due to heat or other issues, in which case a call to Apple to get it seen at your nearest Apple store or a certified repair shop may be necessary. Definitely try to rule out iStat Menus first, however.

Thanks. I’ve uninstalled iStat Menus for the time being. We’ll see how it goes.

Hardware issues can also cause machine checks. Even though it is necessary to disassemble much of this iMac to change out its memory ( i.e. RAM ), it is possible ( search for OWC youtube video ) and should be considered. It’s happened to me. You didn’t mention starting up the machine in “safe” mode which can also provide clues. If the machine has a fusion drive I’d be checking that closely too.

I do understand that bad RAM can cause the kernel panics. I wanted to run MemTest86 to check the RAM. I followed the instructions here: to create a bootable USB drive, but I can’t get the Mac to recognize the drive. I start while holding down the Option key. The Mac recognizes two boot drives: the internal drive and an external bootable clone. But it doesn’t see MemTest drive. I’ve tried with three different USB drives: A spinning drive and two thumb drives. Nothing seems to work.

Any ideas?

I have the 27" version of your iMac and have never had this issue through MemTest86 v8.4. Guess I should update to 9.4 but don’t see how that could make a difference here. Only suggestions I can think of at the moment would be to disconnect that bootable clone and make sure to plug the USB drive directly into your iMac not an external hub of any kind.

I finally got it to work with the fourth drive I tried; an old SanDisk 4GB that I found at the back of a drawer.

On pass two now. No errors during pass one.

How much RAM do you have, and is it all factory-installed Apple RAM?

16GB, all Apple factory installed RAM.

MemTest86 V9.4 Free (Build: 1000) Result summary
PassMark Software
Test Start Time: 2022-06-02 00:00:27
Elapsed Time: 3:22:42
CPUs Active: 4
CPU Temperature Min/Max/Ave: 67C/81C/72C
RAM Temperature Min/Max/Ave: 100C/142C/125C
# Tests Passed: 48/48 (100%)
Lowest Error Address: N/A
Highest Error Address: N/A
Bits in Error Mask: 0000000000000000
Bits in Error: Total: 0 Min: 0 Max: 0 Avg: 0
Max Contiguous Errors: 0

Safe Mode

It was suggested elsewhere that I boot the machine into Safe Mode. I finally did this last night. I’d never done it before so didn’t know what to expect. What I didn’t expect was what a slug the machine would be in safe mode. It was barely useable. The pointer moved across the screen in fits and starts rather than the smooth motion to which I am accustomed. In text fields the insertion point kept disappearing.

I was actually grateful when there was another kernel panic and the machine rebooted into UnSafe Mode and again operated smoothly.

Is Safe Mode always like that?

I had same experience as you: long, slow boot into Safe Mode followed by sluggish response. And then I too had a kernel panic again anyway.

I think Safe Mode is best reserved for testing purposes (which is probably the underlying intent behind the mode I think).

1 Like

Pretty much and has been for a very long time, if not since it became a thing. At least two things cause this.

Lengthy boot is caused by deleting numerous cache files causing them to build from scratch.

Graphics is crippled which normally manifests itself as a flaky screen and jerky cursor movement. I suspect that is due to the disabling of normal GPU extensions which would force the CPU to have to support graphics.

1 Like

I am having the exact same issue when working with Photoshop on my iMac 21,5 2017. The machine has been upgraded last year by Lab9 (Apple retailer). The original 1 TB HDD was replaced by an OWC 1TB NVME SSD, the SATA side received a 200 GB SSD and RAM was upgraded to 32 GB (also OWC).
The machine seems to work flawlessly until I start using Photoshop with, have to admit, extremely large .psb files (2 to 5 GB). After a certain time I get the dreaded multicolored wheel that seems to turn for ages. Then the iMac restarts. The crash information repeatedly mentions Windowserver?
I’m hesitating to perform a clean install as a last resort.
Any suggestions or advice?

Forgot to add that I’m currently working with the latest versions of Monterey and Photoshop.

Although it may be too early to tell for sure, it now appears that the kernel panics were caused by connecting a Samsung SSD to the iMac via a USB-C/Thunderbolt port. It was suggested that I swap the C-C cable for a C-A cable and connect the drive to one of the USB-A ports. I did that last Friday and haven’t had a panic since then. It’s still early days (96 hours), but I’m full of hope.

Glad to hear you’ve got some resolution to the problem at last. Sounds like you may have lucked out with a cable that wasn’t up to the job. Touch wood, I’ve not had any issues with any of the external SSDs or hard disks I’ve used with my iMac. I do have an Apple Thunderbolt-to-Thunderbolt2 adaptor for one SSD, and A-C adaptor for the hard disk I use for Time Machine, but I could ditch the latter now as I have a free USB-A socket on the back of the Mac.

This feels like a RAM issue to me, given that it only happens when Photoshop is using huge files. Perhaps run MemTest86, as mentioned above?

The cable I was using was the one that came with the Samsung SSD. When I work up the courage I may buy another Thunderbolt cable and try that drive in a Thunderbolt port again. Right now it seems to be fine in the USB-A port.

Turns out the joy was premature. Just had another kernel panic this morning after four days without one. Same signature as all the others: 0x906e9

I’m ready to give up on the old iMac.

Although I can’t be certain, I may have figured out the cause of the kernel panics on my 2017 iMac running Monterey.

After I’d spent nearly a month trying different things and had mostly given up, I recalled that LaunchBar had been behaving oddly. For example, almost every time the machine booted up, LaunchBar complained that it was unable to process the Applications indexing rule. I figured that this was a bogus error message as I was able to launch applications with LaunchBar as usual. Then I recalled that if I manually rebooted the machine, it always took a very long time for LaunchBar to quit. It was always the last app to quit.

So, I had a look at LaunchBar’s Index. It turns out that there were two indexing rules called “Applications”; one in the General section and one in the Files & Folders section. I had a look at the unusual one and saw that it contained a real mishmash of locations and “Search for” items. None of it seemed like anything I would set up, so I deleted the rule.

Since doing so I have had not one single kernel panic. It’s been ten days. I have written to Objective Development about the issue, but have yet to hear back.

Of course, I have no way of knowing if this was really the cause of the panics.

I won’t feel comfortable until a few weeks have passed, but this may be it.