TipBITS: How to Send a Full Web Page by Email


(Adam Engst) #1

Originally published at: https://tidbits.com/2018/06/20/tipbits-how-to-send-a-full-web-page-by-email/

Want to get the contents of a Web page, such as a back issue of TidBITS, into your email archive? Surprisingly, it’s a task most easily accomplished using Safari and Mail, rather than any other Web browsers, email clients, or online services.


(mpainesyd) #2

I have the opposite need. For many web pages if I share a link from Safari in iOS it creates an email with the entire web page content. There doesn’t seem to be a way to only share the link. In macOS there is an option to only share the link.
I have sent feedback to Apple on this (not holding my breath!)


(Curtis Wilcox) #3

When I share a web page from Safari to Mail on my iPhone (I haven’t installed iOS 11.4 yet), the subject line is the web page title and the body is only the URL. I thought sharing the web page content or URL was configurable but I couldn’t find a setting anywhere.

In case it changes Mail’s behavior, my default email account has a custom domain hosted by Google.


(Adam Engst) #4

Another friend noted this, and while I don’t have an iOS 11.3 device around to test @cwilcox’s supposition that it’s new in 11.4, one workaround would be to install a different app for email. I haven’t tested all that many, but those I have tried always send just the link, and no text. Since you can pick which email app you want in the Share sheet in iOS, it’s not really any harder to use another app just for sending links.


(Mark Williamson) #5

I also see this (URL only, no option for the full page) on my iPhone X running iOS 11.4, with my default account set to either mac.com or a custom domain not hosted by Google.

There’s some variable we haven’t tracked down yet.


(mpainesyd) #6

Ah… I think it might only happen (full web page in email) when the web page has the Reader option available (but I try sending a link from the normal
page). This Tidbits page has a Reader view and if I send a link the resulting email includes the full web page. Apple web pages don’t have Reader view and the email only has a link.


(mpainesyd) #7

It happens with 11.4 on iPhone and iPad.


(mpainesyd) #8

I have sent this feedback to Apple:
I previously reported that sending a web page link by email in iOS 11.4 often creates an email with the whole web page and not just a link (and there is no option to change this).
I have now discovered that it only happens when the web page has a reader view available. The problem occurs from the normal page, not just the Reader view page.
Please urgently fix this, or at least give the option to send only a link as happens with Mail in macOS.

(Apologies for the multiple posts - I don’t seem to be able to edit a post - have now found the button :slight_smile:


(Curtis Wilcox) #9

Well observed! When I also visit a page that has a Reader view available, the email body contents are the link followed by the Reader version of the page. I can delete all the Reader content from the body but I think it would be better if there was an option like macOS’s Mail.app’s dropdown menu, Send Web Content As.


(Marc Z) #10

This is how it’s worked for ages — when you send an email via a page in Reader mode, it quotes the full article. It’s wonderful. I use this all the time to forward articles to friends so they don’t have to hassle following a link.

If you don’t want to send the full article, just toggle off Reader Mode before tapping the share icon and it will just send the link.


(Doug Miller) #11

But that appears to be the issue. If you open, say, this tidbits article in Safari on iOS: https://tidbits.com/2018/06/25/new-eu-copyright-regulations-threaten-the-internet/

Even when you have reader mode off, if you use the share sheet mail extension, it will share the link as well as the reader mode version of the article (at least it does so on 11.4.)

It doesn’t happen on every web site, either.


(Marc Z) #12

You’re right! Must be a change in 11.4 or maybe it’s only certain websites. About 98% of the time I want to send the full article, so I never noticed when the link-only feature went away. Puzzling, as the old behavior made sense to me.

But then to send link-only, you can just copy the URL and email that. It’s not that many extra taps.


Quote tags not on their own line -> breaks quote
(Curtis Wilcox) #13

This behavior of always emailing the Reader view if the page has a Reader view (regardless of whether the view has been viewed) is not new to 11.4. My phone is 11.3 and also does it. What you’re describing, only including the Reader view if it was being viewed, could work but like many things on iOS, it would not be an easily discoverable feature. Maybe Send Web Content As options could be revealed in the email composition, just as things like the Bcc field are.

I often have trouble copying URLs from the address bar on my phone and then I’d have to use the Home button, then tap the Mail icon, then tap the compose button, then paste in the body. That’s much worse than tapping the share icon then tapping the Mail icon. If I get the Reader view version of the draft email from sharing, I’d probably rather try to select and delete the text after the link than copy the link from Safari’s address bar and start composing an email manually.


(Doug Miller) #14

There is a “copy” option on the bottom section of the share sheet in iOS Safari that copies only the link. Tap that, open Mail, compose the message, paste, and that will include the link. (I just tried it from that same Tidbits article to make sure it wasn’t also creating a reader mode snippet).

While you can do it, trying to select all in the address bar and then copy is a lot harder.


(Marc Z) #15

What I’ve done in the past is tap the address bar, select Copy, hit the Share button, hit Mail button, and then Select All in the text and paste in the URL. That way my subject line is already filled out and it’s easier than switching to Mail or trying to select just the article to delete in the “full article” email.

Another way to get the URL is to Share but hit Messages, select and copy the resulting text, and then cancel the message and re-share using Mail.


(Simon) #16

I wonder if the proper solution would be that there’s only one share button and only one share behavior regardless of which mode Safari is in, but as soon as you hit the share button it simply asks what format you prefer and then does that.


(mpainesyd) #17

Yes - just like macOS. Don’t departments in Apple talk to one another?!