Tip: Force-quit misbehaving (Apple TV) apps

I just wanted to share a recent experience. For the past few days, the YouTube apps on my Apple TV (4K) was misbehaving. When playing a video, I would get audio but only see a solid gray screen - no video content.

At first, I ignored it, assuming that it was some server glitch or that a recent app update has a bug and would soon be fixed. But that wasn’t the case - several days later, the problem persisted.

Then I remembered that you can force-quit apps on Apple TV using the application switcher (double-click the TV button). I did that for the YouTube app, restarted it, and it worked normally afterward.

Although it is obvious in hindsight, it wasn’t at the time. If you see a misbehaving app on a device (Apple TV, phone, Mac, .etc.) your first attempt for a fix should involve quitting and restarting the app.


Yep - double click on the TV button (latest Apple TV Remote), select the misbehaving app and swipe up to force-quit it.
Fortunately I rarely have to use it. However I have downloaded some poorly written apps that sometimes refuse to quit so the trick has come in handy.

I’ve force-quit Apple TV apps 1000x more than I’ve ever quit iPhone / iPad apps.

I commend myself. My spouse uses an iPhone as a timer, and it was failing silently. I quit Clock (which contains the timer function) and restarted it to test it. Then I started reading TidBITS, and your thread was the first thread I read. I patted myself on the head because I had just tried “quitting and restarting the app.”

(The timer still failed, this time by playing the sound once and then going silent. I restarted the iPhone, and that seems to have fixed it. I’m not sure that restarting the device should be the second attempt for a fix, but it should be high on the list.)

My only quibble with your post is that I would have put “Apple TV” in parenthesis in the thread title because of the wider applicability.

This thread raises a question, in my mind, that perhaps might be better as a separate thread.
But it feels like a comparable issue.
I find that video streaming generally, is not handled well in Apple’s web browser, Safari, which
can very often exhibit the very same symptom described for the Apple TV app glitches.
Sometimes clearing the browser cache can help, but often an additional step of a system restart is necessary to correct the phenomenon of Audio Only/NoVideo streaming glitch

And to digress even further, I notice Apple’s iOS iteration continue to exhibit a phenomenon of running app audio even when apps have been quit. And occasionally audio content embedded in Messages Texts continue to run, even after a text has been deleted.

I know these may be far afield of the main thrust of the original query, but something seems connected in these various device symptoms

Out of curiousity, did you try restarting the Apple TV? Every now and then an app like Netflix gets weird on our fourth-generation Apple TV, but I never quite know if it might be more of a networking stack or connectivity problem, so I just restart the entire box, and that’s always solved the problem. Of course, I have to experiment with which two buttons to hold down for a while or look it up since I only do it a few times per year. :slight_smile:

I can never remember the keyboard combo, so I always just go to:

Settings » System » Restart

Thanks! I wonder if that’s been there for a long time or if it’s newish. I know a similar option was added to iOS only relatively recently.

It was at least in iOS 14 but I can’t really say that I remember before that.

Related: Is there a way to have Siri on the AppleTV open the Settings app to “System” sub-menu? If so, I could not determine it.

In the AppleTV hardware? I have had a Gen4 Apple TV for a couple of years and I believe the Restart option has always been there under the Settings menu.