Time Machine Trials and Tribulations

When I upgraded my iMac to Monterey I noticed that Time machine had stopped working. The OS had reformatted the Time Capsule hard drive to APFS but wasn’t completing the backup. After several attempts where it did not recognize the previous backup and added another 400 GB to my backup drive each time, I decided to revisit my backup strategy and updated to Joe Kissell’s lates version of backing up your mac for guidance.

I selected a 2 TB Thunderbolt 3 SSD (same size as the fusion drive on my iMac.) I formatted it as APFS encrypted and then offered it to Time machine as a backup location. Again time machine failed.

I tried using Clean My Mac to remove potentially troublesome files, but it did’t catch everything. I then used System Information to identify 32 bit apps still on the machine and manually deleted each one using the identified path to locate them. (They were all inactive, circle slash)

I was able to do a complete backup in Safe Boot mode so I went back and removed all startup items. No luck.

I decided to exclude the users folder from Time machine backup - success.

I excluded all individual user folders - success

I only excluded my user folder - success

I excluded all folders in my user folder - success.
One by one I included each folder until only my user library folder was stopping the backup.

I then followed the same process in the Library and had three folders that were preventing backup success:
~/Library/Application Support 20.55 GB
~/Library/Group Containers 15.38 GB
~/Library/Mail 10.5 GB

I realize Mail could probably be resolved by deleting attachments, but at this point I was ready to claim success. I had a full backup from Safe Boot and wasn’t too concerned about backing up the other two ( I may regret this later).

So at this point Time Machine appeared to be working.

About a month later it stopped working again and showed no backups and reduced disk space available on my backup drive. I tried running disk first aid and discover it doesn’t work for APFS format. I could mount and unmount the backup disk and see the backup folders inside. Time Machine could not. I booted into recovery mode and was able to use disk utility first aid with my Time machine encryption password. No problems found on the backup disk. I did a normal restart and reselected the backup drive in Time machine. I still had the library files excluded. It did not recognize the existing backup and identified over 100K files that needed to be copied. I left it running and when I came back it was recognizing the previous backups and had a minimal increase in backup size.


  1. Backup works in Safe Boot mode (for me)
  2. The folder exclusion process seems to work. I have multiple files over 6 GB in size that it does not seem to have problems with. Just those three in my user library (for now)
  3. I believe when my computer crashes it throws off time machine and it can’t recover without help.
  4. I doubt reselecting the backup disk would have allowed it to recover if I didn’t have sufficient spaces on the disk for a second full backup.

BTW, I am seriously considering dumping Time machine in favor of Carbon Copy Cloner for this hourly backup function.

I have heard recurring troubles with Time Machine over the years. I know many people who have no issues with it, and never have - but not me. I switched to Carbon Copy Cloner and have not had an issues, and I love the clarity of just what and when backup are occurring (and the ability to schedule backups). Follow your instinct - switch to Carbon Copy Cloner.

1 Like

Thank you for your detective work and post.

Those folders on my computer are not nearly as large, and Time Machine still failed to complete a backup (to Time Capsule or an external disk) even after excluding them.

I don’t recall a crash and do not believe there was one. The start of failures on my Mac corresponded closely to system updates. (Following the first system update, Time Machine simply started working again after several weeks. Following the second system update, Time Machine has never completed a backup. I don’t have the patience to follow the protocol you outlined for testing.

Following the first system update, I deleted one of the Time Machine backups and started a fresh one (on the same disk; I don’t recall if it was the external or the Time Capsule). This did not solve the problem.

Having read this thread I investigated using CCC 6 instead of Time Machine. I also have a Time Capsule (last gen) attached to my router and use it as a Time Machine. Occasionally the backup gets corrupted and I have to make a new one, which is a pain not only because I lose maybe a year’s worth of backups, but also because I can’t reclaim the space by formatting the Time Capsule’s drive as my wife has a TM backup there too. So I let Terminal spend hours deleting bands…
The initial backup of the 230GB used on my MBA’s SSD took 27 hours over wi-fi. During that time I read some more of the CCC manual, and discovered that network disks used for snapshots do not allow you to browse files and restore what you want. It’s an all or none restore. That’s no good!
So I fired up Terminal and spent many more hours deleting the folders CCC had just placed on the Time Capsule and switched on Time Machine again. Fortunately it offered to re-use my old sparsebundle.
I have a couple of external SSDs with USB-C interfaces, and currently use one to clone my disk when I remember. I set the second to do a CCC backup with snapshots. That took about ten minutes(!) and updating it when I plug it in takes <2 minutes, which is about the same as updating my clone.
So I shall stick with Time Machine on the Time Capsule, and a daily clone plus a daily new snapshot.