Time Machine password strangeness in Catalina

OK…this one has me confused so hopefully somebody can point out what I’ missing.

As part of moving into our new house and out of the RV…all of my LAN stuff obviously has to be reconfigured. Our daily drivers are laptops and we have a mini that was our file server and Time Machine server back in the rig (but it was running Mojave at that time).

I bought an iMac to be the server in the house and it came with Catalina. I plugged in an external HFS+ formatted drive, put a folder on it for each laptop to backup, shared each folder including making it a TM destination and gave R/W permissions to admins and the user group that contains our network share login accounts in it…I also gave those users and groups R/W permission to the root of the external drive.

I then upgraded the mini to Catalina, hooked up an identical external HFS+ formatted drive and created folders for each laptop on it (different disk and folder names naturally)…figuring I would just alternate Time Machine backups from the laptops because I could and the mini is hooked up to our TV for a media box anyway.

I then went into the laptops, removed all Time Machine backup passwords from keychain access and logged in as my normal non-admin account.

Setup Time Machine to the mini share…put in mini admin userid and password when asked, and it works just fine.

Setup Time Machine to the iMac share, told it to use both destinations, put in the same admin userid and password (I have userid and passwords synced across all of our machines to make things easier), and Time Machine said it was setup. Tried to backup…fails with a bad password dialog.

Tried deleting the share and redoing it, tried verifying the password is correct for the iMac (it is)…still failed, tried a third time and it still fails.

The only difference in the way the two TM machines are setup is the iMac is wifi (since I haven’t run a cable through the attic to the office yet) and the mini is wired…but the iMac is on the same 5G wifi network as the laptops are.

Any suggestions as to what I might try next? I’m about out of ideas.


I’ve no expert knowledge with your problem and in lieu of no other responses, may I suggest you try changing the password that accesses the Time Machine within the Airport Utility app. The one under the DATA tab (just going from memory as not in front of my home set up), or it may just be the password for time machine set up. I can’t recall.
Apply the change. And then change it back to the original password (if you want to keep it) and Apply the change.
One other option is to log onto the Time Machine drive via the Finder (should show in the Sidebar). Or toggle it. ie Log Off and Log back on.
I’ve not upgraded any of my 4 Macs to Catalina, but I’ve experienced either the same or similar problem with my Time Machine set up in Mojave.
I’ve also found that sometimes a restart by pulling out the power cord and/or doing a soft reset on the Time Machine fixes problems (and I also restart my ISP-supplied modem as well).
It’s pleasing to see the green light on and back-ups being recorded … after trouble-shooting for an hour or so, and seemingly not changing any settings!. :slight_smile:

Good thought but it isn’t a Time Capsule or shared volume on an Airport…the destination is another machine running Catalina. I’ve tried nuking all of the applicable passwords out of the Keychain as well as recreating the share used for the TM destination. I haven’t tried changing the share perms to include guest access… it have tried setting Everyone to R/W. I will give that a whirl as well.