System settings prevent Private Relay from working?

I’m receiving this message when trying to enable Private Relay:

“Your system has extensions or settings installed that are incompatible with Private Relay.”

There is a MacRumors thread on the topic that seemed promising. I’ve removed all VPN software, per the thread’s recommendation. And I’m not using any special DNS settings. However, I’m still getting the error message when trying to enable Private Relay. (This was working at one time. Unfortunately, I don’t know when it stopped.)

This is an issue on my Macs (MacBook Air (M1), and iMac (Intel)) but not on my iPhone. There may be an extension that’s an issue, but there’s no hint as what it might be.

Has anyone here encountered (and maybe solved) this problem? Are there any other recommendations on which extensions or settings may be the cause of this error?

Thanks, in advance.

I may have solved my own problem.

I installed EtreCheckPro and generated it’s report. EtreCheckPro found an extension for Private Internet Access that I had missed (com.privateinternetaccess.vpn.daemon). The VPN daemon was reported as an unsigned module. I remove the PIA file, restarted my MacBook Air, and Private Relay now works.

Maybe this will be of use to someone else.

3 Likes