Suggestd quit unexpectedly

My 2015 Macbook, running Mojavestrong text, has started to frequently display the error message “suggestd quit unexpectedly”. I found some advice here:

But it doesn’t seem to work!
The error is also mentioned in this Tidbits thread:

It seems be related to Spotlight indexing.
I have “repaired” the disk, tried the cdutil commands etc. i don’t want to “upgrade” macOS.
Any thoughts?

The EnigmaSort site is blocked for me by my DNS, probably for promoting SpyHunter and leading you to believe the error is caused by spyware/malware, so I wouldn’t believe anything they had to say.

What else is the error message telling you about the reason for the unexpected quit? Does it match what @fredbrock posted in the migration discussion?

Not sure what you mean by this since we don’t know what macOS you are running nor what update you might be referring to.

If you are able to restore your current macOS, that would seem to be an appropriate next step.

1 Like

Thank you Al. There is more info here from 2016. I will try the last contributors tips when I get back to the office in a few days.
https://discussions.apple.com/thread/7441737

Well, it’s too bad that 26T didn’t respond to Linc’s request for a dump as he was by far the smartest troubleshooter on the forum until he suddenly bowed out back then.

If I had to guess, I’d have to say that the problem is with a developer who has miscoded the use of the suggestd process which causes the process to quit without delivering the desired results. So it’s only actually impacting that app and simply an annoyance to you which can safely be ignored.

I find the @mbluke recommendation quite troubling. I’m sure that completely disabling suggestd is going to solve your issue, but at what cost? All of the apps that benefit from the use of suggestd will completely loose it’s functionality. If you really can’t live with the issue, then you should only change the MachServices to “No” one at a time until you find the culprit and leave the others as “Yes”. Recognize that will take more time, but IMO vastly better than totally disabling it.

The issue is still happening. I guess I will need to methodically quit apps that might have a bug.

I think I have tracked it down to the iCloud Mail settings. I unchecked this (meaning my iCloud email was no longer accessible from the Macbook) and the bug seems to have vanished. I turned it back on and, so far, no sign of the bug.
Anyway, I have submitted a bug report to Apple (ha ha!) and have kept a copy of the error report if anyone is interested (I can send/post extracts)

Disabling Mail in iCloud settings did not work :slightly_frowning_face:
I read that someone found Calendar was the cause but, again, disabling that did not work. Bizarrely the error still occurred when I was not connected to the internet.
So… it looks like I need to reinstall Mojave!

Restoring Mojave did not fix the problem so I guess it must be due to some corruption in apps or data, such as plist files (that are not automatically replaced by Restore).
I suppose the next thing to try is a clean install of Mojave and the tedious task of setting up all my apps.

I feel your pain, Michael. I’m moving to an M1 MacBook and hoping against hope that moving to the latest Mac OS will leave the offending cruft in the dust following my data transfer. If not, a clean install and a painstaking manual transfer is in my future also.