Strange PDF form issue

Quick question for the deep Mac experts here: my accountant gives me my tax organizer as a PDF. Last year, for my 2018 taxes, all I had to do was open the PDF in Preview and fill it out as an online form (check boxes, fill in text boxes, etc.)

This year I opened my 2019 organizer PDF and Preview did not recognize it as a form. The only way I can edit it is by manually using the Markup bar, which would take forever.

Then, thinking it was a change in Preview (I upgraded to a new Mac and Catalina last December), I tried opening my 2018 tax organizer in Preview. And sure enough, it was no longer editable as a form in Preview either.

So I thought, maybe I need to use a PDF editor. So I bought PDF Pen from Smile Software (which I love), opened the PDF. And it is still not editable.

So then I went back to my old machine (a 2015 MacBook Pro still running Mohave) and sure enough, BOTH PDFs were editable as forms.

So what’s going on? Why can’t Preview under Catalina edit a PDF form? Can anyone clear up this mystery for me?



Whoa, that’s really freaky. Give Acrobat Reader a try in Catalina. PDFpen is great, but when you’re troubleshooting PDF issues, you want to go to the horse’s mouth.

1 Like

My guess is that this year your accountant sent an uneditable or a password protected PDF. Many individuals and businesses prefer it this way. If it is protected, and he might have forgotten to send the password, all he needs to do is send you the password. Or he can unclick a checkbox to create unencrypted version.

If he sent a PDF of a scan, he sent you an image and you need the full version of Acrobat to edit it via the Edit PDF tool. He should be able to easily create and send you an editable PDF directly from whatever accounting software he uses. I suggest giving him a call.

I turns out Adam was right. The PDF is actually a PDF form—produced by the same software my accountant used to produce last’s year’s version. So it wasn’t locks or permissions or anything like that.

But neither Preview nor PDF Pen could edit the form. And yet when I loaded it into the free version of Adobe Acrobat Reader, suddenly no problem, I can edit the form just like I could LAST YEAR using Preview (on Mojave).

That is so strange. I can understand Preview not doing it, but I paid good money for PDF Pen and it still can’t edit a PDF form? I’ve written Smile Software (who I love—I swear by TextExpander) to inquire about that.

Thanks for your help!!

It’s likely that Preview and PDFpen both rely on Apple’s PDFKit framework, so if the particular PDF was created by software that wasn’t being tested against PDFKit, it makes some sense that both would be affected.

Apple rewrote PDFKit a while back and caused great consternation; it’s entirely possible there was some additional change made from Mojave to Catalina. @mjtsai might know more due to his work on EagleFiler.

Here’s what we wrote several years ago:

1 Like

I haven’t seen this particular issue, but there are definitely ongoing changes to PDFKit, so it’s possible that something broke between Mojave and Catalina. Aside from Acrobat, some PDF apps that don’t rely on PDFKit are PDF Expert and PDF Viewer. I’m not sure whether they handle forms. If you have a non-private PDF that exhibits the issue in Preview, I would encourage you to report it to Apple.

I would use a different adjective to describe PDF Pen (especially the “Pro” variety). Lots of features, but HORRIBLE user interface.

And, since I’m opining, I’ll offer one more.

The only truly universal portable thing about a PDF is the icon. Inside, it’s like Forrest Gump’s box of chocolates. Even those you get from extraordinarily expensive publications such as the New England Journal of Medicine. I’ve found instances where PDF reprints from the publisher had confusing glyph substitutions because not all the fonts used in the article were embedded in the emailed pdf. And, if you download PDFs of web pages, sometimes what you get is a bitmapped picture that you can rescue with OCR software. It’s messy in there!!!

Thanks. I thought maybe I was just failing to understand the designer’s vision. (Of course, maybe we both are.)

Again, thanks. I couldn’t figure out how I could be opening a file incorrectly, but that’s what it seemed like.