Spanish Language is more prevalent

Over the last month or so, I’ve noticed that when typing on my iPhone (and maybe iPad), that I’m getting a lot more Spanish word suggestions/auto corrections. For instance, I attempted to type the word “to” and it was corrected to “tío”. Even while entering English words, but not yet completing them I’ll get Spanish word suggestions. I’ve double checked that the only keyboards that I have active are English (US) and Emoji.

What gives? Any ideas? Has anyone else experienced this?

Perhaps this has something to do with it, but how do I change it?


I thought I might have had a Spanish dictionary loaded, but I don’t.


I hadn’t seen the Edit button in the upper right corner. When I selected it, I was able to remove Spanish language as my 2nd choice which appears to have resolved the issue.

I’m afraid I have seen something similar with iOS 13. I have several languages for both keyboards and in my preferred language order. My native language is English which is my preferred and I write most of my texts in English using the English keyboard. However, every once a while I’ll write a text to an old colleague in their language. I switch the keyboard over and sure enough word suggestions make sense.

Then came iOS 13 and I started noticing how in the middle of an English text to my wife using the English keyboard, I’d get suggestions for Italian words. Now my wife doesn’t speak Italian (not that mine is really any good) and hence I’ve never used the Italian keyboard to text her. But I have used the Italian keyboard to text an old buddy in Frascati in my broken Italian.

I haven’t been able to find a setting to turn off these nonsense suggestions. My best guess is Apple changed iOS 13 behavior to be “smart” about what to suggest based on what other languages or keyboards people have selected regardless of what keyboard they’re presently actually using. Now in some instances that makes sense because multilingual people will often mix languages when they communicate. So a German/English speaking couple might use an English keyboard to exchange texts in English but still every once in a while use a German word (especially when there’s no English equivalent, such as the beautiful sternhagelvoll). In those cases Apple’s new “smart” approach (assuming this is actually what’s happening here) would make a lot of sense.

On macOS after all they’v already done something very similar for a long time. We can have multilingual spellchecking where macOS will recognize from the context which language you’re in (I’ve checked this works down to a quite granular level) and apply that spellchecker to only that part of your text.

The problem with such “smart” support is usually just that. It’s not quite as smart as we are. Which is why it would be nice to have a setting where you can turn that off on iOS if you want to force it to suggest according to the language you’re typing in. For people that never or only rarely mix, that would likely require far less manual correction, while for those that mix a lot the setting would allow them to have iOS mix suggestions dynamically matching their use.

I think Apple introduced “multilingual typing” back in iOS 10, but I’ve seen quite a few complaints about how it works or doesn’t work the way people want. It used to be that what Dictionaries you have active in the settings item for that was a key factor. You might try playing with that if you haven’t already.

1 Like


I love that you’re an A’s fan! I was born and raised in Oakland!

I went to Settings -> General -> Language & Region, and noticed that under iPhone Language I had English and Español (Mexico) selected. I then clicked the Edit button in the upper right corner, and deleted Spanish, and in doing so, my iPhone no longer recognizes Spanish words. As mentioned previously, when I typed the word “to” it autocorrected to “tio” (uncle, in Spanish). Now when I type the word “tio” it’s autocorrected to “too”. I think this was the fix that I needed.


Glad you figured it out! Yes, the solution to this sort of problem for many people is just to delete the extra language. If you do need multiple languages enabled, then it’s more of a troubleshooting task.

1 Like

A’s forever man. I was born in Oakland too, much rougher of a town back then though (team was better too) ;). After traveling a lot, I ended up coming back. I now live right next door again.

I’m not surprised you can get it to work by removing languages from your list. Problem with that is I’m not sure I really want to do that. I read a lot of stuff people send me in other languages and as I said, every once in a while I’ll even attempt at sending them something in those languages. So I want those keyboards and I’d like to be able to use those dictionaries to look stuff up. Will all of that still work fine without those extra languages in my list? I guess time will have to tell.


I’m across the Bay in San Mateo, so I haven’t gone far from Oakland, and still get over there (or Berkeley) several times a month. The East Bay has definitely seen a lot of change over the years, better or worse.

It appears that there are 3 places for foreign languages in iOS; Keyboard, Dictionary, and Preferred Language. I wonder if you can disable/enable one of these, and still be able to lookup the words you want, and type in the language that you’d like, with the issues of “smart” support?