Solving the macOS Installer’s “Failed to Personalize” Error with New Firmware

Originally published at: Solving the macOS Installer’s “Failed to Personalize” Error with New Firmware - TidBITS

A TidBITS Talk user was unable to update macOS on an M2 16-inch MacBook Pro, receiving a “Failed to personalize” error each time. The problem turned out to be related to firmware, and the little-known solution required restoring with Apple Configurator.

2 Likes

This is a welcome solution! I have had people write me about this over the years, and never had diagnosed what could have caused it—much less a solution!

1 Like

Thanks so much, Adam. One of the many reasons I check the posts on this website!

I’ve an M1 Studio that has had the problem since shortly after I purchased it, now through three versions of the Mac OS. I am able to get around it by booting into recovery mode and then reinstalling the latest OS. I’ve tried many other solutions, including erasing and rebuilding, and twice using Configurator and a second Mac to perform a restore. Disappointingly, my interactions with Apple support 2 years ago were similar - they focused on issues interfering with the download of the update or network issues (despite the fact that I told them we have 2 other Macs in the household on the same network and neither has ever had this issue). Left it at the Genius Bar, they wiped the machine and installed Ventura, claimed they could then update to Sonoma without a problem. I reinstalled apps and data via a Time Machine backup and held my breath until the next Sonoma update appeared, and again got the “Failed to personalize” message, as I have for every update since. I guess this suggests the issue may be with some software I have on the computer, but Apple was unable to solve the problem in my case.

2 Likes

Thank you for this article on the “personalize” problem. I had to deal with it on my iMac. I couldn’t find guidance using that term, but I eventually resolved it through the
Recovery route. Jim Wheelis

Running Monterrey (12.7.5) on an 2019 Retina 5K iMac and Ventura on M1 MBPro Ultra and M2 Air.

App Store says MacOS 14 required for Configurator. Haven’t tried downloading with the laptops running Ventura yet.

Any way to get around this?

Thanks!

Maybe one solution is to install MacOS Sonoma on an USB stick or external drive. Then boot from that drive to get Configurator and try to update the firmware.
Another solution may be (have not tested it) is to use Configurator from your Macbook Air conected to the iMac with an Apple USB charge cable.

Many thanks for this article! I have been struggling with this issue for months on a MacMini 2018, i.e. still with an Intel processor. The only way to update system software (now Sonoma) was in recovery mode. I am looking forward to use this solution.

This was an interesting article; thank you. I checked, and my MacBook Air M1 (2020) running macOS Big Sur 11.7.10 has firmware version 10151.1.1 rather than 10151.121.1. Since I have lost most of the technical expertise that I had years ago, I would like to ignore the discrepancy and do nothing. FWIW, I installed 11.7.10 last September and have experienced no (new) problems since then.

There are three recurring issues with the MBA, and I wonder if the firmware could be causing or contributing to any of them.

First, Time Machine will not complete a backup, either to a Time Capsule or an external (spinning) disk. It used to, but stopped working two or three macOS updates ago. It does seem to back up everything from ~, and I suspect that the issue is permissions on some file that is near the end of a backup session.

Second, keystrokes are sometimes doubled. In other words, I’ll type a character and it will appear twice. Again, this has been going on for a long time. It is rare but annoyingly frequent, and it happens on both the external and internal keyboard.

Third, the external display will sometimes go blank for about two to six seconds. This has happened 22 times so far this calendar year (and like the other issues, has been occurring for years), sometimes twice in one day and one time it didn’t happen for 35 days. I cannot detect any common trigger.

So, what is the downside to doing nothing (and staying at firmware 10151.1.1, at least until I get around to upgrading macOS to something more modern)? Is it likely that any of the three issues is caused or aggravated by the out-of-date firmware? Thanks for any guidance.

And @lalicata deserves the lion’s share of credit for tracking it down and reporting the experience here!

1 Like

Well, it would seem that the downside is living with those problems, when you might not have to. :slight_smile:

There’s no way to tell, but a combination of a very old version of macOS and old firmware could explain it. Unless you have an important reason to stick with Big Sur, like an app that won’t run on a later version, I can’t see any reason not to upgrade to Sonoma.

Jon Lindemann

3 June 2024: Jon, I did NOT want to go to 14.5 but the Apple Engineers were quite sure that there was absolutely no way to fix my problem unless I went to 14.5. One did let it slip that in the future, do not discard the Configurator app that works with that system software. It was never said but I got the feeling that each major software jump gets its own configurator. Lee

Hi. This is Lee. I tried this with an Apple Engineer on Monday when I did not have the right cable on hand, Did not work. No amount of petting, stroking, talking nice, yelling, screaming, cursing, pleading, weeping, or begging could get the Configurator2 app to recognize the system software on the USB stick AND make active the “restore” command. I think, but am not sure at all that the firmware that is being updated on the faulty Mac must be read from a well behaving Mac. I am SWAGGING this.

Well, I don’t know. I’m using Excel version 16.16.27, and it’s a bit flaky (editing conditional formatting almost always causes a crash), but it’s a lot more important to me than trying to fix any of the three annoyances I mentioned, especially if the fix only “might” take care of the problem. Does anyone know if my 2018 (copyright date from About Excel) version of Excel would work with Sonoma? Ventura?

My plan is to get a new MBA and install an up-to-date version of Office and try to make sure that everything works, then upgrade macOS on the old MBA and install an up-to-date version of Office, and then retire my MacBook Air from early 2015.

My Excel v16.16.27 (I suppose that is Excel 2016) works just fine on Sonoma on this 14" MBP. And this is in spite of having to go through Rosetta 2 translation. :+1:

Granted, it’s not getting any updates anymore, but I couldn’t care less. In fact, I prefer the peace and quiet that comes with not getting constant MS updater nags. I’m never going to allow Excel to dao anythign that could endanger my system anyway.

I had this with my M1 and a Dell 4K display I was using external retina display. I believe the 60Hz 4K USB-C to HDMI dongle I was using wasn’t quite up to the task, as I’d read other reports of the issue on the Amazon listing for that adapter. It felt to me like a bad clock or refresh sync, but I too can’t explain the sporadic nature of it happening.

Anyway, I stopped using that display as it wasn’t really mine. My wife uses it with her late-2013 Intel MBP and has no issues. These days I use a non-retina display, for my sins.

Random intermittent display blanking, especially when using digital interfaces like DVI, HDMI and DisplayPort, usually means that you’ve got a weak or marginal signal. When the display loses signal, it goes black.

As @gingerbeardman pointed out, this can be due to problem cables or adapters. Higher resolutions require more bandwidth and cables designed for a lower-resolution may not be able to handle higher resolutions.

For example, there are four different types of HDMI cable (c.f. Wikipedia: HDMI: Cables and HDMI: Refresh frequency limits for standard video):

  • Standard (aka “Category 1”)
    • Approximately 5 Gbit/s (4 Gbit/s of usable data)
    • Good for all HDMI 1.0 through 1.2 features
    • 1080p at 60 Hz. 1440p at 30 Hz. Not suitable for HDR content.
  • High speed (aka “Category 2”)
    • Approximatgely 10 Gbit/s (8 Gbit/s of usable data)
    • Good for HDMI 1.0 through 1.4 features
    • 1080p at 144 Hz, 1440p at 75 Hz, 4K at 30 Hz. Lower maximum refresh rates for HDR content.
  • Premium High speed (also category 2, but with tighter testing requirements)
    • Approximately 18 Gbit/s (14 Gbit/s usable)
    • Good for HDMI 2.0 features
    • 1440p at 144 Hz, 4K at 60 Hz, 5K at 30 Hz. Lower maximum refresh rates for HDR content.
  • Ultra high speed (aka “Category 3”)
    • Approximately 48 Gbit/s (42 Gbit/s usable)
    • Good for HDMI 2.1 features
    • 1440p at 240 Hz, 4K at 144 Hz, 5K at 60 Hz, 8K at 30 Hz, 10K at 30 Hz.

Similarly, DisplayPort cables are certified for certain transmission modes (c.f. Wikipedia: DisplayPort: Cable bandwidth and certifications and DisplayPort: Refresh frequency limits for standard video/):

  • Standard
    • Supports up to HBR2 signaling (21.6 Gbit/s)
    • 1080p at 240 Hz, 1440p at 165 Hz, 4K at 75 Hz, 5K at 30 Hz. Lower maximum refresh rates for HDR content.
  • DP8K
    • HBR3 (32.4 Gbit/s)
    • 1440p at 240 Hz, 4K at 120 Hz, 5K at 60 Hz, 8K at 30 Hz. Lower maximum refresh rates for HDR content.
  • DP40
    • UHBR10 (40 Gbit/s)
    • 4K at 144 Hz, 5K at 60 Hz, 8K at 30 Hz. Lower maximum refresh rates for HDR content.
  • DP54
    • UHBR13.5 (54 Gbit/s)
    • 4K at 144 Hz, 5K at 120 Hz, 8K at 60 Hz. Lower maximum refresh rates for HDR content.
  • DP80
    • UHBR20 (80 Gbit/s)
    • 4K at 240 Hz, 5K at 180 Hz, 8K at 85 Hz. Lower maximum refresh rates for HDR content.

Cables certified for one category may work for with frequencies beyond the certified maximum, especially at shorter lengths, but it’s not guaranteed. And the further you go beyond the certified maximum, the less likely it will work. A cable that doesn’t meet the needs of your data, but comes close may work/fail intermittently or produce artifacts in the image.

3 Likes

Thanks, @Simon. Do you use conditional formatting in Excel? As I noted, editing (and sometimes just reviewing without changing) a conditional format rule usually causes an expected program termination.

And thank you to @gingerbeardman and @Shamino for the discussion of cables. That makes more sense than anything I thought of.

I’m using an Acer display that About This Mac tells me is 2560 x 1440, which I understand is definitely sub-Retina. The Displays pane in System Preferences shows 60 Hz (and is unchangeable).

I am using an HDMI cable; I believe it came with the display, but I’m not sure. I also have what was billed as a higher quality HDMI cable, but it’s much longer, so it might not fix the problem. [Edit to add: “8K UHD” is on the connectors, and I believe it’s 12 feet long, compared to about 18 inches for the one in use.] When I first got the display, I connected the Mac using a USB-C cable. I do not recall if I had screen blackouts then. (I have been using the HDMI cable, and an Anker USB hub with ethernet and HDMI ports, for some years now.) When I get a moment (probably the next time the screen blacks out), I’ll switch to a Thunderbolt cable.

Thanks for all the responses on this off-topic sub-thread.

The cables bundled with displays should work for that display, but they may not be certified for anything in partiular.

An “8K UHD” marking on a cable is just marketing and may not mean anything beyond the cable manufacturer’s wishful thinking. A certified (meaning it passed official tests) HDMI cable will have one of the four buzzwords: Standard, High Speed, Premium High Speed, or Ultra High Speed. And the cables certified in the latter two categories will include a certification label that includes several anti-counterfeiting features (like per-cable serial numbers and QR codes).

See also HDMI Cable Overview, which has links to two articles describing how to spot genuine certification labeling.

Mind you, an uncertified cable may work just fine, and there are plenty of good manufacturers that don’t bother with it. But without it, you’re relying on the integrity of the manufacturer.

Another useful/interesting resource is a Linus Tech Tips article from 2021: I Spent a THOUSAND Dollars on HDMI Cables… for Science.

1 Like

Apparently neither of my cables is certified for any level.

Yesterday, I replaced the combination Vava USB hub and HDMI cable with a Thunderbolt cable (at least, it has a thunderbolt symbol at each end) from the Mac to the Acer display. Today, I had a screen blackout. Ah, well, the blackouts rarely happen twice in one day and they (so far) go away on their own after some seconds.

One thing I neglected to mention is that I occasionally use a MacBook with the Vava hub and HDMI cable, and it has never (as far as I can recall) had a blackout, so maybe it’s something about the MacBook Air rather than the cable. Even if it is the cable, it’s not a big problem, so maybe it’s time to return this thread to the original topic.

Thank you for the discussion and technical information.