(Solved) Problem of Spotlight not finding contents of Home folder unless searching from This Mac

I just migrated from a Intel MacBook Pro 2017 to a M1 MacBook Air 2022. I used Migration Assistant directly from the older computer (via a USB-C cable) when I first started up the new computer.

I have a weird problem with Spotlight:
It can find files only if I search from “This Mac”, but not if I search in my “Home” folder, or any subdirectories of the “Home” folder.

e.g. if I search for files with names containing “garage” in This Mac, it finds ~/Music/Garageband which is within the Home folder.

But if I do the same search in my home folder, no results return. Even though ~/Music/Garageband is within the Home folder.

ccf is the Home folder name in the screenshots.

Searches within for anything in the home folder never reveal any results. Search by kind, or extension, or name etc.

Starting a search in ~/Downloads doesn’t find anything.

But searching in /Applications (not in the Home folder) works fine.

I’ve tried:

  1. resetting the Spotlight command
    sudo mdutil -E /

  2. Also tried resetting Spotlight, and “Repairing Permissions” with the CleanMyMac X app via Setapp.

  3. Booting into Recovery Mode, and running Disk Utility First Aid on all the Volumes I can (even though I only have one partition)

Searching via the Spotlight Search box (command-space) finds files.

A side effect is that Hazel won’t find matches using the “Contents Contain”. But will find matches using “Contents Contain Match”. I am guessing that the “Contents Contain” feature relies on Spotlight.

Any ideas on how to fix this?

The only thing I could think of would be to check the privacy tab in Spotlight System Preferences and see if anything is listed there under Prevent Spotlight from searching these locations.

There’s some tips here as well including re-indexing the spotlight search.

1 Like

You don’t mention what OS you’re running. Monterey has a bad memory leak problem which has never been resolved:

You might try HoudahSpot to see if you get better results. Spotlight’s performance, in my opinion, has dropped precipitously since Mojave. Houdah has demo available:

Here’s an updated reference. Refer to Howard’s site for a complete discussion:

Try number 7. Re-indexing has helped me with this problem several times in the past.

1 Like

Solved. Number 7 worked for me as well.

Looks like adding the whole drive to the Privacy box, and then removing it, does something extra that the sudo mdutil -E / doesn’t.

Interesting to me is that, I tried adding just my Home folder into the privacy box, but results from my Home folder would still appear when searching under “This Mac”. It’s only when I added the whole drive to the Privacy list, that results from my Home folder stopped showing. After removing all entries from the Privacy list, all the searches started working again.

Hazel “Contents Contain” conditions works like it should now.

I was on Monterey 12.3.1

4 Likes

In addition to the previously mentioned HoudaSpot it’s also worth mentioning Alfred’s search capabilities. I’ve abandoned Spotlight entirely for Alfred’s faster, more comprehensive and flexible results. The app gives you the option to do many things with the results, such as copying a phone number from a found contact without opening the Contacts app and using a hot key to open a found file shown in the list of results. It’s been a game changer for me and I use it dozens of times a day to find, launch, copy and take other actions on files, contacts and apps. I highly recommend it.