[Solved!] Connected-to-WiFi-but-not-the-internet

It’s been years — OK, literally decades! — since I’ve had the temerity to try running a beta version of macOS. I think it was Mac OS 7 or 8, “Copeland,” which was then never released.

But a lot of people, fortunately, do. And a fair number of those trying out Ventura 13.4 reported a problem where they were both apparently and demonstrably connected to their local LANs via Wi-Fi (or ethernet), but were not then able to reach the internet at all. From my vantage, it looked much like a DNS problem. Here are a couple of such reports/threads:



Apple Developers:


It looks like almost everyone was able to work around this by deleting Little Snitch and/or their VPN software.

I just hit the identical situation when updating to (official release) macOS 13.4.1, and I do not have Little Snitch or any real VPN software (other than Cloudflare WARP, which is only quasi-VPN) installed. Uninstalling WARP had no effect on my difficulties.

The symptoms were just as you’d expect from the description on the box:

  1. I could AirDrop, print, and file share on my local network with no problems.
  2. Other devices on my LAN had no problems using the internet.
  3. My Mac, however, was able to load a web page or retrieve email in only about 5% of my attempts; 95% of the sites I tried to load came back with “you are not connected to the internet,” no matter what web browser I used.

This was terribly frustratinng!

Early in the analysis process, I tried Safe Booting — which, surprisingly, acted in exactly the same way! I was nearly certain I’d have to wipe my disk and start all over with a brand-new system installation.

I spent hours, then, playing with network and wi-fi settings in the profoundly awful new System Settings app. It didn’t help that 90% of the time clicking on the “Details…” button brings up … nothing at all. Still, I kept plugging away, trying various combinations of turning off “Limit IP address tracking” and explicitly entering DNS servers, and frequently deleting my DNS cache. To no avail.

BUT then I remembered that I’d read that Apple had removed network “Locations” early on in the betas of Ventura 13.0:

I was pretty sure I’d read that they’d ultimately restored it — whether because of feedback from IT staff or because that was the plan all along, I don’t know. So, I looked. Then, I looked some more — because the new System Settings dialog is really really awful (did I mention?).

Finally, I found it! It’s the last option off of the button labelled “…” at the bottom of the Network panel:

I had three defined locations. I deleted two of them. Instantly, everything just worked. Perhaps someone facing the same issue will find this and save themselves a few hours of hitting their head on the table.

What gets me, though, is that the problem was absolutely identical when I used Safe Boot. Isn’t that supposed to be a generic system that knows nothing about your locations and networks, &c.? I’ve lost too much time to this to spend any more experimenting — but if anyone wants to look further, I’d be very interested as to whether their normal-boot network locations are visible (and operative!) when they’ve safe-booted.

Toughest networking problem I’ve had to solve in at least 25 years…


So when all else fails look for the “…” icon!
Thank you for the tip. So far I haven’t had this problem but will keep it in mind.

Nice hunting. So often with upgrades, issues arise with one small change moved to where you never look. Half the issue is our experience. This looks like a feature returned but designed to wither through obscurity. I wonder what the thinking is, Locations can be very useful.

I periodically experience the same symptoms (connected to WiFi but not the Internet), but not for the same reason. The symptom is that Internet performance (web pages, etc.) slows over a 24 hour period, and then fails completely (for all my devices, Macs, iPads, iPhones, Apple TV). The reason is that Cox pushes out cable modem firmware updates every 60 days or so. It happens at night, but then the next day I start seeing the symptoms. The solution is to reboot the WiFi router, and then all is fine (until Cox updates again). This happens so regularly that I recognize the symptoms quickly and reboot the router. I have asked Cox techs about this - never got an explanation. This has happened with the Cox cable Modem and my own cable modem that I installed when I got tired of paying the rental fees. It has also happened with two different WiFi routers. Very strange.

I’ve experienced a “good LAN connection/no WAN connection” problem with the newer OS versions; sometimes it’s ethernet, sometimes it’s WiFi. Whichever one can’t connect gives me an error message about having a self-assigned IP address. It seems like whichever connected first has the blessed IP address. I copy the address of whichever one can connect and then also use that address for the one that is not connecting to the internet. So far, that is working.

I once tried to deliberately do this. I had two older iMacs, one connected to my scanners for digitizing negatives, and the other connected to a lot of external drives for photo storage and all my digitized movies. The time came when neither could be updated with new software and I was concerned about them being connected to the internet 24/7. If I remember correctly, I changed the subnet mask to something like all zeros, and that way I could use the LAN to move photos to the storage attached to the server, and could watch a movie on my MBA, I believe I even used Locations to save the LAN-only config, as well as a more normal one (there’s a new version of VueScan every time you open it! - and that needs internet access.)

1 Like

Over the past few days, I’ve been mulling over just exactly why I had defined any locations. When I deleted them, I thought only about the fact that it had been many months or perhaps years since I’d last used the Network Locations facility to change my network settings at all — and since it was clear that I wasn’t using them, and since I had good backups, I just went ahead and deleted them without looking into how the settings might have differed among them.

Coincidentally, I just tripped over my own comment to a post here, which makes it all clear. It was to work around a Monterey bug!

There’s a lesson here somewhere…

I always thought safe booting only disabled third-party stuff. I don’t think settings in the Apple-native network control panel would qualify as third-party.

Would it help to manually assign (static) IP addresses to critical devices in the router settings?
I did this for my Homepods and AppleTV several years ago to fix wifi connection problems (the original Homepods seem to have difficulty with the latest “smart” routers).

Not so. Safe booting only loads software that is absolutely essential, which does mean that some Apple and second party software is not loaded.

That said, I don’t know whether location determination is enabled under safe boot or not. Because it’s been decades since I’ve had the need to define more than one location and my iMac never moves, I’m not in a position to check.