Solve Credit Cards Not Appearing in 1Password 8 Autofill Pop-Up

Originally published at: Solve Credit Cards Not Appearing in 1Password 8 Autofill Pop-Up - TidBITS

Annoyed by several of his credit cards not showing up in 1Password’s autofill pop-up, Adam Engst spelunked through the card metadata and found the offending field.


I’m glad to know that you are getting closer to finding out what is causing the problem, and that 1 Password is assisting you in that endeavour. I have to say though that I initially concluded just the opposite when I read this sentence in your introduction to this week’s edition:
[…] Adam solved the problem and has started trying to figure out what went wrong with 1Password support. Perhaps changing it to “*has started, with 1Password support, trying to figure out what went wrong.” Just a suggestion.

I find it interesting that 1Password is possibly the only password manager to offer autofill of credit card info. None of the Keepass apps do, nor does Bitwarden. Wondering why that’s not possible with other apps?

@ace , I’m really puzzled by the statement in the article that you

don’t know how a website entry ended up in the Additional Details section because you can’t add one manually—the website option appears only when adding fields to Contact Information.

I just checked this in 1Password v. 8.10.28, and I certainly can add a URL in the Additional Details section for a credit card entry. This screenshot shows the popup menu for “add another field”:

And this one shows the result of adding the “TidBITs” web site URL to that field:


(Handy in case TidBITs decides to start issuing an affinity card!!)

I added, routinely, the issuer’s URL printed on a physical card when I entered the details into 1PW (have been doing that since I started using it around 2009 or so). It was possible then, and it is possible now, without moving it into the “Additional Details” section.

Hope this helps in tracking down the issue, Adam!

Urk… I’ve recast it to avoid any confusion. :slight_smile:

Yes, but that’s a “url” entry, not a “website” entry. They might both contain a URL, but the issue I’m dealing with is a spurious “website” entry.

Got it, Adam. But it leaves me wondering how and from where 1PW would capture a spurious website entry. As I’m sure it does you.

If your cards were entered manually (and not by, say, scanning and capturing the text such as one might for Apple Wallet), I just don’t see how a website could even be associated with a credit card unless that site was entered in the URL field.

I’ll be following this thread in case the AgileBits folks can shed some light on it.

I worked with increasingly higher levels of support, and they’re still not sure how it happened, but they’re continuing to investigate the code. It doesn’t seem like this is a common problem, so hopefully, no one else is running into it.