Software update spins but never completes

I am running macOS Big Sur 11.6.2. I want to update to 11.6.3. After clicking on Software Update, I get spinning wheel next to Checking for updates… It never completes.
What is wrong? How can I get the update?

I’ve found that when the regular UI way of doing things fails, it’s easiest just to use Terminal:

sudo softwareupdate -i --all --restart

This will install all available updates and reboot if needed.

1 Like

Same thing happens.
Software Update Tool displays “Finding available software”
It never completes.

Fortunately for me, I don’t have the problem. But if I did, would the terminal command take me from 11.6.2 to the latest version of Monterey (my Mac keeps inviting me to update to Monterey) rather than to 11.6.3?

@DavidS4001, that sounds like softwareupdated is either hung or not able to contact Apple’s servers. Have you tried rebooting? Also, are you using any sort of adware prevention tool which might keep you from reaching Apple’s servers?

@Will_M, I my experience, no, it won’t automatically do a major OS update. I’ve used this command line procedure when running Big Sur and not had it upgrade me to Monterey.

You can tell what updates would be performed with the --all option by running this command first:

softwareupdate --list

1 Like

I received this reply from P. Phillips on the Apple discussion forum:
“Check in Applications folder for a new application called " Install Monterey” - yes Monterey macOS 12. If it exists and one does Not what to upGrade - Drag and Drop to Trash and Empty Trash."
That worked! I’m not sure how the Monterey installer got downloaded. I’m no where near ready to install it. And I do not understand why it prevented the update to be found.

1 Like

Apple seems to have pushed it down onto everybody (twice, so far). They aren’t trying to run the installer (fortunately), but they are downloading it, even if you have Software Update configured to not auto-download updates.

Bug or evil? I’ll leave that as an exercise for the reader.

That’s a much more interesting question. The presence of that installer shouldn’t break the search for updates.

This is almost certainly a bug.

1 Like

I had the same problem. I restarted using Safe Boot and Software Update worked correctly while in that mode. After 11.6.3 was installed, I still had the endless Checking for updates problem but restarting one more time cleared it up.


I did 11.6.3 last week and it took a very long time (like 2 hours) to find the update and start downloading it. I presumed the server was have a coffee or was just tired, as these things do.

But thanks to all for pointing out the Monterey download that Apple has so graciously done for me… glad I wasn’t on my hotspot when it did that. There are polite words for companies that download 12GB without warning, but I can’t think of any just now.

does this direct link to the update work?

Not sure what you are asking and why here. Does it not work for you? It is the correct link to Apple’s Big Sur Preview site and does offer to open the App Store Big Sur page.