So what's the deal with incessant Siri nagging? [caution: contains rant]

Every single Big Sur update now regardless of how minuscule (and we know how many of those there have been) after the update has completed and the Mac has restarted (so basically ~30 min and ~3GB later), Apple thinks they need to again nag me about stupid Siri and with that plug hold up the entire login and app restart process. How many times do I need to tell you guys to **** off with that junk and leave me alone? Don’t you think if I wanted Siri I would have agreed that last three dozen times you peddled her to me? Do you think I suffer from some kind of reading comprehension issue? God, when did Apple become a company that put marketing in their existing customers’ faces ahead of said customers’ user experience? If you want people to install Siri, just make her better. It’s not like the world just hasn’t heard about her yet. So stop acting like the new found lovechild of Google and Facebook for Pete’s sake.

Hmm. OK. … Now that I got that rant out of the way :wink: can anybody point me to some kind of option to permanently say no to Siri on Mac? These updates are frequent and lengthy as is. I just want my Mac to restart and re-open all my apps by the time I come back to it. No nagging, no baloney. Is there some kind of secret handshake here perhaps? Or can I somehow tear Siri’s guts out of my macOS installation to get the peddling to go away?


I’m a little confused—when you are seeing this dialog? At update? Have you tried just enabling Siri once and then turning it off?

Personally, I have Siri enabled, but ignore it on the Mac. Doesn’t seem to have any downside and I don’t get any nags.

After the update is complete and the Mac has restarted, but before throwing you back into your user session (and holding up that last step).

I have that totally inscrutable problem with the first boot after an update, so I stand no chance of being able to reproduce this, but I’d try enabling Siri once and then disabling. It’s possible that if you’ve never enabled Siri, there’s a flag set to nag you to try it, and just enabling and disabling will reset that flag.

I get this nag every time there’s an update, too, but it really doesn’t bother me all that much. I just uncheck and hit next. I guess I’ll try Adam’s suggestion next just to see if that works.

I’ve seen this too. Not only that, but if you turn off iCloud sync for Documents & Desktop, it asks you about that too.

I’ve never turned Siri on any Mac that I’ve owned. The last thing I need is another device listening to not give me the information I want or do what I ask. It’s bad enough when I ask my iPhone something via Hey Siri and the HomePod down the hall in the living room answers but I can’t hear it because it’s too far away.

(If only there was a way to give different devices different hailing words, which Alexa has been able to do for like 10 years now.)

Every point update also:

I now have scripts to re-enable all of those because they happen so frequently and I never remember the exact syntax.