Share Screen Firewall Problem?

I’ve been having a problem with “Share Screen” option to remotely control my mom’s iMac.
been having the problem for a while and thought is was an Mac OS compatibility issue.
Today I updated both my and her computer to the latest Sonoma 14.2.1.

Whenever I try to Share her screen I get a dialogue box saying " Unable to communicate with “user”. Make sure the remote computer is available and the firewall is not blocking screen sharing"

Yes I’ve checked the firewall dialogue in System preferences and it is off.
And Screen Sharing option is on.

The only other thing that changes is she switched to Verizon from Xfinity and maybe the new router is blocking? Not sure what setting if any needs to be adjusted.

This is a long shot, but is one of you connected to a VPN of some sort that would have an additional firewall? When I’m connected to my work VPN, all traffic is funneled through the company firewall and I can’t use Mac screen sharing.


Hey Dave,
Thanks but that’s not the case. I was trying to set that up as an alternative option, but wasn’t having any success with that either.
As a side note using screen sharing via the Zoom app works fine.
So its frustrating as this was working fine until sometime after Ventura was installed last year or the switch to Verizon… I’ll do some more troubleshooting.

That’s the angle I’d focus on. Have you seen this thread? It may have some suggestions of things you haven’t tried.

Jeff, thanks for the thread link. I will try out one of the 3rd party apps as a test.
But it seems crazy that I should have to use a different app rather than the built in Screen Share app.
It worked flawlessly for so long.
As an fyi I can use screen share while I’m on the same LAN. Won’t work when I’m at my house… which is when I need it to work of course!

I haven’t tried it but this page suggests a different approach for remote screen sharing using the other computer’s AppleID:

How are you initiating the screen share? Do you start in a FaceTime call? Or use Messages? Or just try to connect directly by IP (is this option still available?)

The preferred approaches these days appear to be FaceTime or Messages…

Thanks for the suggestions.
I believe I solved this issue.
I had to open the 5900-5902 ports on the router. I’m a mac guy for sure, but not an IT specialist, so I needed to read up on doing this.
And I can only connect by using the Screen Share app and using the computers public IP address
(and sign into the computer with the log in credentials)
It solves the access problem, but I still cannot “just use” the ‘Ask to Share Screen’ option via Messages app, as I once did.
Thanks to everyone for the feedback.

When I’ve had connection problems with another person’s Mac (using iMessage to start the process) I have had success (most times) getting that person to start the process of Sharing Their Screen with me “accepting” the dialogue box.
One just needs to talk them through the process of where to click in iMessage on their screen.
Good luck :wink:

Glad you got it working! But if you use iMessage or FaceTime, you shouldn’t have to make any router adjustments since, I believe, the cloud helps negotiate the connection by using a socket that is already active in the firewall.

yes I usually use/used iMessage. The problem is: iMessage would initiate the connection and after clicking accept, the shared window would open for .5 of a second then the connection would close with a dialogue box popping up stating “Unable to communicate with “user”. Make sure the remote computer is available and the firewall is not blocking screen sharing”
So it’s been frustrating!

Ah. Fun times. I have definitely seen some flakiness along those lines myself when trying to use Messages or FaceTime to set up screen sharing. Sometimes it appeared to help starting a new call. It’s possible your approach could mitigate those issues.

Good luck!