Send To Kindle app broken on MacOS?

Has anyone else tried using the latest version of Amazon’s “Send To Kindle” app? Apparently on December 22 they released a version,, that can finally upload ePub files to your Kindle library, and as a consequence Take Control books has stopped releasing MOBI files.

I attempted to upload the latest version of one of my Take Control books, so I booted up Send To Kindle, clicked my assent to updating the app, and then…I got a non-working Send To Kindle app. Any attempt to boot it up causes it to bounce once in the Dock, but it doesn’t actually boot up, there’s no error message, and there’s no Kindle-related processes in Activity Monitor. Tried restarting my MBP in case there was some hanger-on process blocking the app, but no dice.

I’m still running Monterey on my 2017 MacBook Pro - I’m trying to update to at least Big Sur, but I’ve got a couple 32-bit apps I need to replace, including PowerMail, which holds 25 years of emails in it, and I’m trying to not lose all that information. I was wondering if Mojave was the problem (in which case the app shouldn’t have offered to update to a non-working version), and if anyone else has also found the Send To Kindle app non-working on whatever version of MacOS they’re using.

I wound up using Amazon’s web interface to upload the ePub file, but annoyingly it assumes the file name is the book’s title (the app allowed you to type in the title), and it seems to munge up the cover, so that the book appears as a generic document in the MacOS Kindle app. I’ve attempted to send Amazon feedback after clicking around for five minutes trying to find a way to contact them, but I have no faith that anyone will actually read the email I sent.

Amazon released a new hardened DRM on 3 Jan 23 and is also not allowing anything published after that date to use their Download and Install via USB option. So if you updated your app after that date, it may be a factor.

No, that can’t be related. Like I said, I was able to upload, and then download to various Kindle devices, the Take Control book via their web interface. The problem is the newest version of the Send To Kindle app simply won’t run; bounces once in the Dock, but never actually opens, and doesn’t throw up any kind of error message. The previous version, prior to updating itself, worked without a hitch, but they don’t make older versions available on their web site, and they use an installer that automatically throws itself away once run, so I don’t have the older installer in my archive of downloaded software.

I stopped using Send to Kindle because the program stopped working on my MacBook Pro M1 Pro with Monterey, I tried a new install but the login failed and Amazon wanted me to reset my password. So I did that but on the next launch Send to Kindle wanted a password reset. It was an endless loop.

I gave up on Send to Kindle.

Now I just send the file I want to upload via my Kindle’s email address.

They sure don’t make it easy to let them know their app is broken. Or maybe they don’t even make it possible; I rooted around their site and turned up an “app feedback” email address, and sent them a message saying Send To Kindle won’t run on my MacBook Pro along with specs, but the actual email address was “”. :roll_eyes: