Selecting old Printer Description Files

I’ve got an old but still perfectly working Xerox printer on my network. Existing computers can connect to it with full functionality. When adding the printer to a new computer, there is a “Use:” menu which offers
Auto Select
Generic Postscript Printer
Generic PCL Printer
Select Software…

Previously the routine was to choose “Other…” and then select a Printer Description File, a postscript file supplied by Xerox.

But now when I try to set it up on a new computer, and try to select this printer description file, the file is greyed out in the file selector.

Existing computers where the printer is already set up, still work with it even though their version of macOS has been updated. Even a new computer, with user migrated from an older one, has the migrated printer definition working fine. But if trying to to add it as a new printer it’s not possible to select this file, and so not possible to set it up properly. I can still set up the printer as a generic printer, but can’t then access all the features.

Does anyone know what the printer set up software is looking for when it decides whether to allow me to select the printer description file? Does it need a particular extension (I’ve tried .ppd and .PPD) ?



.ppd is right, so there must be something else that is the problem. Have you tried downloading a new driver from Xerox?

It’s a good question, and it is one that had been high on my personal list to investigate, until an old PoseScript printer that I loved needed a repair I couldn’t justify. It used to be the case that all you needed to do was drop a properly formatted PPD file in the proper directory (used to be /Library/Printers/PPDs/Resources/Contents), but somewhere along the way (Mojave? Catalina?), that stopped working.

The best solution, where possible, is to use the printer’s PPD installer program, but not all printers have such software, and the installers for many older printers are 32bit only, so they won’t run on Catalina or newer. It’s a real issue when the PPD for an old printer exposes much more functionality than is accessible via the generic PostScript drivers.

I would investigate whether the PPD file can be installed using the CUPS command line, i.e. using the “ppdi” command and/or “lpadmin”. I’m sure there is a way to get it working. Maybe I’ll investigate with an ancient Brother laser printer I have and a Ventura Mac.

1 Like