Security Update 2020-003 (Mojave and High Sierra)

For months now, on my wife’s High Sierra MBP every security update needs to be installed twice. I install it once and it downloads, installs, and restarts. Then upon launching the updates section I see that it claims the update is still there. So I select to install it again and it does the exact same thing: download, install, reboot. Then finally it claims no new updates. It’s a super annoying bug. And it’s been left this way without a fix now for months if not years. I don’t know how many updates I’ve had to install twice just because of this. Ugh. :exploding_head:

In this particular case, I think Apple has re-released Security Update 2020-03 for High Sierra, so it makes sense that you’d see it again.

But in general, I don’t have a good answer. I’ve not seen that problem before. I could imagine that if something caused the initial install to fail silently toward the end, it might try again and still show up in the logs as having completed twice. But that’s total speculation based on no evidenced whatsoever. :slight_smile:

What I saw in the past pretty regularly was that there would be a Safari and security update available and I’d tell it to install everything. It would download and install Safari, then download the security update and restart to supposedly install the update, but wouldn’t, and would eventually restart normally, but the security update would still be available to install, so I’d have to download it again, and then it would install. So what I’ve been doing recently is installing everything one at a time, with the security update last. That’s generally worked and it’s only taken one try to install the security update.

While there are probably lots of causes to this sort of behavior, installing things one at a time fixed it for me, so it’s worth a shot if you’re seeing a similar problem.

Sounds like the exact same thing I’ve been seeing on my wife’s MBP. Except that I already resorted to doing all updates separately and doing the security update at the very end. The security update still always seems to require two full installation cycles to actually acknowledge it’s been fully updated.

[This was posted in the thread about the spate of security-related updates that did not include Mojave, so I’m guessing that it’s associated with Security Update 2020-03. -Adam]

I received notice of an update for my Mac Pro running Mojave. I initiated the update. The process seemed to be working like all other updates. Then it shutdown like it was going to restart. Then it never started. Black screen. Let it run for half an hour. Never came back.
Shut it down, then tried restarting, with the same results.
I recently replaced the video card with an RX580. It worked just fine for over six months this way until this update.
Beware of this update. I really would like to know how to get my Mac working again.
Val Pistilli

Thanks, vpistilli. So the problem I reported in detail earlier in this thread occurs both in High Sierra (me) and in Mojave (you).

Adam, I read the TidBits notice of the replacement* for Security Update 2020-003, installed it, and still have this behavior: machine will not shut down, whether by shutdown command or by restart. (Cursor shows and moves; volume control keys show the popup and move the bar; other keyboard input recognized, but rejected with a dull beep.)

Power off, boot, runs as expected until next attempt to shutdown or to restart.

I still hope to see someone reply to my request for any suggestions of what to try before reinstalling High Sierra.

Also whether reinstall from Recovery partition is the way to do that.

Footnote: “Replacement” !! Let’s divert some of the rioters to Apple Park and have them take out the design department, or whoever decided that the name for the “replacement” update must–in order to preserve Apple’s reputation for a slick appearance–must not, can not, be allowed to be “Security Update 2020-003.1” or some such. At least break some windows. (Please remove this footnote if my suggestion is beyond the pale.)

Much as I hate to say it, yes, I’d ensure that you have current backups (because, always), and then reinstall macOS. You’ll have to be careful to get the right version—see

Thanks, much, Adam for the advice. And for the link.

I certainly will have good backups (a Carbon Copy Cloner total clone, which I update daily and will again just before reinstall (plus TimeMachine, should I need to use it)). The CCC clone drive is internal in my old Mac Pro. I’ll pull that and the other drives before the reinstall. Belt and Suspenders.

1 Like

It appears that there was an update to Mojave, at least that’s what came up when I clicked on “software update” a few days ago. After I did install the update, a change occurred which I don’t understand. For some reason photos I added to the Photos app by scanning them are no longer able to be displayed as desktop background. Everything was fine before this update, and I can’t seem to find out anything about why this happened. “About This Mac” still shows OS 14.6.

does security update 2020-003 include fixes from 2020-002 or must they be installed sequentially on Mojave?

Peter Donlevy

Security updates have been combo updates for years now, so yes it contains everything needed.

Thank you!

I’m using high sierra 10.13.6 and after applying the update i checked under Apple Menu > About This Mac > Overview > System Report > Software > Installations but the only listed Security Update is Security Update 2019-007 with Install Date:12/12/2019, 17:39 however when app store shows no updates available. any ideas?
can it be that i am used patcher to allow installation on my mbp 5.2 early 2009?

thanks in advance,

What’s the build number? ->About This Mac and click on the version number to see. Should be (17G13035) for 2020-003, but latest 2020-004 is out now which is (17G14019). 2019-007 is build (17G10021). If it’s (17G65) you only have 10.13.6 with none of the security updates that have come out over the last two years.

thanks for the reply!
->About This Mac shows version number 0.13.6 (17G14019) !
how can this be that security updates are not listed on System Report > Software > Installations?
that’s weird