Security Update 2019-002 (High Sierra and Sierra)

(Agen Schmitz) #1

Originally published at: https://tidbits.com/watchlist/security-update-2019-002-high-sierra-and-sierra/

Patches 15 security vulnerabilities in Apple’s last two operating systems. (Free, various sizes)

0 Likes

(Mark Nagata) #2

On March 26th, Software Update notified of “Security Update 2019-002”, and I updated my iMac 5K. ‘About This Mac’ window then showed “macOS High Sierra version 10.13.6 (17G6029)”.

On March 30th, Software Update notified again of “Security Update 2019-002”, and I updated my iMac 5K, then ‘About This Mac’ window showed “macOS High Sierra version 10.13.6 (17G6030)”. Safari version is currently 12.1 (13607.1.40.1.5).

0 Likes

(Al Varnell) #3

Apple explanation is at https://support.apple.com/HT209635

“These builds restore a number of security fixes that were missing from the previous build.”

-Al-

0 Likes

(guenther) #4

I have tried to update my iMac High Sierra 10.36 (17G5019). You should take the version number with a grain of salt because the update bombed and I had to restore using Time Machine. I tried twice but am now afraid since I have to update the entire disk. Has anyone else seen this issue and better yet has anyone been able to successfully update their system. Safari hs the current update number.

0 Likes

(Cam Lynn) #5

Yes, it seems this particular update bombed on quite a few of our systems causing more than a little inner turmoil and anguish. Once I was able to get the system responsive again I was again advised of the update. I updated again, and all has been well since. I hope I remember in the future to wait a few days before installing these updates.

0 Likes

(Joaquin Miller) #7

So, if I understand Apple’s industrial user interface design, the plan is this: When there is a pop-up suggesting a security update: open AppStore; look at the Security Update number, click to display installed updates; look through those to see if an update with that same number has already been installed; if so, do some sleuthing on the internet to see whether Apple has decided to issue two updates with the same identifier, wait, no, uh, recall that the Security Update number is not an identifier; let’s see, …, ah, invoke About this Mac, try to recall how to see the identifier of the operating system build already installed,oh, right, they hid that to get a slicker design, umm, let’s see, uh, oh, click on something to reveal the important data, which the typical user might never need, so that the display of which would be clutter, probably click Version number, yes!, there it is; now, try to recall how to discover the identifier of the update that the App Store wants you to make, try clicking “For more information on the security content of this update, see https://support.apple.com/kb/HT201222”; that seems generic, but scroll down, you will not find the identifier you want there but…; click on the slick pale blue text that goes so well with the hep grey of the rest of the text; now scroll down again; Bingo! there’s the identifier; compare it with the one that About this Mac hides from the typical user; there’s your answer: this is a new update; in it’s wisdom and style, Apple has decided to reuse the same Security Update number.

Now, that was easy.

We do admire Apple for keeping the interface simple and uncluttered. Easy to use.

0 Likes

(Ken) #8

I thought my High Sierra update had “bombed” on my Early 2011 17" MBP when the screen went dark for maybe 15 minutes, but it did come back, and everything seems normal now. Not a good user experience!

0 Likes

(Al Varnell) #9

That’s a common experience these days, now that Apple has moved all firmware updates to OS update installers. The includes EFI, SMC, SD, SSD, and other firmware. That’s probably what was happening during at least part of that time.

0 Likes

(scottman1987) #10

This update appears to have caused system instability. Sometimes the typing is super slow. Also, it caused an issue with Microsoft Remote Desktop. I find that the system becomes visually unresponsive, although I can tell the core continues to function. (Backups keep occurring).

0 Likes

(Adam Engst) #11

Ouch, sorry to hear it. Is that with Sierra or High Sierra?

It might be worth reinstalling macOS to see if that resolves the issue.

0 Likes

(scottman1987) #12

Sorry, yeah, High Sierra

0 Likes

(Al Varnell) #13

Have you applied the second version of Security Update 2019-002 for High Sierra? If so the build number should now be 17G6030. See https://support.apple.com/HT209635.

Also note that there was an update to Microsoft Remote Desktop v10.2.11 posted a day or two ago.
See https://itunes.apple.com/us/app/microsoft-remote-desktop-10/id1295203466?mt=12

-Al-

0 Likes

(Michael Josephy) #14

I’m another user who suffered Security Update 2019-002 10.13.6 problems. Last night I installed the update (presumably the second version) on my late 2009 iMac, but then it wouldn’t reboot, indicating a firmware problem. I ended up having to restore from Time Machine. The process took all night while I slept, and this morning the desktop was back to normal. Nevertheless it was a time-wasting nerve-racking experience. Should I try the update again? Better wait?

0 Likes

(Al Varnell) #15

What exactly did you observe that indicated a firmware problem? I have a theory that one must be connected to the Internet in order for the OS to conduct an EFI integrity check when it boots in order to download to the latest EFIAllowListAll. You can conduct your own EFI integrity check by entering the following into the Terminal app:

/usr/libexec/firmwarecheckers/eficheck/eficheck --integrity-check

If you post the results I might be able to better diagnose the issue.

-Al-

0 Likes

(Michael Josephy) #16

Thanks, Al. After trying to reboot, the onscreen error message mentioned firmware. Now I tried typing in Terminal your suggestion about an EFI integrity check (without knowing what that really means!) and just got

Michael:~ Michael$ /usr/libexec/firmwarecheckers/eficheck/eficheck --integrity-check

ReadBinaryFromKernel: No matching services found. Either this system is not supported by eficheck, or you need to re-load the kext

IntegrityCheck: couldn’t get EFI contents from kext

0 Likes

(Al Varnell) #17

Haven’t seen that one before, but it appears to indicate that this kernel extension:

/System/Library/Extensions/eficheck.kext

either isn’t working or didn’t load. That might happen if you were in Safe mode, but otherwise seems to indicates a problem with your OS.

If that’s the only problem, I guess you can live with it, but if you start seeing other unexplained issues then I would certainly go for restoring macOS from Recovery.

0 Likes

(scottman1987) #18

Yes, in fact, I didn’t start seeing the problems until I applied the second update.

However, Microsoft just released an update of RDP, on the heels of the second security update, mentioning having to make modifications due to this update. I applied that, and so far, so good.

0 Likes