Safari 12 Crashes Spotlight in Sierra—Here’s the Fix

I had the same issue, after upgrading to Safari on Macbook Pro running regular Sierra. This tip saved me from going crazy! Thank you so much!

I had to downgrade back to Safari 11.1.2 because of the .webloc problem. Just clicking on a .webloc file with the pointer is enough to crash the Finder in my case. I didn’t even get to the point where I could try to invoke QuickLook. It even happens on a fresh Sierra install on which you immediately apply Apple software updates. This problem is very hard to miss, so I am saddened and alarmed that Apple managed to miss it during QA testing. What’s worse is that this is STILL NOT FIXED in Safari 12.0.1.

Gary, there was a solution that worked for me, but I thought it was in this thread. No luck for you?


I am having same problems with MacOS 10.12.6.
The suggestions here (unchecking a few items in Spotlight) did not work for me.
Anything that invokes Quicklook of a Webloc item on my MacBookPro crashes Finder. AND the same thing happens in PathFinder, crashing that file manager app also! So it must be specific to Quick Look. Tom

Yes, this seems to be an ongoing bug with Safari 12. I’m not aware of any fix, apart from upgrading to 10.13 High Sierra, where the problem doesn’t occur.

With Spotlight, I think it has to do with web content being the first search result. The crash also happens to me when using either Quicklook or Cover Flow on .webloc files.

I am happy to finally find the fix above. I am still reluctant to move to High Sierra because of the change in file format that presumably makes going back challenging, and the fear of the expected drop of performance with most system upgrades. It was so annoying to get repeated crashes that I had just formatted my drive, made a fresh install of Sierra and imported my data back (several hours total) just to find the problem was not solved. Finally the tip above made the job, only a few seconds… Actions in the wrong order ! Thanks anyway.

I haven’t seen any valid complaints about APFS with SSD’s, in fact most of us are reporting increased performance from them. The only users that I know of that had to revert to HFS+ were HDD and Fusion Drive owners that were involved in early testing. I personally have had zero issues involving SSD APFS.

The only real issue has been for drive utility developers in receiving details late and somewhat incomplete in order for them to properly update their apps. Most are at least partially compatible at this time, with DiskWarrior still holding out.


Thanks for the thread… it did not solve the issue for me, but at least I now know why this is happening on my machine! :wink:

If you’re in list or icon view mode and double click on the .webloc file it opens fine, but trying to preview it in any mode causes the Finder to crash. Being in column causes Finder to crash immediately as I have preview column enabled. Once I turn that off I can also open .webloc files safely.

I also tried turning the various items in Spotlight preferences and have seen no change.

This thread: has a link to WebFinagler which will bulk convert .webloc files to Windows compatible .url files which do not crash the Finder.

For those of you comfortable on the command line there’s also

Now to avoid spending the afternoon figuring out how to wholesale convert every single .webloc file on my mac to .url files… hmm. I’m sure I could do it with find and xargs …



1 Like

-currently working for OS X 10.12.6
-Finder doesn’t crash when .weblock is clicked.
-Safari is able to launch the url.
-However, Quicklook views .weblocs as plain text files, bypassing the web preview generation.

Step 1
File: /System/Library/QuickLook/Web.qlgenerator/
Remove: <string></string>

Step 2
File: /System/Library/QuickLook/Text.qlgenerator/
Add: <string></string>

	<string></string> <!-- sierra-webloc-crashfix  -->

Step 3
Copy File: /System/Library/QuickLook/Text.qlgenerator
Move Copy:/Library/QuickLook/Text.qlgenerator

Step 4
Terminal Command: qlmanage -r

*Make sure to backup edited files as a failsafe.


I’m not sure your directions are complete. Don’t you first have to disable SIP to edit these files? When I try to save with BBedit I just get an error that it can’t save it maybe because I have SIP enabled?

Also, like someone else has mentioned in another thread, I don’t see the existence of the string in the plist.

Also, where you say “Location:” doesn’t match up with what I see in my plist. Do I paste everything you wrote here in the plist somewhere?

	<string></string> <!-- sierra-webloc-crashfix  -->

OR just this part somewhere?


Very confusing.

Hooray! It looks like Safari 12.0.3 finally fixed my running problem with Safari 12! This is the first Safari 12 update I tried that didn’t introduce the .webloc crashing problem (see my 11/21/2018 entry above). I tested with both a fresh Sierra (10.12.6) install, and my fully up to date copy of Sierra that I had downgraded back to Safari 11.1.2. In both cases updating to Safari 12.0.3 did NOT introduce the .webloc crashing that I encountered after every previous Safari 12 update (12, 12.0.1, and 12.0.2).

The curse has lifted!

Does Safari 12.1 bring the Quick Look Finder crash back in Sierra or does it remain fixed?

Appears to be as I can’t seem to make it crash.

There is no longer a <string></string> in the info.plist, but there isn’t a <string></string>, either.

1 Like

With Safari 12.1, did they fix the issue where Quick Look on webloc files doesn’t show a website preview in Sierra or is that still broken and only showing a generic webloc thumbnail?

Is that really an issue? I don’t normally deal with webloc files, so I don’t know that it shows a website preview in a different OS, but to answer your question, it still? shows a generic weblog thumbnail.

The only quicklook generator in /System/Library/Quicklook/ is one for WebArchives, and that does show a thumbnail.


1 Like

Yeah, before the update to Safari that caused crashes, you could use Quick Look on webloc files and it would pull website data off the Internet and show the site just like Quick Look works on images and videos.

Then after Apple fixed the crash with Safari 12.0.3, they didn’t re-enable that capability and we still just see generic thumbnails in Sierra. Not sure about other macOS versions however.

I see only the generic thumbnail in High Sierra. Will let you know about Mojave when I get back to it later this week.


1 Like

Wow, I wonder if they killed it for every macOS version? Guess there was a security issue perhaps with the feature they couldn’t or wouldn’t resolve. Then again, last I checked it was still working in High Sierra, just not Sierra. Strange that it’s not working for you.

I looked thorough all the Apple Security notes yesterday to see if I could locate anything along those lines, but have not been able to. There was some speculation about this back in January when Safari 12.0.3 came out, but nothing to confirm.

I know there was an issue with Browser Address Bar spoofing back in 2015 which was fixed long ago, so perhaps it’s related to that.

1 Like