Safari 12 Crashes Spotlight in Sierra—Here’s the Fix


(Adam Engst) #1

Originally published at: https://tidbits.com/2018/10/01/safari-12-crashes-spotlight-in-sierra-heres-the-fix/

TidBITS readers have reported a conflict between Safari 12 and Spotlight in macOS 10.12 Sierra, where invoking Spotlight and typing causes it to crash. Happily, there’s a simple fix.


Finder crashed by any QuickLook at .webloc files in MacOS10.12
(MR) #2

I have been experiencing a different type of crash that happens repeatedly and reliably in Sierra: invoking Quick Look on a .webloc file crashes the Finder, instead of displaying a Quick Look view of the web page. Could these two crashes be related? Anyone else experiencing this Quick Look / Finder crash?


(Matt Neuburg) #3

Wow, great tip! I’ve been experiencing the crash, and I’d also noticed that it only happens when the spotlight search contains certain letters. Moreover, I had a different workaround: don’t use the Spotlight window, just use the Search field in the Finder (or use NotLight, of course). In other words, the bug is the Spotlight window only. But your solution is better.


(Adam Engst) #4

Thanks, Matt! Not having a Sierra Mac handy, I couldn’t test this as fully as I would have liked—I was wondering about the Search field in Finder windows. I’ll tweak the article to work these facts in.

Now I’m wondering what the letters are that crash Spotlight. And I’m getting flashbacks to “Letterman” from Sesame Street. :slight_smile:


(mstrickland) #5

I have the same problem with 10.12.6 where Finder crashes when accessing a WEBLOC file under some ways. I have yet to find a solution.

One quirk is a double click of a WEBLOC on the desktop launches Safari but if inside a folder/directory it crashes Finder but does not launch Safari. I can right click a WEBLOC file and select “Open With” and it works anywhere.


(Lawrence Seiford) #6

Thanks for this tip. Fixed the problem for me. Yet another reason I subscribe to TidBITS!


(Diane D) #7

I was not having an issue with specific letters. Most of the time it would crash, but sometimes it wouldn’t.

I found that if I hit Command-space and waited, I could then type a letter and wait for the list to show up. If my choice was there, I could arrow down. If not I’d try the next letter and repeat.

This often worked, but not always.

I posted the issue to the group on Sept 20 but didn’t get any replies. (I wrote it as “timing out” vs crashing)

Diane


(B. Jefferson Le Blanc) #8

I haven’t had the problem—because I don’t use Spotlight from the menu bar. I almost always use the Finder window search field. But I used your tip to turn off Bookmarks and History anyway, just to be safe. Thanks for the tip.


(Adam Engst) #9

I’m seeing a number of people reporting this in the Apple Support Communities, but no real solutions.

https://discussions.apple.com/thread/8547433
https://discussions.apple.com/thread/8543117
https://discussions.apple.com/thread/8546050
https://discussions.apple.com/thread/8543288


(Matt Neuburg) #10

I do also see the Quick Look issue; I’m glad I’m not alone.

A comment over on Macintouch suggests that unchecking Other in the Spotlight Search Results pref pane may be needed, in addition to Bookmarks & History.


(randalltrini) #11

I had the same issue, after upgrading to Safari on Macbook Pro running regular Sierra. This tip saved me from going crazy! Thank you so much!


(Gary Gibson) #12

I had to downgrade back to Safari 11.1.2 because of the .webloc problem. Just clicking on a .webloc file with the pointer is enough to crash the Finder in my case. I didn’t even get to the point where I could try to invoke QuickLook. It even happens on a fresh Sierra install on which you immediately apply Apple software updates. This problem is very hard to miss, so I am saddened and alarmed that Apple managed to miss it during QA testing. What’s worse is that this is STILL NOT FIXED in Safari 12.0.1.


(Diane D) #13

Gary, there was a solution that worked for me, but I thought it was in this thread. No luck for you?

Diane


(TomR) #14

I am having same problems with MacOS 10.12.6.
The suggestions here (unchecking a few items in Spotlight) did not work for me.
Anything that invokes Quicklook of a Webloc item on my MacBookPro crashes Finder. AND the same thing happens in PathFinder, crashing that file manager app also! So it must be specific to Quick Look. Tom


(Adam Engst) #17

Yes, this seems to be an ongoing bug with Safari 12. I’m not aware of any fix, apart from upgrading to 10.13 High Sierra, where the problem doesn’t occur.


(mimetic) #18

With Spotlight, I think it has to do with web content being the first search result. The crash also happens to me when using either Quicklook or Cover Flow on .webloc files.