Safari 12.0.2

Originally published at:

Addresses WebKit and address bar vulnerabilities for macOS 10.12.6 Sierra and 10.13.6 High Sierra. (Free)

And yet the webloc crashing bug is still present after installing Safari 12.0.2 on macOS Sierra. One wonders what kind of regression testing or basic QA actually happens at Apple these days when they release software that is supposed to work in multiple versions of macOS. This is a pretty obvious and dramatic bug.

Reproduction steps:
1) Click on a webloc file in Finder - crash!

Workaround: Remove Safari 12.0.2 (the bug occurs all previous versions of Safari 12 too). Restore Safari 11.1.2. Do the same test as above. It just works. Not really an edge case, unless Apple stopped supporting webloc files and I didn’t get the memo. Even so, it shouldn’t crash Finder. Good grief!!!

1 Like

I don’t see this; clicking and double-clicking on webloc files works just fine for me under Mojave and Safari 12.0.1.


The OP appears to be referring to a specific problem with Sierra and Safari 12.0.2.


1 Like

Al, no, he said all versions of Safari 12 and that it’s just not fixed in 12.0.2.

Anyway, I’ve just tried it under Sierra on my MacBook Pro with Safari 12.0.2. Worked perfectly. No crash.


Yes, this is a specific problem with Safari 12 under macOS Sierra (10.12.6 December 2016/January 2017 installer) not to be confused with Mojave (10.14.x) or High Sierra (10.13.x). We’re standardized on Sierra (and El Capitan) at work because we still have a large fleet of older macs that require a stable environment (school district).

I have had this problem with every version of Safari 12. (that’s 12.0, 12.0.1, and now 12.0.2) running on a an iMac (4K, 21-inch late 2015) with the aforementioned version of macOS Sierra. And yes, I did test each update on a pristine fresh install of Sierra, and got the same crashy results.

Interesting that it works on a macbook pro. What model do you have, and was this a fresh Sierra install, or an old install that you’ve had on your MBP for a while? Also, did you test with an old webloc that you had lying around, or a new one that you just created with that browser? My problem is with pre-existing weblocs. I didn’t think of creating a new one! I’ll have to try that.

1 Like

I have the same .webloc issue on multiple Sierra and High Sierra machines; we also have the chronic Spotlight crash if Bookmarks & History are indexed; still have that disabled even after the latest update showed it was still broken (yes, I rebuilt the spotlight index entirely before testing).


It’s an early 2013 MacBook Pro. Sierra was installed a few months after it was released, over whatever had gone before; it’s fully up to date (now 10.12.6).

I tested with a webloc I created by dragging from the address bar to the desktop. I didn’t think I had any old weblocs lying around, but a search showed one (to MS Silverlight, as it happens) from 2011, which worked just fine.

Anyway, I realise that “it works for me” isn’t a solution to your “it crashes for me” problem! I just thought it might be helpful to you to realise that it’s not a universal difficulty.

If I can help, let me know.



Thanks for the info and the offer of help. It looks like Safari 12.0.3 finally fixed the .webloc crashing problem for me. So far things just work, and I haven’t noticed any other browser issues. Third point release is a charm!