Retroactive app issue installing iTunes

This post is for anyone who might run into an issue with installing iTunes 10.7 CoverFlow with a current updated version of Catalina and possibly newer OS versions.

In the past, I’ve used the Retroactive app 1.8 or 1.9 to install iTunes on Catalina with no problems. I have another 2012 Mac Mini i5 which is similar to my i7 on which I wanted to install the older 10.7 iTunes version as I had before. But when coming to the iTunes menu using Retroactive which has a slider to move the choices over, that was missing on the i5 Mac. I had just installed the latest Catalina OS from Apple on the i5 so I started thinking that maybe one of the later security updates changed something about how Retroactive interacts with Catalina but I’m not sure. These screen shots indicate how it should look:

This is how it looked on the i5 with no slider to move over for the iTunes 10.7:

So I thought I would try an older version like 1.8 but same issue. I noticed that the other older versions are still on GitHub so I went back one at a time until I found one that allowed me to select the iTunes 10.7 version which is Retroactive 1.5:

On the i5, there was no slider (pic is from i7) but you can still select any of the choices since they are all visible. Installation went fine. Here is the link for older versions in case someone runs into a similar situation:

As I mentioned, I still don’t know why it didn’t work on the i5 with the current Retroactive version but since there have been a few security updates that caused issues with file sharing and NTFS writing on Catalina, that is my first guess but I could be wrong.

After thinking about the problem, I noted that I was using a different mouse for the i5 system, a Magic Mouse vs the Logitech one I always use. So I tried a wired mouse first and the slider came up on Retroactive. Then, I tried the Magic Mouse again which did not show the slider but if I used a left/right gesture in the correct spot, the slider appeared. So, the mouse was the issue all along. I hardly ever use the Magic Mouse as I always liked the feel of the Logitech one along with the more substantive click. I had tried different movements/gestures with the Magic Mouse when trying to figure out the issue but I guess I had those wrong.

This is a macOS configuration. There’s an option to hide scroll bars. You can configure them to be always visible, visible only when actively scrolling, or automatically select one of those two options based on what kind of pointing device you’re using:

I configure my system so they are always visible. It sounds like you may also prefer this setting instead of the default, which is based on your pointing device.

1 Like

Thanks for that tip which I forgot about. But on my main computer which uses the Logitech Mouse, I have it set for automatically and the slider still comes up using Retroactive by itself. The Logitech has its own control panel which may or may not override some settings as I have found in the past. I had tried the Apple mouse on the other computer in various locations to make it slide but it didn’t happen but now that I know where the “magic” spot is, all is well. I now feel stupid about the whole issue but maybe someone else will run into the same problem and will now know what to do. Thanks again.

Running a quick test on my Mac (Big Sur) with my mouse (a wired Microsoft Basic Optical mouse), “Automatic” behaves like “always”.

On my MacBook Air (running Sierra), Automatic behaves like “when scrolling” when I’m using the trackpad. But when I plug in a generic mouse (an HP-branded optical mouse with a scroll-wheel), it switches to behave like “always”.

I also tried my laptop with an Apple Mighty Mouse (scroll-ball) that I keep in my parts closet. It also causes scroll bars to be always visible.

But, as you observed, a Mighty Mouse does not. It causes scroll bars to only appear while scrolling.

I suspect that the algorithm for automatic is to behave like “when scrolling” when you have a touch-surface for scrolling, like a trackpad, but like “always” when you don’t. Since a Magic Mouse has (effectively) a trackpad built-in to its surface, that’s probably why it doesn’t cause scroll bars to appear.

FWIW, I have never liked Apple’s hiding of scroll bars. And I don’t like the fact that this practice has become popular on Windows and Linux platforms as well. Which is why I configure my devices to always show scroll bars wherever I have the choice to do so.

It is (sort of) justifiable on a touch device like an iPhone or iPad, since you are scrolling by swiping across the content anyway. But it makes no sense to me on a platform that has a well-defined on-screen pointer, like any desktop OS (or, for that matter, an iPad that is using an external pointing device).

1 Like