Restoring Reader View in Safari/Sonoma 14.2.1

I’ve given up on having my Macs behave in predictable, deterministic ways. My main machine runs Sonoma 14.2.1.

I’ve sometimes seen the Safari Reader button appear and sometimes not, even on the same page.

I suspect the variability may be due to whether or not certain page elements (ads, videos, etc.) have fully downloaded/rendered.

No idea, but they’re easy to turn off and then try again.

You should also test in another account, which would show whether not the problem was related to a corrupted preferences file.

1 Like

That’s possible. But my experience in the last two weeks is that there is no page format that is rendered in the earlier Print View format.


Well, let’s eliminate the test page as a variable too. Try this TidBITS article, which I can show works in Reader View in Safari 17.2.1 under macOS 14.2.1 on an M1 MacBook Air.

From what I know of the sealed system volume approach that macOS uses, it’s not inconceivable that a reinstall would work, not because of any problem with macOS, which by definition can’t be modified and still boot, but because of issues with Safari itself, which is outside the SSV in a cryptex. I wouldn’t think those cryptexes could sustain corruption either, but maybe?

I’m still curious about the alternative account test. It’s easy to imagine a Safari preference file getting corrupted.


Hi Adam, I think Vincent is having the same issue as I did. My previous post was short on detail, so let me fill in the story a bit.

Software Update had offered me an update to Safari on my 2017 4k iMac running Ventura. I accepted and let the installer run while I retired for the night.

Next day I discovered that Reader View was not working. After fiddling with extensions and prefs, I had not succeeded in fixing the problem. As one does in these circumstances, I sought help from TidBits. After a day or so, it seemed that I was the only one afflicted. I returned to Tidbits with some jpegs showing the problem. These show a page on my wife’s (un-updated) Mac with Reader View selected, then activated. It worked as expected. The next pictures show the same page on my Mac with Reader view selected, then activated. Not the expected result!!

I was getting a new M2 mini, so was eager to clean out much of the accumulated crud as possible, and get my files in some sort of easily handled order. I had already pruned Safari extensions and settings to no effect, so ventured boldly into /Library and ~/Library to see how much damage I could do. I did enough to realize that I was getting nowhere. Next step…re-instal Safari. This proved quite frustrating as I could find no stand-alone Safari installer. It seemed the quickest path was to install macOS from Recovery and get a shiny new Safari… Enough time wasted. I dragged Safari onto AppDelete and emptied the trash to rid my machine of as many Safari-related files as the Trash would allow. Safari was now crippled enough that I hoped the OS re-install would work It did.

1 Like

Maybe also try clearing the Safari caches:
Safari Settings/Privacy/Manage Website data/Remove all

I’ll try that.


No. Sorry. That doesn’t change the behavior of Safari at all.


Vincent, You are describing exactly the same problem that I encountered after an update.

I deleted all extensions, caches, and restarted the Mac, only to find the problem still present.

Next I tried various “cleaning” apps like Onyx, EtreCheck etc to no avail.

I then looked in ~/Library which contains a wealth of files relating to Safari….

~/Library/Application Support








and did some pruning in the hope that Safari would replace any needed file with a new copy.

Another failure!

I then decided to reinstall Safari, but could not find an installer, So decided to reinstall macOS.

Before I did this I used AppDelete to delete Safari, as I wanted any associated corrupt files in the Data volume on the MacintoshHD to be expunged. Reinstalling the OS will preserve your files (even your corrupt ones) and only replace the System Volume. There will be files in the Trash which your machine may refuse to delete as you do not have the required privileges.


Simon has provided you with a link to Apple Support if you wish to take that path. Otherwise, if the problem is apparent to more than just you and me, Apple might fix it soon.

thanks for the suggestion. In the college environment and its IT system that I have to use, I have difficulty connecting to the WiFi server when booting from the Mac Recovery mode which is needed to reinstall the OS. I’ll have to see whether I can get a workaround.


Safari just got updated to 17.3 with the Sonoma 14.3 update. This will probably fix things for you (I hope).

Hope so. Thanks for the head’s up.


A site for which I have Safari set to use Reader View as default, no longer allows it, on what are now the past two Safari and Monterey version bumps. I can also click Show Reader View in the search bar, no change. I can, however, use reader view on the same site(s) with Safari on iPad 15.8). MBPro,Monterey 12.7.3, Safari 17.3
[EDIT] Safari 17.4.1 still does not permit Reader View as described above, but it works “normally” for the same sites using Safari/iPadOS 15.8.2. So, “handoff” is great, I copy the URL on the Mac then paste it into Safari on the iPad.