Reconnect a HomeKit Accessory over a 2.4 GHz Wi-Fi Network

Originally published at: Reconnect a HomeKit Accessory over a 2.4 GHz Wi-Fi Network - TidBITS

After a network hiccup caused his HomeKit-enabled smart thermostat to lose its network connection, Glenn Fleishman had to do tweaky network reconfiguration to get it to rejoin his Home setup.

1 Like

This 2.4Ghz/5Ghz issue arose with the original Homepods as well as Homekit devices. Some of us had to temporarily disable the 5Ghz service on the router to get things to work with 2.4Ghz.
I also found that assigning a static IP to the Homepods and Apple TV in the router settings also reduced issues.
Another quirk I came across with re-connecting LFX lights (after resetting them) was to change the light’s Homekit default name during the set-up process.

I’ve been bit by this several times. Thankfully Eero has an easy way to temporarily turn off the 5 GHz band for 10 minutes (settings / troubleshooting / my device won’t connect), but perhaps the phone or iPad or Mac should turn off its own 5 GHz radio when you are adding a HomeKit device, or something similar?

But it must be tough for people who have no idea about networking to figure out how to solve this problem.

I’m a bit confused by this article. Did you need access to the 2.4 GHz guest network only to set the thermostat up again from your iDevice? And why did the thermostat work for so long in the first place, or rather, what was it that made it get booted off the 2.4 GHz network unable to reconnect again?

Stories like this remind me why I actually enjoy not having a “smart thermostat”, relying on a simple wired unit (that probably costs about $2) with three buttons rather than on stuff like HomeKit to keep my house warm during winter.

1 Like

I’ve had this problem with the smart light switches in the past. Frequently they connect up by using your iOS devices’ Wi-Fi network and using their app. What if your device does not use the 2.4 MHz (Like the newer iPhones)?

I had to return some wall light switches because I could never get them to connect up consistently though I may look into using an extender that uses the other frequency. I think I’m only allowed to have one guest network with my router but I’m not sure whether it is selectable as far as wavelength

Yes, the iPhone had to be connected to a 2.4 GHz network to pass that information using the HomeKit protocol (which I didn’t note relies on Bluetooth as well). After that, the iPhone can be on any network.

As I note in the article, no idea why! I suspect when I first set it up, I was unintentionally on the 2.4 GHz side of my network. I may have better 5 GHz coverage in my house now (I have swapped and upgrading a few things). Why it fell off the network and couldn’t rejoin? No explanation! So that part is all a mystery.

I resisted them until this upgrade. The utility subsidized the large part. It worked 20 months without a glitch (and I expect now to not have any further ones). We dearly love the fact that we never have to muck with the thermostat: when we leave, it goes to its “away” setting; when we return, it resumes its regular schedule. Less cognitive load for us and more savings in energy use.


Agreed. If you have to be on 2.4 GHz and that’s a requirement of HomeKit for a device, Apple should integrate support for that.

1 Like

You have two iPads for home use. Could you set one to only use the 2.4Ghz network and connect the device to that?

Also, my router has both 2.4 and 5Ghz networks and they seem interoperable with each other. That is my phone on the 5Ghz network can talk to a device on a 2.4Ghz network. Sort of like how your guest network can talk to your main house network.

A question for @glennf : I have heard that another reason for devices like this having 2.4 GHz radios is that while they are slower, they are able to connect at longer range because of their lower frequency band. Is that true?

And, your article made me go check my two Ecobee thermostats that came with our heat pump system. They both connect on one of the two 5 GHz bands provided by our router.

Definitely. 5 GHz signals are more easily blocked by walls and stuff inside walls (HVAC ducts, plumbing, insulation, etc.). So it gives you more bandwidth but usually shorter range.

Devices that don’t need a lot of bandwidth (like most IoT devices other than cameras) probably should be configured to connect over for 2.4 GHz.

That’s how I’d expect any router to behave (unless specially configured otherwise).

I have seen some routers that do not forward multicast/broadcast traffic between Wi-Fi segments or between Wi-Fi segments and wired network segments, and that may impact device discovery, but that’s far from universal behavior.

Yes! Noted very much in passing in the article, but 2.4 GHz can penetrate solid objects better. The longer wavelength provides greater coverage, but the scarcity of frequency and the overlap with other non-Wi-Fi devices limits performance. If there were 1,500 MHz of frequency in 2.4 GHz (as there now is in 5 GHz + 6 GHz), it could be likely just as fast! The higher frequencies are allowed greater power because of the more rapid degradation of signal over space due to shorter wavelengths, and thus they are very good at in-room or one-room-away performance.

I’ve had my Homepods act up weird every few months and ironically, when an iOS update is released. I wonder if related? I lost a smart switch from Homekit and had to re-add it. Also, I added a smartswitch for my Xmas tree lights and when I packed up the tree… Homekit was complaining it was missing when executing the Good Night shutdoff lights scene…it could not find the Xmas tree plug (in a box). Had to remove that from the scene.
Now, thinking about this, I looked into my thermostat, a Honeywell Lyric (non-home kit and Honeywell wouldn’t even allow a trade up) that is now under Residio, that I looked in the user guide and sure enough: Make sure your smartphone or tablet is connected to a 2.4 GHz WiFi signal. (Many WiFi routers broadcast both a 2.4 GHz signal and a 5.0 GHz signal. If given the option, choose the 2.4 GHz signal)
Perhaps an opportunity to have a list of devices that work on ONLY 2.4Ghz or both 2.4Ghz/5Ghz?
I see that Honeywell’s T9 Smart and T10Pro Smart thermostats work on 2.4/5ghz but their T5 Smart is only 2.4Ghz. (The Pro name means you have to have professional installation…won’t even give prices on Honeywell site…which I searched and found priced from $199 to $429 for the T10Pro…w.Redlink 3.0… .more for homes with Heatpumps…not mine).

Note: 2.4Ghz slower but further, 5Ghz is faster but shorter range. Glass, Steel and Stone are not ideal for wifi*

The issue is that the new (or factory reset) HomeKit device isn’t connected yet to your network - it doesn’t have any of the authentication details. That’s part of adding a device to HomeKit - your phone, iPad, or Mac communicates the WiFi details to the device so it can connect. I think it does the configuration using Bluetooth, but I’ve run into issues many time with older HomeKit devices that if you have 5 ghz networking going, the device won’t complete the configuration and will give an error message. Once the device is configured (which often takes temporarily disabling 5 GHz) it will interoperate just fine with devices on both 5 ghz and 2.4 GHz (assuming they are on the same LAN of course.)

Yes - that is my understanding. For set-up most Homekit devices need to temporarily connect to an iPhone or iPad by wifi in order to authenticate and get rhe SSID and password for connecting to the home wifi and join the Homekit system.That is part of the Add Accessory function in the Home app.

This means the iPhone/iPad must briefly disconnect from the home wifi while it sets up the Homekit device. If the Homekit device only works with 2.4Ghz and the iPhone/iPad only works with 5Ghz (as suggested above) then … it won’t work. You would need to find an old iPhone/iPad in order to set up the device.

Of course Apple doesn’t care about older Homekit devices that have to use 2.4Ghz.

Once the Homekit device joins the home network it shouldn’t matter which wifi band it, or the iPhone/iPad, are using.

The other issue that I didn’t mention in my earlier post was that the original Homepods and some Homekit devices can be confused by “smart” router features that try to optimise the wifi performance. Try disabling this in the router settings.

1 Like

But that’s madness! Who (presumably at Apple) thought it’d be a good idea to tell the accessory the BSSID of the network you’re on, instead of the name and key? That just seems so obviously wrong to me. Glad you’re up and running now, but I hope this is changed in future, for the benefit of the poor sods who’ll run into this very frustrating issue!

The other thing I’ve noticed is that many devices (including HomePod) are very resistant to band steering (Netgear calls this “Smart Connect”). So, in addition to making sure your devices can reach the 2.4 GHz band, not a bad idea to turn this off. Contemporary devices won’t need this, anyway, and will generally prefer speed over range when it’s an option.

This makes sense to me.

IoT devices generally don’t have Ethernet ports and often don’t have keypads or displays. But you need to configure them somehow.

There are two standard ways to get this initial configuration into the device. One is to use Bluetooth. This works great and is probably the best way.

But if your device doesn’t use Bluetooth during normal operation, a manufacturer probably won’t want to add the cost of a Bluetooth radio module, just for setup and configuration.

So the other approach is an ad-hoc Wi-Fi network. The device advertises a device-specific ad-hoc network. Your mobile device needs to scan for this network. Once connected, it can use that link to push in configuration. After that, it will join your normal Wi-Fi network and work as you’d expect.

But since mobile devices usually don’t have the ability to connect to two Wi-Fi networks at once, they need to disconnect from your LAN while configuring the device.

But I am surprised that any mobile device would be locked into a 5 GHz band only and wouldn’t also scan the 2.4 GHz band looking for that ad-hoc network. That just sounds strange to me. Although you might disable 2.4 GHz for your wireless LAN access points (and of course, the IoT device would need 5 GHz support to join your network in that case), I don’t even know if it is possible to disable it on a client device like a phone or tablet.

This sounds to me more like a bug than a design choice.

This is where I remain confused. The HomeKit device shows a code that you scan with your iPhone. That code then allows a connection, which I believe happens over 2.4 GHz Wi-Fi, and relies on Bluetooth as an additional security factor to exchange keys. However, at that point, when the iPhone is connected, it is configuring the device to connect to the local Wi-Fi network. If it simply passes the network name and password, but it doesn’t matter if it’s 2.4 GHz or 5 GHz. The device will attempt to find a network, and only be able to use 2.4 GHz, so should find the network name that matches. So that’s where I think something else is happening.

1 Like

Ah - my wifi has the same SSID and password for both bands. If they are different then maybe this can result in set-up errors?

Exactly the opposite is what happened for me! See article!

Precisely. I have 2.4 GHz and 5 GHz coverage throughout the house. I have heard since on Mastodon that some people have had similar experiences.