Problem with virtualization programs in Mojave?

I’m trying to help a client with an issue that cropped up after upgrading from High Sierra to Mojave. She had a previously-working version of VMware Fusion (version 7.x), and while it opened in Mojave, it threw a cryptic error regarding a kernel extension called vmmon.kext. We went through a lot of crazy recommended fixes, including command line stuff that had to be done via Recovery Mode, and none of it worked.

Then I suggested she download a trial of Parallels Desktop, to see if that worked. It does essentially the same thing. We’re now stuck, and I’m hoping someone here may have experienced this to some degree or another, and might have an idea about a fix.

Here’s the main error that Fusion throws up: “could not open /dev/vmmon: Broken pipe”

Parallels simply says something like “unable to start Parallels services”

Have any of you experienced something like this with your virtualization software in Mojave or elsewhere?

Many thanks in advance,

I’d try downloading the free VMware Fusion 12 Player and see if that works.

I’d try downloading the free VMware Fusion 12 Player and see if that works.

Sorry, I should’ve been more clear about that. We tried the newer version of Fusion first. and only tried Parallels after we hit a brick wall with Fusion 12.

From my research, my gut tells me there must be something specific to her Mojave upgrade install that’s bunged up. I’m going to suggest she reinstall Mojave from Recovery Mode, simply as a big hammer approach, simply because I’ve run out of other ideas!

I think that’s sensible—restoring macOS from Recovery isn’t that big of a deal anymore, so it’s well worth trying when easier methods fail.

Requires Catalina.

Good news; the Mojave reinstall resolved the issue. Who knows what the problem was, of course, but at least it’s behind us!

1 Like