Printers lose AirPrint

I have a small, tidy home network. 2 MacBook Airs 13’ 2018 running Monterey 12.4, 2 iPhone 12s running iOS 15.5, an iPad air 2 running 15.5 and 2 HP Printers a Laserjet M203 dw and a laser jet M127 fn (all-in-one).

Both printers are plugged into a network hub (hardwired) and are connected to the network (Verizon Fios) wirelessly.

Up till now everything has workedd flawlessly. In the last 2 days I have found myself unable to print wirelessly from any device. Attempting to print I get a message "No AirPrint printers found’.

When I access the printer on the network it reports that “AirPrint is on”. It also says to unplug the network cable to setup the wireless connection. I’ve tried that, but unplugging the network cable loses my connectivity and then I can’t setup squat.

Both printers are apparently not communicating wirelessly with the router. I didn’t change anything (that I know of) but something’s happened.

I downloaded the HP-Smart app from the app store but it fails repeatedly to diagnose the issue.

Am I the only one seeing this?

Thanks in advance.


An update. Still no good. I unplug the network cable, press the wifi button on the printer, it begins to flash, I go to the router, press the wFS on the router, it begins to flash, but they don’t connect.

You may have already seen this, but since your post didn’t mention anything about “restoring the wifi setup mode”…:

1 Like

Thanks, Jeff!

An update:

Everything is working!

How? I have no idea.

I have done so many things (rebooted the router& the printers, messed with HP Smart, gone through the setups in MAC settings etc.) that at this point, I don’t know when both printers suddenly started working again.

But they did.

So i’m going to pour myself a large glass of Gentleman Jack (Daniels) and put my feet up.

Thanks everyone for listening to a doddering old fool.



Yep. Sometimes the old “two kicks and a bang” approach works. :slight_smile:

And when it doesn’t, there’s always Gentleman Jack.

And I was doddering around behind the scenes racking my brain because my HP just had that problem, and I remember that I found “The Solution”… but I forgot…if it comes back, I’ll post.

Dodder off, stage right…

My HP LaserJet regularly drops off the Bonjour network, which I believe is what AirPrint uses. The only solution I’ve found is to reboot the printer.

Yes, AirPrint uses Bonjour service discovery (which is, in turn, based on multicast DNS) to see printers.

I have found that some printers stop responding to mDNS when they go to sleep, which makes them disappear from Bonjour. Waking up the network interface (e.g. by restarting the printer or by sending it a document through some other means) will make it re-appear.

In my case, it was a Brother laser printer. A firmware update fixed it. So if you are seeing similar symptoms, I think the first thing you should try should also be to see if there is an available firmware update.

Thanks to everyone for replying so promptly and helpfully.

I really wish I knew which one of the multiple things that I did really worked.

I’m embarrassed. My training in troubleshooting (admittedly from 40 years ago) involved keeping a detailed written log:
1- Do X. Wait 5 minutes. Test again.
2- If no good, Do Y. Wait, test again. etc.

I just didn’t have the patience.

Thanks again to all.


My HP LaserJet sometimes does that, but it’s not because it actually loses connection or Bonjour gets screwed up. It’s because the printer is off.

Unfortunately, some of HP’s laser printers don’t have a clear ON indication (some only blink once every few seconds or so when they’re in sleep). And if you suffer from a blackout or your cleaning person unplugs the cable because they’re extra careful about “not damaging it”, it will shut off and I wouldn’t know sitting next to it. Just because it again sees power does not mean it turns back on. So then the printer disappears from Bonjour. When I then “power cycle” the printer, I’m actually turning it on and voila, Bonjour sees it again.

Just another remark about AirPrint. I have Canon printers, and my current one (a TS 5350) sometimes decides to print very very slowly (over a minute for a simple page of text). Other times it’s OK. This particular machine has its own private wifi network, and when I connect to that (is this AirPrint? I wouldn’t know) it returns to normal speed. Obviously not much of a solution since until I go back to my main wifi, I don’t have internet access on my Mac. I hate that I don’t know what’s going on, which for me most often happens in networking situations. Grrr.

It could be any number of things, but I would start by looking at the Wi-Fi network that is having problems.

Check your routers to make sure they’re configured for their top speeds. Also, maybe check other Wi-Fi parameters (2.4 GHz or 5 GHz band, channel selection, etc.). In general, a router’s automatically-configured settings will work fine, but sometimes it helps to manually configure some parameters. Or if your router is configured manually, maybe try making it automatic.

If there is Ethernet connectivity in the printer’s location (e.g. my home office, where the printer lives, is in the same room with my router. I use an Ethernet switch to hook up everything that lives in that room), give it a try. Wired networks will almost always perform better than wireless networks.

Thanks for that. I keep switching locations, but as soon as I get back to the one I described, I’ll try the things you suggest. I am also using Ethernet over power line devices, but this has also gone wrong recently, so that my Mac is said to be connected to Ethernet with a self-assigned IP and therefore useless. I am almost on the verge or recycling myself as a nerd, this time a network person (I’m a long-retired software engineer that never got into networks, just used them blindly). I hate not understanding things, Thanks again.

How old are the transceivers? They do go bad over time. I recently replaced the ones in my home because two (out of the four I normally use) started getting flaky.

Unfortunately, this is a natural side effect of a device that must be connected directly to the power line without any surge suppressors or power filters (since they block the data). They end up getting hit by power surges, which eventually breaks them.

1 Like