Preview app no longer opens Excel docs since Numbers update

The Preview app on my MacBookPro no longer opens Excel docs since installing a Numbers update the other day.

This could be just a coincidence - because I only open Excel documents 2 or 3 times a month.
The Excel docs are exports from Google Sheets.

I’m running macOS 12.0.1 on an M1 Max MacBook Pro.
The docs will open in
The docs can be forced to open with Preview but nothing shows except an entry in Preview’s ‘Open recent’
Preview is not listed as a recommended application for .xlsx docs.

The same behavior occurs signing in as Guest user as well as a 2nd user account I have on the Mac.

Thanks for any help.

I can live with this but opening .xlsx docs quickly in Preview was convenient for me.

I’m not sure if I’m in quite the same situation, but I can select a .xlsx file, choose File > Get Info, choose Other from the Open Within pop-up menu in the Get Info window, choose All Applications in the Enable popup menu in the Open file dialog, and then choose Preview.

Then that Excel file opens in Preview, and I was able to use the Change All button to change everything to use Preview. That all worked fine although I did get a warning about there possibly being code in the very first Excel file I opened, such that I had to Control-click it and choose Open With > Preview to approve it.

For me, that just launches Preview, no document window opens, and the Excel doc gets listed in File → Open Recent. But never any display of the document.

I have discovered that selecting the doc on the desktop and hitting the space bar appears to give a preview that is from Preview. I think it’s Preview b/c Preview always handled my column spacing correctly while Numbers requires adjustment. This ‘Select - space bar’ has columns correctly set.

That may be my go-to method when I need a quick look at the spreadsheet.

Do you have Excel installed on your Mac or do you only open Excel files with other apps?

I ask because on my system (where Excel is installed), Preview can open Excel files. It shows the same output as what Quick Look shows.

I seem to remember something about how Quick Look and Preview use plugins in order to support data types not built-in to macOS.

If you don’t have Excel installed, then some other app would need to provide the plugin. If Numbers was providing one and the latest version didn’t include it (or if the installation got corrupted), that would cause the symptoms you describe.

You might want to try uninstalling/reinstalling Numbers. If the problem was due to the plugin being corrupt, that would fix it.

I’m wondering also if it might be due to the fact that your xlsx files were exported from Google Sheets. What happens if you create a new spreadsheet (in Numbers, Excel or LibreOffice), save it, and try to preview that?

Same here on my 14" MBP with 12.0.1. I can drag it onto Preview but Preview will never show any content or a document window at all in fact. It will later show the doc in its recents though. I’m pretty sure this is a Monterey bug/feature. Note though that QuickView works independently of Preview. My Excel docs still show just fine with QuickView even if Preview doesn’t display them at all. I’d consider QuickView (just select doc in Finder and hit space) a work-around until Apple fixes the bug (if they do, that is).

Never had Excel installed.

The point is that prior to this past weekend, Preview always opened Excel files on my Mac.

I’m leaning toward this being a bug in 12.0.1 as Simon (comment below) has the exact same experience as me.

“What happens if you create a new spreadsheet (in Numbers, Excel or LibreOffice), save it, and try to preview that?”
Excellent suggestion for trouble shooting
but the same thing happens - Preview doesn’t display the excel file but lists it as a recent doc.

Just an update - problem still exists after update to macOS Monterey 12.1

The fact that I wasn’t seeing it suggests to me that it’s related to a setting or corruption somewhere on your Mac. What happens if you try in another account, even a guest account?

I had tried both of those - same results.
So we know it’s not specific to a user.

But good suggestions.

chiming in, on a laptop that has never had Excel installed, Mac OS 12.1’s Preview will only Quick Look an .xlxs file, which isn’t ideal as usually the font size is microscopic. ( I never noticed that you can open other tabs in a spreadsheet this way.)

I mostly use Numbers, not Preview, so cannot confirm that this worked/didn’t work in 12.0, fwiw.

I never had Excel installed and but was able to open previously on earlier 2012 MacBook Pro.

I migrated from macOS Mojave on that older Mac to the current M1 MacBook with Monterey.
I open an .xlsx so rarely that I cannot be certain that it ever worked on the new MacBook Pro

That older Mac had OpenOffice installed - so maybe that preformed the same purpose for Preview as having Excel would.