PDF apps repeatedly crashing

I need some help. I have a 2021 M1 MacBook Pro running Sonoma 14.1.4 and with 16 GB RAM and 1GB SSD which has just over 500 GB unused. I have 3 PDF apps installed, (1) Nitro PDF Pro v. 14.1, (2) PDFPenPro v 13.1 and (3) PDF Expert v. 3.10.1. Primarily I have used PDFPenPro because after Smile sold the app to Nitro, I didn’t like how the first upgrade issued by Nitro functioned.

Until last week, all 3 apps worked without any issues. Last week, I started having repeated crashes of both PDFPenPro and Nitro PDF Pro and to a lesser extent PDF Expert. They would crash when opening a file, they would crash when just sitting idle and once started, it was a vicious cycle of repeated crashes. The crash reports in Console look fairly similar, at least to start though interpreting them is beyond my capabilities.

They generally start with the following (change the app name as appropriate)

Process: PDFpenPro [53090]
Path: /Volumes/VOLUME/*/PDFpenPro.app/Contents/MacOS/PDFpenPro
Identifier: com.smileonmymac.PDFpenPro
Version: 13.1 (1310.8)
Code Type: ARM-64 (Native)
Parent Process: launchd [1]
User ID: 501

Date/Time: 2024-05-01 15:55:16.9308 -0700
OS Version: macOS 14.4.1 (23E224)
Report Version: 12
Anonymous UUID: 1477D23A-B542-7166-7891-AC8A4B0A555D

Sleep/Wake UUID: 20D64DAE-709C-440F-842E-09344D8C8F53

Time Awake Since Boot: 150000 seconds
Time Since Wake: 34869 seconds

System Integrity Protection: enabled

Crashed Thread: 0 Dispatch queue: com.apple.main-thread

Exception Codes: KERN_PROTECTION_FAILURE at 0x000000016f117ff0
Exception Codes: 0x0000000000000002, 0x000000016f117ff0

Termination Reason: Namespace SIGNAL, Code 11 Segmentation fault: 11
Terminating Process: exc handler [53090]

VM Region Info: 0x16f117ff0 is in 0x16b914000-0x16f118000; bytes after start: 58736624 bytes before end: 15
MALLOC_MEDIUM 160000000-168000000 [128.0M] rw-/rwx SM=PRV
GAP OF 0x3914000 BYTES
—> STACK GUARD 16b914000-16f118000 [ 56.0M] —/rwx SM=NUL stack guard for thread 0
Stack 16f118000-16f914000 [ 8176K] rw-/rwx SM=SHM thread 0

No problems with any other app, just the PDF apps. I have tried deleting the apps and trying clean installs. I have also tried reinstalling Sonoma. I have tried wiping everything on the computer and reinstalling from a Time Machine backup that predated the onset of the problems. I have seen some postings on line that suggest this is a memory problem. I have run apple diagnostics and found no issues. If anyone has any ideas about what is causing this and how I can fix it, I would greatly appreciate the help. Thanks for your time and expertise.

Sorry an addendum. SSD is 1 TB