OS that supports 32 bit software won't open


(Robert Tallitsch) #1

I tried to download Mac OS Sierra but was informed that the software wouldn’t open on my Mac Pro, so I am unable to install it on an external hard drive - suggestions. (Sorry for the second post but I finally found a spot to download an older version of Mac OS Sierra).


(Doug Miller) #2

Apple has a support page that lists where to download El Capitan, but I believe that you can also search for it in the Mac App Store, or look for it in the list of purchased apps, if you installed it from the Mac App Store before.

See https://support.apple.com/en-ca/ht206886


(Robert Tallitsch) #3

I have tried to download Sierra and ElCapitan but the App Store says the installer is too old for my Mac OS (10.13.5). I would like to install Sierra on an external hard drive and use that as a bootable disc when I need to use this particular piece of equipment (it won’t work with my current software). Any work arounds to install ElCapitan (I know it worked on that Mac OS) on an external hard drive that would be bootable?

Bob Tallitsch


(Doug Miller) #4

If you already have High Sierra (10.13), you can also install that on a bootable external drive. Perhaps the best solution is to boot from the recovery partition (start from being turned off and hold down Cmd-R, or, better, option-Cmd-r) and install the os from recovery to the external drive. See https://support.apple.com/en-us/ht204904

Or just use something like superduper or carbon copy cloner to clone your existing drive to the external drive (though I believe that CCC has a tool to copy the recovery partition there as well that superduper may lack.)


(Al Varnell) #5

Just use a USB thumb drive and follow these instructions to make a bootable installation drive: “How to create a bootable installer for macOS”

https://support.apple.com/ht201372.

-Al-


(gastropod) #6

Robert Tallitsch wrote about needing to install an older system on an external drive.

Apple is quite aggressive at preventing people from ‘downgrading’ their systems for any reason. You’ll need to create a bootable installer thumb drive, or probably better in your situation, a bootable installer on a partition (8GB is fine) on your external drive. Be sure that the drive is using GUID, not APM or (gasp) Master Boot Record, and it needs to be MacOS Extended (Journaled), not APFS. If you erase the entire volume, the defaults should be correct even on High Sierra, but check to be sure.

Although there’s at least one utility to do this, Install Disk Creator, I prefer the ‘only slightly less easy way’ Ars Technica instructions because it’s more flexible. IDC (at least in the past) wouldn’t install to a partition, only to an entire volume.

https://arstechnica.com/gadgets/2016/09/how-to-make-your-own-bootable-macos-10-12-sierra-usb-install-drive/

It’s basically a (long) one line terminal command that runs the createinstallmedia app that’s in every modern installer.

Template from my cheat file (don’t just copy/paste because who knows what mail plus discourse has done to it!):

sudo PATH-TO-INSTALLER/Contents/Resources/createinstallmedia --volume PATH-TO-TARGET-VOLUME  --applicationpath PATH-TO-INSTALLER --nointeraction

Real example:

sudo /Applications/Install\ OS\ X\ El\ Capitan.app/Contents/Resources/createinstallmedia --volume /Volumes/PutElCapHere --applicationpath /Applications/Install\ OS\ X\ El\ Capitan.app --nointeraction

Note that the volume that you point it at will be erased, so be careful. Using drag and drop into Terminal for the basic paths helps avoid both typos and thinkos, and escapes the spaces in file names correctly.

I keep a 32GB thumb drive with installers for the most recent three systems plus a spare partition for tools such as carbon copy cloner. Very handy not only for installs, but for booting a wide variety of sick Macs when the Recovery Partition isn’t there or is damaged.

To get the installers if you need them you can find the magic links in the Apple tech notes. Keep copies safe somewhere, because it could easily get harder to find or download them in the future. If the hardware is too new, it won’t let you download an older one at all (grumble).

El Capitan 10.11:

https://support.apple.com/en-us/HT206886
https://itunes.apple.com/app/os-x-el-capitan/id1147835434?mt=12

Sierra 10.12:

https://support.apple.com/en-us/HT208202
https://itunes.apple.com/us/app/macos-sierra/id1127487414?ls=1&mt=12


(Robert Tallitsch) #7

The problem is Al that, because I have 10.13.6 on my computer, any download of an older version of the Mac OS, stops mid process and says that the installer is too old for my machine. Therefore I doubt that I would get far enough to use the terminal commands and put it on a flash drive. I need a way to put an OS older than ElCapitan on an external hard drive. An attempt to do so resulted in my computer now being able to find the startup disc with the old OS on it and me having to hard restart my computer to get back to 10.13.6

Bob Tallitsch

(309) 764-8507

www.Augustana.edu/users/bitallitsch

Devote yourself to love others;

**Devote yourself to your community around you, **

and devote yourself to creating something that gives you purpose and meaning.

Mitch Album, Tuesdays with Morrie


(Curtis Wilcox) #8

It’s not a problem because you only download “Install macOS Sierra.app” (or whatever version it is) on your Mac, don’t run it there. Instead, you use the terminal command to create a bootable volume from which you can boot your Mac and then run the installer to install the desired OS on the external drive.

The command line from the Ars Technica article is just from an Apple Support article, How to create a bootable installer for macOS.

  1. Run the terminal command on your Mac, using the desired installer as the source and a (blank, HFS+, at least 8GB) USB flash drive as the destination.
  2. Restart the Mac and hold the Option key to select the flash drive as the volume to boot from
  3. Run the OS installer, pointing it at the external drive on which you want the older OS
  4. Boot the Mac from the freshly installed older OS on the external drive

(Al Varnell) #9

That has not been my experience, but I’m currently doing maintenance in Sierra at the moment, so will have to check later today.

I did check and had no problem downloading El Capitan 10.11.6 while booted to Sierra 10.12.6. I know I can’t actually install it, but no issues with the download. It shows up in my Applications folder and then posts the dialog ‘This copy of the “Install OS X” application is too old to be opened on this version of OS X.’ with a “Quit” button.

-Al-


(gastropod) #10

My experience is that a given system version will only refuse to download an installer (or App) if the mac hardware can’t run it. Which is a problem if you need to download an older something because yours is clobbered and you don’t know anyone who has the right hardware generation.

It’s one of the reasons that I avoid the Mac App Store for regular apps when I can–often there’s no good way to revert to an older version if an update breaks the part that you need most. Most things I buy on the web keep older versions available in perpetuity (for a much better definition of perpetuity than Apple uses…)


(Robert Tallitsch) #11

Thank you Curtis - I will get a sufficiently large flash drive and give it a try, while keeping my fingers crossed.

Bob


(Robert Tallitsch) #12

Thanks Al - never checked to see if anything had actually downloaded; I simply got the same message you did. I will give it a try.

Thanks again

Bob


(Doug Miller) #13

You don’t need to go to all of this trouble. Your machine can already run High Sierra. You were getting that message about older versions because you cannot run the installer for an older version of Mac OS on a higher version. Just follow the instructions I gave earlier to install from recovery to an external drive and you will be able to install High Sierra on a bootable external drive.


(Al Varnell) #14

From another discussion, I believe he already has the installer, just didn’t realize it.

-Al-


(Doug Miller) #15

Right, but he doesn’t need an older version of Mac OS to run 32 but software. High Sierra will be fine and it runs on the Mac Pro he has.


(Al Varnell) #16

Agree, and I we pointed that out to him earlier, but for whatever reason, he’s looking to install Sierra.


(Harro de Jong) #17

In addition to everything else, Apple has built in a date limit in the Mac OS installer: after a deadline, the installer is no longer signed and will refuse to run. You’ll get errors like “can’t be verified” and “error occurred while preparing the installation”

See e.g. this article: http://osxdaily.com/2015/01/19/fix-os-x-install-errors-cant-be-verified-error-occurred-preparing-mac/
although that article is incomplete: it just says to set the date to the current date, but for older OSes that’s not enough. I recently had this problem installing Mac OX 10.10, I had to set the date to a date just after the release of 10.10 to get it to run.

Harro de Jong


(Al Varnell) #18

Yes that happend over three years ago, but I believe that has been completely resolved, at least I hope so. I simply re-downloaded the expired installer, which had been replaced with a validly signed one.

Supposedly Apple will renew the applicable certificates before they expire next time.

-Al-


(Adam Engst) #19

Always safest, but if you prefix CODE text like this with four spaces (which I did in editing), Discourse should display it as a single scrollable line suitable for copying.


(Fritz Mills) #20

I don’t think it’s been resolved. About two months ago I had to reinstall 10.10 on a friend’s laptop. I redownloaded the installer to avoid the expired signature issue and ran it from an old MBP that still runs 10.6.8, but I still had to set the date back before the installer would run.