Numbers update with open files

Just the other day, when Numbers was updated, I had about half a dozen Numbers files open, all of which I use regularly and depend on. These files were in the Numbers folder stored on iCloud remote storage. Once the application was updated, only the forefront file remained open when I relaunched the app. All of the other files had been closed. Or so I thought. When I tried to re-open the files, they were not there! No evidence of their existence in the Numbers folder, or even in the Open Recent… menu item. Luckily I back up regularly, and found them on my hard drive backup. So, case in point, I DO NOT TRUST ICLOUD for safe storage. Something in the Numbers update is amiss, but files shouldn’t have disappeared because of it. I’ve never liked Apple’'s approach to storing app’s files in separate folders which are essentially hidden away.

This would seem like something that could be reproduced! Has anyone here NOT updated to the latest version of Numbers yet? If so, let’s see if we can reproduce @jhewell’s situation.

Can you let us know how many files were open, whether or not they were saved or “dirty,” and what version of macOS you were running? Oh, and what version of Numbers you were updating from?

Thanks for the attention on this.

I had four files open, each with multiple tabs. All had been saved, and the OS is Big Sur 11.2.3. Numbers was at the latest available version just prior to the update to version 11.0 (7030.0.94). The forefront file was actually saved locally on the mac in a different folder from the other three, which were in the Numbers folder within iCloud.

If you go to ‘Recently Deleted’ in the iOS Files app or iCloud Drive on, are the missing files there?

No, they were not. First place I checked when I noticed the issue.

1 Like

Good details! Now all we need is someone who hasn’t already updated to Numbers. I’ll have to check one of my test machines…

I have not, and would be willing to be the guinea pig, but I need the answer to a question I asked in the Numbers update thread. Can Numbers files edited and saved using the new version (11.0) be opened and edited using Numbers 10.3.5? (I’m running 10.3.5 on Mac with Mojave, and apparently cannot update Numbers without updating macOS, which I am loathe to do.) I’m assuming but would appreciate confirmation that Numbers 10.3.9 under iPadOS 14.4.2 would also play well; it does with 10.3.5 on the Mac.

On the other hand, my test would only involve two Numbers files, since that’s all I have. (Much as I would like to abandon Excel, I find Numbers to be too limited.)

Edited to clarify that the Numbers that would be upgraded would be on a MacBook Air running Big Sur. That probably wasn’t clear (he understated).

Just tried it with Numbers 10.0 on my Mojave iMac. Yes, it can open a file saved with Numbers 11.0 from Big Sur, edited, and saved.

1 Like

Confirms my standard operating procedure not to use iCloud for important work. Apple has never got cloud right.


Finally, I got around to this, I thought. (Generally, I only install or update when logged in as admin, and users, including me, only run applications from a user account. Is this unnecessarily cautious?) But read to the end, because my data point might not be meaningful.

I opened my two Numbers spreadsheets (both in iCloud) and created but did not save a third spreadsheet with content in only one cell, then told the App Store to update Numbers. After the update, all three spreadsheets were open and appeared to be intact.

A few hours ago, I clicked the Update button in the App Store for Numbers on my M1 MBA running Big Sur, and I ended up with Numbers 10.3.9. Why didn’t I get 11? Did I get a choice that I didn’t notice about which version to install?

What happens if you check for updates again? Maybe you need to update again to get to 11.0?

If so, try running the open files test again.

It appears so, and I will. I wish I had paid more attention when I updated the first time; that might have shed light on what was going on. I was surprised when I read that @ddmiller mentioned 11 and then I found I had 10 immediately after updating.

I will do that, too. But it will be a while.

To add here, I also had an issue with the first attempt to upgrade Numbers (App Store showed the progress circle, but it never finished and returned to the UPDATE icon. But I didn’t check the files until I tried again to update. Once the upgrade to 11.x succeeded, then I noticed the files had disappeared.

Sorry this took so long. Long story short, I lost no files. I only have two Numbers spreadsheets (both in iCloud); I opened both and created a new spreadsheet (and typed in one cell and did not save) and then updated to Numbers 11.0 with all three files open. I forgot to notice what Numbers looked like immediately after updating, but later (and from a different account) I saw I had three Numbers files in iCloud and I opened all three of them. Numbers even recognized that I had not saved the new file; when I clicked the close button, it asked if I wanted to save it or delete it.

It wasn’t fully painless, however. When I first visited the App Store, it did not offer a new version of Numbers to me. I did something intentional that forced a refresh and then I did see the new version. (Whatever I did was so obvious that I didn’t need to make a note of it, and now I’ve forgotten.) I think there was some other hurdle, but I don’t recall. I do know that Microsoft was giving me fits and I was distracted by those difficulties.

I did have one anomaly that @jhewell didn’t mention. The Numbers folder in iCloud, where the files were stored, did not appear in the Finder on one Mac. The Open dialog box in Numbers could navigate to it and see the files. (I wish I could recall whether it was the MacBook running Mojave or the MacBook Air running Big Sur, but I don’t. Certainly it now appears in the Finder on the MBA, where I am now typing, but I don’t know if that’s a change.)

In summary, I did not have as many files open as @jhewell, but Numbers behaved well after I finally got it upgraded. Like @jhewell, the files were in iCloud.

If I’ve left out any details, feel free to ask for them. I’m not confident that I’ll be able to provide them, but I’ll try.


Thanks Will_M for the extraordinary effort. I, fortunately, was able to recover all my lost iCloud files since I had made a recent backup. Any future updates via the App Store of apps storing their files in the special iCloud folders will begin with closing all open files first. We may not know the reason why it occured, but at least I learned a lesson.

Do you make a special backup of iCloud files or do you simply back up the local versions? In other words, is the source of your backup the folder(s) in iCloud or the folder(s) in /Users/[username]/Library/Mobile Documents? And how would a simple user tell the difference?

It was just a regular backup I do with Carbon Copy Cloner. I found the data in the /Users/[username]/Library/Mobile Documents folder on the backup drive. The Numbers folder on the Mac drive within this same path was empty after the update of Numbers. (see clarification below)

Clarification: the missing files were the files I had open when updating. All other files which were not open did not disappear.

That’s great—thanks for the sleuthing!

At least it doesn’t seem as though there’s a reproducible problem here. Much as those are easier to fix, they’re also more likely to cause trouble for more people. Some things just need to be chalked up to cosmic rays.

1 Like