Nested volume folders in Big Sur -- bug or feature?

For those interested in nerdy details: After I updated from High Sierra to Big Sur a few months ago my Anaconda installation didn’t work any more. It turned out that it has moved to a folder on my hard drive that was nested within a folder on my hard drive. Here is the pop-out when I Command-click the title bar of that folder:


I haven’t seen anything like this before. Some other folders at the same level behave like the anaconda3 folder (e.g. “boot”, “Documents”) but others don’t (they are just within one “Macintosh HD” drive).

Apart from the Anaconda Navigator not working, I cannot even navigate to that folder in Terminal. Eventually I “solved” the problem by installing Anaconda again, but this time it ended up in an invisible folder in my current User folder.

Questions: is this normal on Big Sur? Anybody seen this? Does it have / need a fix? (I have two Anaconda installations now, each a couple GBs, so I assume I can delete the “nested” version now).

It would be nice to know how this looks from UNIX perspective. Have you activated locate? If not do an sudo launchctl load -w /System/Library/LaunchDaemons/ in terminal
then type locate anaconda. Do you get a path?

No, I am not a Unix nerd, not even an experienced Anaconda user. If I do the launchctl thing you suggested I get the message that “The locate database (/var/db/locate.database) does not exist” and that I can create it by sudo launchctl load -w /System/Library/LaunchDaemons/ (of which I am warned that it may take some time, so I haven’t tried).

I also cannot cd to the full path but have to “cd /System/Volumes/Data/anaconda3” which makes little sense to me.

On my 2015 MacBook Pro the making of the locate database took 5 minutes. On my new MacBook it took less. The nice thing is that it lists where things are placed. If I knew it would be easier to make suggestions about what to do.
locate just lists out placement of files and folders. I want to find out where I put the file I remember begins with pbV1

pb@M1Max ~ % locate pbV1

Ok, I have done that now and I find a gazillion files (~384,000 to be more precise) in two main directories, maybe as expected, namely

One question is if I can delete the first set, as I am not quite sure what ramifications that may have (but I suspect not too many, but not sure). Thanks :slight_smile:

Sorry, can you expound a bit?

What is the stuff before “locate” in the second snippet (especially pb@M1Max)?
Is the second line of the second snippet the output from the locate command? If not, what is it?


First I have no knowledge of the Anaconda software, so I am guessing here. I think anaconda was installed at slash same place as /Applications /Library /System in High Sierra. In macos Big Sur, this is not allowed. The OS installation therefore moved it to /System/Volumes/Data/. You can try renaming the /System/Volumes/Data/anaconda3 folder to something else and then check if your current installation still works. If it does, there is no problem as far as I can see with deleting the folder and its content.

If you start your Terminal you will see something like this before you have written anything at all.

Last login: Fri Nov 26 22:33:03 on ttys001
pb@M1Max ~ %

It is called the zsh promt. It is my username pb, my mac name M1Max which I have written in System Preference>Sharing, the sign ~ which tells me I am in my user directory.

The funny (and confusing) thing is that there is NO “Data” folder. It’s just shown in that locate output. The anaconda folder is right inside the “Macintosh HD” volume / folder but locate shows it as “/System/Volumes/Data/anaconda3”. That’s what makes it so flabbergasting and why it made me wonder if it’s some weird MacOS bug (or maybe it’s a feature, how do I know ?).

PS: Anaconda is just a distribution for Python and some other scientific software; I only used it to install Python and R.

Under no circumstances do you want to delete /System/Volumes/Data since that includes your home folder and other things you may not be able to replace, if the system even allows you to do so.

Here’s a somewhat technical pictorial explanation on how things changed with Big Sur: Big Sur boot volume layout. It shows up to you as Macintosh HD.

In Finder, it is no /System/Volumes/Data shown. But if you start up Disk Utility, you will see the Data Volume. (This is Monterey. I do not remember if Disk Utility shows this in Big Sur). Select “Show all devices” in “View”.Screenshot 2021-11-27 at 10.25.58
In an easy way of looking at it, Apple has made the system more secure by putting the files we tinker with in Data

And made the system files complicated to tinker with. :smile:

So when you upgraded, they had to move your anaconda folder to /System/Volumes/Data/ which is UNIX’s way of seeing the Data Volume. Finder seems to have some problems with showing you that nicely.

Did you try typing cd in Terminal, and then dragging and dropping the anaconda3 folder onto the Terminal window? That should provide the correct path, and is very useful as a quick way to find the true paths for some obfuscated folders on modern MacOS (such as iCloud Drive).

1 Like

Thanks for the details. (On a joyful, personal note, I understood all that!)

1 Like

Yes, you are right – that works :slight_smile: Just cd from folder to folder doesn’t work though, but:
By dragging the anaconda3 folder to the command line, this folder hierarchy in the Finder


is translated in the Terminal to

uetz$ cd /System/Volumes/Data/anaconda3

so Macintosh HD is replaced by the Data folder.

That solves much of the problem. Thanks :slight_smile:

1 Like

Makes sense, and so easily discoverable! :rage: