My Mac Apple-Calendar went berserk-I need help!

Has anyone tried local (no iCloud) wifi sync yet even though it will be much slower than USB sync? I wonder if that will work.

Did, it didn’t.

Drats and thanks. :( I was hoping it would work as a workaround. I wished we could escalate our issue to Apple. I’d be OK to overwrite macOS’ Calendar with iPhone’s Calendar data as one way. I even chatted with Apple Chat support and the guy said it’s not possible. I even asked him to ask others like his supervisors and engineers. I wasn’t surprised.

Has anyone tried restoring from Mac’s backup to iPhone? Do those back ups contain iPhone’s Calendar data correctly?

If they were sound to begin with (ie. backed-up in Monterey), yes, they will restore correctly. I just assumed the backups under Ventura and later were corrupted because the sync was. Never actually tried. Don’t have a Sonoma volume…anymore…

1 Like

Will: What’s your plan for the future when Apple stops supporting Monterery next year?

Still working on that…

:-{

I have had somewhat related problems, starting with Ventura and persisting until Sonoma 14.2 update.

  1. Spotlight totally disabled with Ventura on M1 MacMini , but not on Intel MacBook Air (2020). Unable to enable Spotlight with any of the many suggestions on Apple Discussions.
  2. iCloud malfunctions: syncing of iPhone calendar with M1 MacMini calendar over Wifi stopped and all entries in iPhone calendar disappeared.
  3. In Sonoma 14.1, when I clicked to enable contacts syncing via iCloud, I got the heavily reported problem of multiple duplicates. When I turned off Contact syncing, iPhone calendar syncing returned to normal and has continued to function.
  4. After Sonoma 14.2 update, Spotlight started working again. I assume Apple finally responded to the many complaints about Spotlight and fixed some bugs, without any announcement. However, I disabled it and continue to Find My File and EasyFind instead.

Never tried syncing only Calendar, and nothing to test on now. Still, broken Contacts is broken syncing. I need the whole package.

Just for kicks in desperation. I posted in Is there a known issue with macOS … | Apple Developer Forums. Maybe we will get lucky?

Worth a try. Thanks.

That was scary. I was locally backing up and synchronizing the old iPhone 11 Pro Max with macOS Ventura v13.6.3 earlier tonight and then it just got stuck during Contacts part. Even iPhone’s Contacts app (during edit screen) got stuck too. I couldn’t abort in Finder. So I physically disconnected and reconnected. I retried and then it got stuck again. So I rebooted both MBP and iPhone to retry. Then, it worked. macOS’ Calendar data was still not updated from iPhone as usual. At least, iPhone’s data looked fine.

I wonder if upgrading iPhone’s iOS v16.7.2 to v17.2.1 will fix these issues since Apple won’t give me v16.7.4 instead of v17.2.1. I doubt it! Apple’s QA is really bad these days. :frowning:

I tried to sync in macOS’ safe mode, but that didn’t help. :(

Has anyone tried connecting to macOS’ Console app to get debug logs from an idevice to get clues? I tried to figure it out after this part with an iPhone 11 Pro Max with iOS v16.7.2 (will try v17.2.1 since Apple refuses to give out v16.7.4 :():

StatusMessage = “Syncing (Step 2 of 4)\nSyncing calendars”;

Lots of technical messages. I saw faults, errors, etc. like:

default 20:12:06.275517-0800 SyncAgent Created new REMXPCDaemonController {self: <REMXPCDaemonController: 0xbfc92c350 serviceName:com.apple.remindd>}
error 20:12:06.277461-0800 calaccessd Could not get application or bundle identifier for client (pid 2271).
default 20:12:06.278367-0800 tccd REQUEST: tccd_uid=501, sender_pid=1599, sender_uid=501, sender_auid=-1, function=TCCAccessRequest, msgID=1599.618
default 20:12:06.278947-0800 tccd AUTHREQ_CTX: msgID=1599.618, function=, service=kTCCServiceCalendar, preflight=yes, query=1,
default 20:12:06.279174-0800 tccd AUTHREQ_ATTRIBUTION: msgID=1599.618, attribution={accessing={TCCDProcess: identifier=com.apple.SyncAgent, pid=2271, auid=501, euid=501, binary_path=/usr/libexec/SyncAgent}, requesting={TCCDProcess: identifier=com.apple.calaccessd, pid=1599, auid=501, euid=501, binary_path=/System/Library/PrivateFrameworks/CalendarDaemon.framework/Support/calaccessd}, },
default 20:12:06.279284-0800 tccd requestor: TCCDProcess: identifier=com.apple.calaccessd, pid=1599, auid=501, euid=501, binary_path=/System/Library/PrivateFrameworks/CalendarDaemon.framework/Support/calaccessd is checking access for accessor TCCDProcess: identifier=com.apple.SyncAgent, pid=2271, auid=501, euid=501, binary_path=/usr/libexec/SyncAgent
default 20:12:06.281647-0800 tccd BUNDLE_ATTRIBUTION: attributed bundle file:///usr/libexec/ has no identifier and is not valid.
error 20:12:06.281722-0800 tccd IDENTITY_ATTRIBUTION: Refusing executable path (/usr/libexec/SyncAgent) which is not a bundle
error 20:12:06.281837-0800 tccd Unable to construct an identity to kTCCServiceCalendar, Resp:{TCCDProcess: identifier=com.apple.SyncAgent, pid=2271, auid=501, euid=501, binary_path=/usr/libexec/SyncAgent}
error 20:13:34.617758-0800 calaccessd Could not get application or bundle identifier for client (pid 1586).

I would upload my copied and pasted Console logs, but they had lots of sensitive data like addresses, names, SSIDs, etc. So, I just copied and pasted some lines related to Calendar. :(

Now looking at a Synology DS723+ NAS (or similar). It has both CalDAV and DLNA servers, and hot-swapable drives. Seems it could be a solution to a lot of things besides frustration w/ Apple’s Calendar syncing. Anyone have experience with them and their server interface?

1 Like

Yikes. Be careful with the macOS upgrades: https://www.reddit.com/r/MacOS/comments/193tmio/macos_monterey_automatically_updated_to_sonoma/,
https://www.reddit.com/r/MacOS/comments/19a4tsm/yes_apple_are_forcing_sonoma_updates/, etc. :(

And our own discussion:

The Reddit threads seem to have a very low signal-to-noise ratio. Looks like they consist mostly of people accusing each other of making stuff up - either claiming that the problem is purely user error or accusing those making those claims of being idiots. Which reminds me why I never bother with Reddit - all of the discussions seem to end up that way, although this one seems to have gone straight there from day-one.

1 Like

I have not noticed any relation to iOS versions in this issue. All of them have worked w/ Monterey.

…Until: Last night I recreated an external Sonoma volume with the latest (I had skipped the last two). Try to sync. At least it didn’t instantly crash the SyncServer process, but it did scramble my Calendars. So… booted back into Monterey to restore the mess, and Finder refused to open either device w/ a “An unknown error occurred (7004).” Both my iPhone and iPad are doing this when booted into Monterey. Sonoma; however, is still happy to mount them in the Finder and trash them even further.

I found lots of references to the 7004 error number, but no concrete info. Anyone here seen it?

Is there anyone up here who is local syncing (either USB or WiFi) Calendars or Contacts successfully with Ventura or later?

1 Like

Will B: I never had problems with Contacts in Ventura with two iPhones (13 and 11 Pro Max) via USB sync. Calendars never worked until I accidently wiped iPhone 13’s Calendar when messing with macOS’ Calendar data as shown in My Mac Apple-Calendar went berserk-I need help! - #53 by ant. Ever since that incident, its Calendar did sync correctly. I didn’t try it in 11 Pro Max since it was too risky to lose all Calendar data that got changed a lot.

I really wished there was a way to overwrite macOS’ Calendar (and Contacts) with iPhone’s. It only can only overwrite iPhones’ Calendar and Contacts with Macs’. :(

We ALL (I know some you already did like me) should contact Apple about these issues. The more feedbacks and bug reports, the better chances Apple will have to fix them.

Does anyone have any experience with this site? Is it legit? Uploading ones calendar is a pretty good chunk of personal info…

They refer to other Calendar validators, but I haven’t found any.

Thanks.

1 Like