Multiple Mail accounts in Apple Mail - moving messages failing

I’ve always used Apple Mail for my iCloud, gMail and Exchange mail in half a dozen accounts. I freely drag messages from one inbox to another folder for storage, and it used to always do the right thing, “moving” the message as I expected, even between different accounts from different hosts. But now it frequently fails to delete the message from the original folder. Has anyone else experienced this and found the answer?

Not that exact issue, but I’ve been seeing periodic short periods where I am unable to delete a message. Later the problem had gone away. On a few occasions, I saw reports on the Apple Systems Status page indicated that a problem with iCloud Mail had been resolved, so I’ve been attributing all such problems as being server related.

Also not the exact issue, but often I delete mails on one iOS device which never show as deleted on another iOS device, nor on the IMAP server itself. It appears Mail gets into a mode where deletions aren’t really deleted except in the one client’s inbox. Sometimes force-quit of Mail app changes deletion behavior (if force-quit actually happens - who can tell with iOS? (sarcasm)), but any previously deleted messages still don’t show on Mail app restart, although they remain on the server. I hate iOS Mail.

I’ve noticed a similar problem. When I tried to sign into iCloud - wasn’t available. I attributed it to that. I don’t think I have had problems deleting mail from other than my iCloud accounts. Gmail and other ISPs worked fine.

It has been happening less frequently but occurred once yesterday for a short time.


This may be the same issue I was asking about earlier (Big Sur Mail Rules) when I started testing Big Sur. In my case rules that have been working in Mail for decades to move/sort incoming mail into folders now copy those emails into the folders but leave a copy in my Inbox. Not the behavior I’m looking for.

Does it frequently fail to move, or does it always copy the messages between accounts?

I think the default behavior has changed to be in compliance with how IMAP is supposed to work, where ‘moving’ in the same account space moves the messages and moving them elsewhere only copies.

But Honestly, I haven’t tested this and moving messages between accounts is something I nearly never do, but it seems to be how it’s been working.

It seems to always copy, but doesn’t always delete. However, it seems to delete on the machine where I “moved” it, but not necessarily on other devices. I probably need to log the exact behavior for a day.

I occasionally see this as well. I assume that the computer failed to send the IMAP request to the server for some reason (probably network congestion), so the change happened locally but wasn’t reflected on the server.

Still a bug - if there was a problem like that, the app should report it and queue up the request to retry it again later, but I haven’t seen that happen.

I make the same observation every once in a while on both iOS Mail and macOS Mail. Usually in connection with work email (Gmail). I am under the exact same assumption as to the cause of this odd behavior. And I agree, if so, it’s a bug.

Right now, iCloud is having problems - I can’t sign in. Not a prob with my password. At the same time this occurred, I couldn’t move messages in mail.

As soon as iCloud came back, I (of course) could move messages again. It’s back up. Does anyone know why it has been having problems lately? I’ve used it for years and it has just been the last few months that iCloud (in my experience) has been having problems.

iCloud has always suffered from brief periods of funk. I would say it has perhaps been a bit more frequent lately, but it certainly is nothing new. IMHO the worst part about it is that you don’t always see confirmation on the iCloud status page. If I knew Apple knew, then I’d just let it be and come back later.

FWIW The problems I’ve had with IMAP messages not being seen as deleted on all clients occurs both on iCloud and my local ISP. Implies to me it’s more likely not a server problem.

Definitely not a server problem - or at least not isolated to Apple’s servers.

I don’t use iCloud mail - my e-mail is Google, Yahoo and I’ve seen this problem (message move/delete operations not always pushed to the server) on all three.

At least on iOS. On my desktop/laptop computers, I use the web interface to my mail providers, so I don’t know if on macOS does the same thing.