Monterey 12.6.7 and Touch ID

After updating to Monterey 12.6.7, Touch ID stopped working on my 2021 M1 16" MacBook Pro. I do not know if these two events are connected. All attempts to re-register fingerprints fail; almost instantly after clicking the Add Fingerprint icon, a message appears saying “Failed” and “Unable to compete Touch ID enrollment.” I have restarted the computer a number of times, cleaned my fingers and the sensor, etc. Is this a known issue? Any ideas how I might regain this capability?

Sometimes you have to move backward to move forward. I’m wondering if you’ve tried going into Preferences and turning off TouchID completely. I’d do that, restart the Mac to clear any buffers, and then set up TouchID from scratch.

Another possible troubleshooting step is to set up a new user account on your Mac, and see how setting up TouchID goes with that account. If it works, then it is an issue with how your main account survived the update.

You may have already tried these things, but if not, they’re worth pursuing. I was going to suggest a third path, which involves changing the password on your main account, but I’d be cautious with that one because if there are issues with security, the password is currently your only way in to the account.

Good luck!

Thank you. I have turned off Touch ID and restarted numerous times to no effect. The new user account idea was interesting but, sadly, it did not work; however, I guess that that might suggest the problem is not with my account per se, but with either the software or the physical button. I could, of course, try updating to Ventura, but I have been holding off for some reason. Maybe it is time…

Mmmm. I don’t think that mass reports of TouchID failures with the Monterey update are rampant.

One rule of thumb (so to speak) is that if a feature doesn’t work in a given major version of MacOS, upgrading to the next major version is not necessarily going to fix the problem.

I hesitate to tell you to try a clean install of Monterey, both because it sounds so Windows-like and because you have to find an installer for it. My spouse’s M1 MacBook Air has TouchID and has not experienced issues similar to yours through various updates.

Have you tried running hardware diagnostics?