Microsoft Office for Mac 16.19


(Agen Schmitz) #1

Originally published at: https://tidbits.com/watchlist/microsoft-office-2016-16-19/

Adds the capability to search the Web for images from within a document. ($149.99 new for one-time purchase, $99.99/$69.99 annual subscription options, free update)


(Alan Ackerman) #2

How do I get Office for Mac 16.19 or Office 2019? I went into Word and selected Help -> Check for Updates -> Check for Updates and got “There are no updates available for your Macintosh software at this time. Please check again later.” I have Version 16.16.4 (181110).

24%20PM|690x242


(Tom Gewecke) #3

What version of macos are you running? If not the latest, that could be the reason.


(Alan Ackerman) #4

Mojave. MacOS 10.14.


(Al Varnell) #5

What version of Word are you running? You need to have a valid subscription to Office 365 to get 16.19 and purchase Office 2019 Home & Student or Home & Business to get those updates.

-Al-


(Curtis Wilcox) #6

Yes, you have 16.16.4 (18111001) which is the most recent version of Office 2016 for Mac. There may be some separate security updates in the future for it but to get 16.17 or newer, updates to Office’s features, you either need to purchase Office 2019 or get an Office 365 subscription.

BTW, the Office system requirements for say Office 2016 is supported on “Mac OS X version 10.10 or later” and for Office 2019 say “the three most recent versions of macOS” which currently are Mohave 10.14), High Sierra (10.13) and Sierra (10.12). When 10.15 comes out, support for 10.12 will stop but I doubt the applications won’t work, they just won’t be tested.


(Robert Brenstein) #7

I had version 15.x for a long time. Automatic updates were not happening and manual check would tell me sometimes that no update is available or mostly that update server is not available. Thanks to this thread, I did a manual check today and it offered me to update the autoupdater. The new version of the updater offered me the 16.16.4 update. So, I am finally up to date. I have no claims for a newer version. I am posting this because there may be other users stuck like myself.

Robert