Messages Images Not Syncing

I have been a big fan of Apple’s Messages and it has worked incredibly well for me for years. But suddenly all is not well.

For the past couple of months, I’ve been encountering nothing but problems with images not syncing between devices. This is so random and inconsistent, it’s driving me crazy, and searches on the internet for solutions show others have the issue, but there’s no clearcut solution.

The symptoms of this are this: I have 3 main devices (Mac, iPad, and iPhone) and when I send/receive a Message with an image, the other devices will show a blank message icon. Sometimes it will show “downloading” but nothing ever downloads. Other times the button says “download” as though clicking on it will start a download, but nothing happens. Worst of all, many times I get a name of the image (“image.jpeg”) with no way to view it.

What’s really annoying about this issue is that I never know which device will have the actual image on it. It’s as though whichever device is the first to download it succeeds and then the others all fail. So sometimes my Mac has the image. Other times it’s the iPhone or iPad. It’s really bizarre. It’s frustrating because if I’m on my Mac I want to reply to Messages there, but I can’t see the image – I have to go find my phone or iPad to see it.

Most recently – the last couple of days – I have a new problem that’s even more annoying. Suddenly my iPad sees all messages from my other devices as failing to send. So I get big ugly alert messages on the iPad, as well as exclamation points next to messages in Message. This is texts as well as images. Yet these are all messages that have gone through. People have replied to them, so I know they were sent. But for some reason, the iPad thinks they have failed. If I try to send them again on the iPad, they fail again.

For a system that worked flawlessly for years, I am baffled and annoyed. I’m about ready to turn off Messages on all but one device just to halt the confusion. (For what it’s worth, Mac is Monterey, iPhone and iPad are on latest OS.)

I have no idea if this is a problem with iCloud, my internet provider, or something else, but I’m wondering if others have seen this and have any ideas for solutions.

Things I have tried:

  • rebooting
  • toggling wifi (sometimes helps)
  • clicking “download” button on Messages conversation (that button has disappeared on my Mac lately, but it did work a few times)
  • toggling Messages on iCloud

Some have suggested signing out of iCloud and back in, but that causes so many other issues, I’m not wanting to try that. The same with upgrading Mac to Ventura. (Also, I don’t think Monterey is the problem as this happens between the iPad and iPhone, which are both running the latest OS.)

I have not yet contacted Apple – my experience the last few years is their support is pretty worthless on anything actually complicated.