Major OneDrive changes: PSA

Hi to all (any?) OneDrive users on TidBITS. I spent a few hours today learning what happened to my OneDrive folders, whether they are still being backed up, and how to ensure they are always fully present and (hopefully–more on this later) backed up on my Mac. So I thought I would document what I found here (1) to help out, but also (2) so I can be corrected in case I’m missing anything.

Recently (I think today) I received the OneDrive update that converts to using Apple’s File Provider platform. This had the following impacts. The new version, which requires APFS, is mandatory on Monterey 12.3 and above:

  1. My three OneDrive folders were completely moved, without my permission, to a mysterious new folder (OneDrive with a cloud icon) accessible in the Finder sidebar under Locations.
  2. About ten of my Finder sidebar Favorites icons disappeared as they were pointing into folders stored in OneDrive.
  3. Files On-Demand is no longer an option in the OneDrive preferences. This meant that OneDrive had already completed the process of removing my files and leaving only stubs, with the side-effect that my Time Machine and CCC backups would no longer back up my files.
  4. The folder and file icons have changed and are not documented on Microsoft’s help pages yet. This adds to the anxiety of not fully understanding whether a file or folder is kept on the Mac and therefore backed up.
  5. All Finder tags in the OneDrive folders were obliterated.
  6. You can no longer trash a file from a OneDrive folder. Instead, it will pop up a dialog saying it will be immediately deleted if you proceed.
  7. The new feature requires APFS. You might relax if you still use HFS+, except OneDrive will simply not run on 12.3 or above unless you have APFS.

I was freaked out as you might imagine, but have managed to undo all the damage, I think, although I have some more work to guarantee that Time Machine and CCC backups will work.

(By the way, I use OneDrive because it enables the Office 365 Autosave feature, in case anyone’s wondering).

Solutions to the above issues:

  1. I first confirmed that Time Machine and CCC are indeed backing up the semi-hidden folder that contains the OneDrive data. That folder is in the following location: ~/Library/CloudStorage/OneDrive. There is a nagging worry about a cache folder, explained in the penultimate paragraph of this post.
  2. I had to manually recreate the entries in the Finder sidebar (under Favorites). Oh well.
  3. To turn off what used to be called Files On-Demand, i.e. to ensure that local copies of all data in the OneDrive folders is always kept local, available for offline use, and (hopefully—more on this later) backed up, I had to right-click (control-click) each of the three OneDrive folders and select Always Keep on This Device. This propagates to all the subfolders, including subfolders added in the future. All folders and subfolders now appear as fully downloaded. I copied a 500 MB folder to a different location and it had an identical size–I think the Finder integrates with OneDrive to ensure the data is copied even if it’s stored on the mysterious cache folder mentioned in Microsoft’s detailed post (next item).
  4. The new Finder icons are documented here, and there’s a detailed post here.
  5. Thankfully my uses of Finder tags are transient and so I didn’t care about this. You might though.
  6. I guess I can live without the trash as long as my backups are working properly.

Speaking of which, I have one big worry remaining. Although I have forced all the folders to be local, OneDrive does some not-well-explained stuff with a hidden cache folder. It’s not clear to me that backing up the ~/Library/CloudStorage/OneDrive folder can be counted upon for recovery purposes, even though all subfolders in there have been marked “Always Keep on This Device”. More info on this topic can be found in the detailed post mentioned earlier… For what it’s worth, though, I checked the backup size for the folders and they match the current size of those folders.

If I can’t get to the point where I’m confident my files are always being backed up properly by Time Machine and CCC, then I’ll have to move off of OneDrive and forego the Office 365 AutoSave feature.


Thanks for this post. I’m not home so won’t see this until I get back, but I may not have even noticed without seeing your post. I do like to have my full online sync accounts on my Mac so I can back up files, so I’ll have to make sure that mine is set up properly. (That said, I still have OneDrive installed on a Mac Mini running Mojave, so maybe I’ll be all set for that purpose anyway.)

Sounds like the changes are a part of an announcement about changes to macOS:

Apple is providing/changing a system framework for implementing online-only files, and other mechansims will stop working in macOS 12.3. So all cloud storage providers (including DropBox and OneDrive) need to update their client software.

In your case, you explicitly want to keep all your files locally, so it shouldn’t matter, but I think this is the reason for the changes.

Thanks, Richard. Apparently, Microsoft rewrote Ond-Drive because the method it used up till now for online-only access to OneDrive files will not be available in the next major Monterey release (12.3). However, in doing so they removed the switch to preserve keeping copies locally. This messes up backup programs like Carbon Copy when they try to back up the collection of folders on OneDrive, only to find pointers to the cloud.

To assure that there is a local copy of the contents of OneDrive, you must open the OneDrive folder, select all folders, control-click on the collection, and, under Quick Actions, select ‘Always Keep on this Device’. You must then select the Download from the Cloud icon for each folder and click it to actually download the contents.

With luck, this will actually work. I had problems with one non-vital folder on my desktop computer and deleted it via the OneDrive app. I also made sure to remove it from the OneDrive recycle bin to make sure it was totally gone. The CCC clone that I ran after doing that was error-free.

1 Like

Apple confirms.

It’s not critical for me since I typically use Mountain Duck to access OneDrive files, so I haven’t tried opening OneDrive for some time (I’m running OS 12.2, OneDrive is at 22.012.0116). I don’t have case sensitive formatting. When I open this version of OneDrive (and the last 2 versions, for that matter) I am prompted to select a location for a OneDrive folder. However, no matter which location I seem to choose, I keep getting this message:
Screen Shot 2022-02-02 at 2 3.17.54 PM
Anyone else getting the same message who has found a solution?

Is it on your startup drive? The new OneDrive doesn’t allow a folder anywhere on the startup drive except in the standard location.

EDIT: For more info see the sections “Sync root location”, “Cache path”, and “Using another volume” in this post. Reading through the five pages of comments on that page is an eye opener. I’m glad I am just using OneDrive for personal use–it’s been a real disaster for folks with large data volumes and/or supporting many users.

1 Like

Yes, I’ve tried multiple locations, completely deleting the app and all related files, reinstalling, both Apple Store and Standalone versions, all without success. I suspect there’s some hidden file sync issue going on, since when I have a preexisting OneDrive folder it is always renamed “OneDrive 2”. Thanks for the link to the post - it sounds as though Microsoft has many issues to work out. I’m giving up for the moment and hope that they manage to fix the issues.

When you say multiple locations, do you mean on an external non-startup drive?

No, all on startup drive, various locations inside and outside ~/ folder. In the past, the folder did reside on an external drive, but I let the new app try to install in its default location first (failed), moved the old folder to the default location (failed), deleted the folder and app and it’s associated files Uninstall, reinstalled app (failed). Especially with the renaming of the OneDrive folder when the failure occurs, it seems as though there may be some retained preference to the external drive location formerly used. Searched for the hidden cache folder mentioned in the links you sent, does not appear to be present. Maybe Microsoft will come up with a complete uninstaller and after its use things will work as expected.

I did make it home, and the app did update, and after a few tries, I was able to get most of my folders downloaded. The symlink that was installed in my old location in my home folder also seems to allow Arq to backup the files (though I didn’t have time to fully test that.)

I do like that these apps won’t be using kernel extensions anymore. After recently switching to Maestral for my Dropbox syncing because I was annoyed that the Dropbox app kept asking for admin permissions, I may switch back to the stock Dropbox app if that won’t be happening anymore.

But, back to OneDrive, I’m traveling again this weekend and finding that one of my spreadsheets (my daily exercise log) is not updated. The Office app shows it in my Recent files section, but browsing through OneDrive, the file isn’t even showing up. So now I’m annoyed at that. This isn’t the first time that I’ve had issues with files not showing up in OneDrive or being browsable in the Office app, either. Even iCloud is better than OneDrive for me on iPadOS and iOS.

I may end up switching all of my office files to iCloud or Dropbox and just retrain myself to manually save files (the one advantage to storing files on OneDrive is that the Mac apps auto save them.)

Hi John. If you want your OneDrive on your startup drive it has to go in the standard spot. But I see from your post that failed. Maybe try creating a OneDrive folder inside ~\Library\CloudStorage, but I suspect that won’t work. I wonder if it’s a permissions problem. Perhaps contacting Microsoft Support will help. I had better luck with email support than on the phone, but YMMV.

As for searching for the cache folder, Microsoft uses a special suffix (I think it’s .noindex) that means search won’t find it. However, at least one commenter on that blog has identified where it is stored.