Mail refuses to show email in Sent if I am both sender & recipient


(Simon) #1

So I’m wondering if this is intended behavior or just a bug in Mail.app. I’ve noticed emails I know I have sent to be missing in the Sent folder. Turns out those emails do show up, but only in my Archive. It appears whenever I send an email for which I am also a recipient (eg. sending an email to a bunch of people as BCC: with only myself in To:) Mail will at first show it in Sent, then once it arrives back on my Mac it will also show up in Inbox, and finally, when I move it from Inbox to one of my archive folders that’s the only location I’ll be able to find it. The copy in Sent is gone. This is using IMAP.

Two things I’ve observed while trying to figure this out is that the copy in Sent will not disappear if I move the email from my Inbox into Archive instead of a specific IMAP folder. The Sent copy also seems to stick around if there’s only one recipient in BCC and myself in To. If I put several people in CC with myself in To I will observe the missing copy in Sent.

Is this really intended behavior or is it a bug? Is it caused by a specific setting I have inadvertently chosen? Or is this some kind of server-side shenanigans? It’s IMAP, but work so unfortunately not my own mail server. Come to think of it, since it’s work it’s also gmail so not even real IMAP, but rather whatever Google has morphed IMAP into.


(Curtis Wilcox) #2

Yes, I think this is quirk specific to using a Gmail account (or Gmail with Apple Mail, I never use it with anything else). I have the Archive/All Mail hidden so I don’t know what it looks like.

It’s annoying because I like sending emails to myself as reminders. My workaround is to use my work account to send such emails to my personal (Gmail/G-Suite hosted) account. It also ignores the fact that the email-as-sent may not exactly match the email-as-received.


(James R Cutler) #3

Sometimes, this Terminal command helps:

defaults write com.apple.mail _AlwaysShowDuplicates -bool true

(Mark McKean) #4

It’s Gmail. I confirmed this some years ago when messages I would send
to mailing lists stopped appearing in my Inbox.

At that time, the behavior manifested as keeping the original in Sent
and not showing the received copy in the Inbox. Google’s argument for
doing this was that they’re saving you from having duplicate emails in
Sent and Inbox. They’re incorrect about it being duplicated, though.
Many mailing lists append additional information to the end of the
message when it goes through their server, so the message that you
receive is not identical to the message you sent. When I presented
evidence of this to Google, as part of a request that they allow users
to opt-out of that feature, their response boiled down to, “We don’t
care.” (Given that I didn’t expect them to respond at all, even that
much should probably be considered a win.) It would seem that they have
since modified the behavior after all, in a way that would resolve the
issue I had with it.

I suspect that the reason it behaves differently when you manually
Archive the message is that Gmail doesn’t actually use IMAP folders;
they use tags to indicate that a message is supposed to be considered as
in a particular folder. Archive is one of a handful of exceptions that
represents an actual IMAP folder. Inbox and Sent are not exceptions. I
can’t account for the discrepancy you’ve described between having one
BCC versus having several, though.

Google wants people to believe that Gmail is fully IMAP-compliant, but
it’s not. It never has been, and it never will be. Full compliance would
break some of their “features” that allow them to monetize the free
service. This, of course, causes odd behavior in IMAP-compliant clients
when using Gmail with them, but Google doesn’t care. They don’t want you
to use a local client; they want you to use Gmail on the web, to provide
them the maximum opportunity for monetization.

Mark D. McKean
[email protected]


(Simon) #5

Thanks for the confirmation, Curtis & Mark. Good to know it’s not something screwed up on my end.

Mark, I’m also puzzled by the bit about depending on how many recipients are in the To: field. I wonder if there’s some other variable I’m not controlling that really explains it. I cannot imagine the number of recipients should play into any of this. I’ve known that gmail IMAP isn’t IMAP and I recall a nice TidBITS article about that not too long ago. It’s caused a lot of grief. I realize what Google is trying to push, but hell will freeze over before I use Safari to check my email (it’s not at all just their recent web client redesign). That’s like trying to take your F-150 onto the golf course instead of using a cart. :wink:

A pity Google cannot wrap their heads around the fact that the sent and received email are not at all necessarily identical. This is work email and the UC system has tied itself to Google so I cannot opt out of this. On the bright side, the alternative would have been Outlook and Sharepoint, and I’ve been through that bag of hurt before. :smiley:


(Simon) #6

Thanks, James. I actually already had that set.

I’m afraid this is server side shenanigans so there’s nothing I can do about it locally. Good to know though that it’s not some weird Mail behavior.


(Doug Miller) #7

I do use GMail’s web client myself, because I find it a lot more efficient than using Apple Mail. (To mark a series of messages to delete, x to mark them, down, continue until you have marked the messages, type Shift-3 to delete them all. Or press “e” to archive them all. Or press “L” and then type a label to put messages in a label/folder. I can do this all without touching a mouse or trackpad.) And, of course, only Gmail’s web interface and apps separates crap mail into Social, Promotions, Updates, and Forums, so that I can deal with that stuff later and only see important email in my Primary mailbox. In Apple Mail, that’s all gathered together.

However, I’m not necessarily trying to convince you to give the web interface another shot, but I have to say that I do not have the problem that you mention at all with Apple Mail on MacOS. When I archive a message/conversation from my in box, my sent messages remain in the Sent mail folder for my Gmail account in Apple Mail.

Have you tried turning off “Include related messages” in Viewing preferences of Apple Mail? I have that off and maybe that will fix that problem?


(Simon) #8

Thanks, Doug. I did indeed try to turn that setting off. No change. Restarted Mail, still no change.

Since I can see that the email is missing server side (IMAP sent folder on gmail) I assume that regardless of what I tell Mail to display, the email that’s not on the server in Sent, won’t show up in Mails’ Sent.

But now I have to ask, what does the “Include related messages” setting do anyway? My email windows have a button to allow me to toggle showing related emails in the same window. At first I thought this was some kind of gloal setting to enable/disable this, but the button does exactly the same thing regardless of this setting. It’s not setting the default view for me, so what does the setting achieve?


(Doug Miller) #9

Second question (and then I’ll stop.) In the account settings, “Mailbox Behaviors” page, what do you have set for “Sent Mailbox”? A local folder, or is it set to “[Gmail]/Sent Mail”? (And is “Archive Mailbox” set to “[Gmail]/All Mail”?)


(Simon) #10

The Sent maps to Gmail/Sent, but for Archive I map to Archive on the IMAP server rather than Gmail/All because I have hidden All. All was just a bag of hurt in conjunction with Mail and IMAP. I actually thought the advice to hide All originally came from a TidBITS article or a post on this board. Couldn’t find it though with a quick search so maybe I’m misremembering.


(Simon) #11

Found it. It’s both in this old TidBITS article as well as this much more recent post by @gastropod.


(Doug Miller) #12

So try setting the archive folder to the default and see if that solves the sent mail being archived problem. (Because I think it will.)

Haven’t read gastropod’s post, but that Tidbits article that you linked is old, and says so right at the top. The only changes that I make to defaults is to change the Drafts folder to a local folder on my system, because otherwise the Gmail server based Drafts folder fills itself with multiple drafts that never get cleared.


(Simon) #13

Which “default”? The drop-down menu shows “Archive” at the very top followed by my whole gmail tree. Of course Gmail/All is not listed there, because I’ve set it to hide that as per @gastropod’s instructions.

The article is very old indeed, but as we established in recent discussions here, not all the advice there is obsolete.


(Doug Miller) #14

Yes, I am suggesting that you ignore the advice to hide the All mail folder/label and use it as the archive mail location in Apple Mail. I have a couple of Gmail accounts set up that way and I cannot replicate the sent mail being removed from the system sent mail folder when you archive message threads in Apple Mail.

Another solution would be to try a third party mail app for the Gmail account(s). I haven’t used Postbox in a while, but I remember it being very Gmail aware (though not free.) I’m really not up to date on any other mail apps for MacOS (Spark?) and how they work with Gmail accounts.

As for the Tidbits article, it says right at the top that leaving the settings at the defaults


(Adam Engst) #15

To be more precise, Gmail’s IMAP support is bolted on top of the service to help those who wish to use IMAP clients instead of Gmail’s native interface. Google is doing IMAP as a favor and has never pretended that it was fully compliant or wanted it to be. And Gmail itself isn’t about monetization; it’s about bringing people into the Google ecosystem (where other monetization will happen eventually). That’s why, even back when Gmail did have ads, they were very easily avoided both in the Web interface and completely if you used IMAP.