Mail choosing wrong sender address

I have noticed this problem before but got a bit closer to understanding what’s happening. I don’t know what to do.
I use Apple Mail and have two accounts. One is my local isp and the other an iCloud account.
As far as I’m able to discern, when I open Mail and compose a new email, my sender address randomly and only occasionally indicates that sender address as coming from the iCloud account.
For what it’s worth, I never intentionally use that account.
Today when I sent an email it did not appear in my isp account’s sent list (which does show other messages sent this morning). I was concerned that I’d made some error in an important message that I’d sent moments earlier. Eventually I looked in the sent folder in the ‘On my Mac’ section and found it there with the sender indicating the iCloud account. There were also another 5 messages sent over the last couple months.
Not to drag this out, but, a couple messages, to which I had expected replies that never came, were in those 6 messages.
Any ideas?

I have seen this happen as well, but think I’ve discerned a reason. I usually have the combined (all accounts) Inbox open when Mail is open. When I then create a new outgoing message, Mail appears to use the account of whatever inbox message is currently highlighted as the outgoing account. Perhaps this applies to your case?

1 Like

Dana, That doesn’t seem to be my problem. Testing your suggestion, I had All Inboxes open and displaying the isp inbox and the icloud inbox. Twice I tested sending a message with the icloud inbox high lighted and in both instances I found them in the isp sent mailbox with the sender address my isp address.
What a puzzle.

The sending default sending address for a new email is controlled by a Preference in the Composing section of Apple Mail Preferences. The default for replies is the address the original email was sent to.

Note that in either case, you can change the address by tapping the contents of the From field on the message being sent. It turns into a dropdown showing all your potential sender addresses/


Thanks, Alan. I found the setting in Mail Preferences set to ‘Automatically Select Best Account’. I’ve now set it to my preferred address.
Since the software was choosing the ‘best account’, perhaps that explains the apparently random and occasional discrepancy.
It may take a month or so to see whether this works but it sounds very plausible. Thanks very much.

A new feature from Apple - random choice of email addresses to add excitement to the experience.

I was aware of the second sentence. I was not aware of the first sentence. Thanks.

Having said that, if I save and close a draft (where the From address is correctly set to the message to which I am responding), all bets are off; when I reopen the draft, Mail has too often changed the From address, with no pattern that I can discern (but usually to my iCloud address).

I have tried (with some success) to train myself to check the From address before I Send. It’s a poor solution, but it’s better than anything else I’ve found.

For what it’s worth, I do not recall ever finding a sent message in On My Mac unless I put it there.

At some point, I removed (possibly deleted) On My Mac. If I wanted to check it for messages (it should be empty), how would I restore it?

That sounds like a bug I had encountered in the past too (no longer with Monterey though).

On earlier macOS versions, when I saved a draft and then later re-opened it (or when I did a Send Again), it would always show a different sending account in its the compose window’s drop down menu compared to what I had originally had (my default compose setting is to always use a certain account). I even asked about this bug right here a long time ago.

Long story short, I never found a solution. I did discover at one point though, that regardless of what account it said it was going to use in the compose window’s drop down menu, it nevertheless always ended up using the one I had originally selected (or rather the default setting dictated) when composing the original draft. It was confusing, but ultimately appeared to be a bug in terms of what Mail displayed being inconsistent with what Mail then actually did. At least for me. It did the right thing, but confusingly displayed the wrong thing.

This is not really a “new” feature. That setting has been there for so long, I cannot remember when I started setting it to the primary account for all my users. Typically, an admin staffer can have as many as 5 accounts in Mac Mail. 1 to send from, the others to monitor and update other staff. What drives me crazy, is I have to remember to make that setting for each new user and Mac. I only wish it were the default setting!

That’s good to know, although I believe that at least once Mail did send it from the wrong address. Unless I’m remembering incorrectly, that’s how I first became aware of the issue.

I will point out that I have compose set to default to one outgoing account. It’s possible that’s what’s saving me here. I’ve never tested changing that compose setting to automatic to see if Mail then actually sends it using the wrong outgoing rather than just showing it.

I have “best account” which these days seems to work for me although I do need to keep an eye on where it is trying to send new messages from. This is a lot better than when Apple first introduced “best account” where it seemed to mean match the domains. So if you had a Gmail account and were sending to a Gmail address, it would want to send from the Gmail account since those few milliseconds saved in how soon the recipient would see your message were much more important than having the recipient see it coming from an address they knew.

Unfortunately, like much that comes out of Cupertino, what exactly “best account” does is undocumented because with Apple, “it just works” unless it doesn’t.

1 Like

The new motto is “it only just works!”
In the Mail preferences you can disable an outgoing email account and choose your preferred account. But, of course, you have to temporarily change that preference to use the first account.

Don’t forget that if you tap the address field after the ‘From:’ header, it turns into a dropdown field allowing you to select an address from any enabled account. The borders indicating a dropdown list don’t appear until you tap the text that is already there.