macOS Recovery cannot write installation information to disk

macbook air 2015.

I have deleted Macintosh HD accidentally. OS/x recovery gives various errors. Disk Utiity sees only Apple disk image / OS/X base system.

I have no useful info on this disk. Is there a method to get diskutil (or some other utility) to simply reformat and restart whatever is needed on the ssd drive?

All I want to do is get this bootable so I can trade it in.

here’s what diskutil list shows.


Someone here may override me on this, but I would say to just reboot your MacBook in recovery mode – command-r – and do a total reinstall. Shut down your machine first, and do a cold start.

MacOS Recovery is looking for a system disk and failing. Have tried gui diskutil first aid multiple times. no help. Must have a system partition for macos recovery.

check out apple support web page.
I have tired everyting on tis page and every linked page.

If your Mac starts up to a question mark - Apple Support.

Sorry, my friend, but I am unable to help you more than that. Maybe someone here with more experience will join in and help you.

I think the trick will be to start macOS Recovery over the Internet, which downloads the necessary data to reformat and reinstall.

  • Option-Command-R: Start up from macOS Recovery over the internet. Use this key combination to reinstall macOS and upgrade to the latest version of macOS that’s compatible with your Mac.
1 Like

Adam, that is actually what I meant for him to do. But it seems I got the command wrong. OOPS! :smiley:

1 Like

Ok folks. Thanks for reading but recall from my post…
I have tried ALL suggestions from Apple’s pages for booting with no disk and NONE work. NONE!!!
Repeat, Disk Utility and all version of Recovery start have been tried to no avail.
NONE work!

On to other possibilities. I’m thinking target disk mode might let me format this macbook air if I can get it to appear on my Macbook Pro in target disk mode. But none of the cables I have are working or this is possibly not possible if the mbp does not recognize the disk. But I’m tring to make it work and here’s details about tdm and cables. Anyone know where I can get one of these puppies.

quote
Apple’s revised information lists two scenarios, depending on the cable:

  • With a USB 3.0 or 3.1 USB Type A to USB-C cable
  • With a USB-C to USB-C cable (with 3.0 or 3.1 support)

Apple notes helpfully, “These cables are not currently available from Apple.” Alas, the USB-C cable that comes with the MacBook only supports USB 2.0 data rates for syncing, and USB 3 is apparently required.

end quote

Read that carefully: USB 3. Not 2. The good news is that the old cranky mabook air 2015 DOES support usb A 3.0. Whew! Now if I can find one of thosse somewhere. I know there’s some company in California that’s suppsed to carry odd cables. Anyone got a recommendation?

Here’s the whole article:

I’m surprised that diskutil doesn’t seem to be listing a physical drive, but maybe things are different with an older OS.

Since you have another Mac, I would try creating a bootable installer on a USB flash drive and seeing if I could get any further with formatting the drive with Disk Utility from there. I’d also favor an older compatible version of OS X for that, e.g., Yosemite or Sierra.

As a last resort, I’d try booting from a Linux or Windows USB installer. Perhaps by repartitioning using one of those operating systems, you’d then be able to use a Mac installer to start over.

What version of macOS are you trying to use here?

I second what @josehill says, since you have another Mac, build a bootable USB Monterey installer using information from Apple’s support article:

Personally, josehill, I’ve always considered Disk Utility a lightweight toy compared to some of the other more hefty, commercial disk recovery products that have been sold over the years. As far as Disk Utility not listing a physical drive, actually, I have a similar problem right now which has persisted for months.

Basically, something happened to one of my external USB backup drives a while back. Despite my best efforts, I cannot get it to mount on my Desktop, or to list in Disk Utility. But what is odd, is that occasionally I will get a notice on my screen stating that an external drive has not been unmounted properly. So the OS does know that it is there, but it won’t allow me to repair it, if it is even possible at this point.

Yup, a bootable installer for macOS is a godsend.
You can even partition a hard drive and create several of them.

When you say you accidentally deleted OS X, how exactly did you do this? Was the machine booted from another drive and you formatted/deleted the internal?
I’m struggling to see how you could delete the OS if it was booted from it?

Good question to which I have no answer. I remove “Macintos HD” and it’s all downhill from there.

OK, so I have checked out hte article on creating a bootable drive, howerver it seems I’m stuck.

My macbook pro, Apple M2 Pro, runs Ventura 13.6. My macbook air 2015 was delivered with El Capitan (I think) and later upgraded to Monteray which is the last version supported. So I downloaded the macosx installer for ElCapitan but it won’t open the dmg file nor allow me to download it from the app store. Either I’m doing something totally wrong or just don’t understand the instructions.

Any help appreciated. Next step is a unix bootable usb drive.

John

booting to umbutu works.

Any suggestions on what to do to the mac disk presuming I can find/see it?